summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-03 12:22:27 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-03 12:22:27 +0200
commit6be958bad01e2614b46204dcb06fb5f3149956eb (patch)
tree5b1d892aef61cba8cccc399718171764fd94f5d3
parentc230ad20123b11af6c2c111d3f6759c322f6715d (diff)
PHP 7.1.0beta2
-rw-r--r--failed.txt23
-rw-r--r--php-5.6.3-datetests.patch23
-rw-r--r--php-7.0.10-datetests.patch68
-rw-r--r--php71.spec9
4 files changed, 83 insertions, 40 deletions
diff --git a/failed.txt b/failed.txt
index 1521f28..5f0a47c 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,26 +1,21 @@
-===== 7.1.0beta1 (2016-07-21)
+===== 7.1.0beta2 (2016-08-04)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/el6i/build.log:Tests failed : 5
-/var/lib/mock/el6x/build.log:Tests failed : 4
-/var/lib/mock/el7x/build.log:Tests failed : 4
+/var/lib/mock/el6i/build.log:Tests failed : 4
+/var/lib/mock/el6x/build.log:Tests failed : 2
+/var/lib/mock/el7x/build.log:Tests failed : 1
/var/lib/mock/fc23i/build.log:Tests failed : 3
-/var/lib/mock/fc23x/build.log:Tests failed : 2
+/var/lib/mock/fc23x/build.log:Tests failed : 1
/var/lib/mock/fc24i/build.log:Tests failed : 3
/var/lib/mock/fc24x/build.log:Tests failed : 1
-el6i, el6x, el7x, fc23i, fc23x, fc24i, fc24x
- gzfile() with various invalid params [ext/zlib/tests/004-mb.phpt]
-el6i, el6x, el7x
- Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
+el6x,
+ Bug #70198 Checking liveness does not work as expected [ext/standard/tests/streams/bug70198.phpt]
el6i
Test mt_rand() function : usage variations - different data types as $max argument [ext/standard/tests/math/mt_rand_variation2.phpt]
-el6x, el7x
- strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
- Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
-fc23x
- Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
+el6x, el6x, el7x, fc23i, fc23x, fc24i, fc24x
+ ** Test base64_decode() function : basic functionality - padding and whitespace [ext/standard/tests/url/base64_decode_basic_003.phpt]
el6i, fc23i, fc24i
Test rand() function : usage variations - different data types as $min argument [ext/standard/tests/math/rand_variation1.phpt]
Test rand() function : usage variations - different data types as $max argument [ext/standard/tests/math/rand_variation2.phpt]
diff --git a/php-5.6.3-datetests.patch b/php-5.6.3-datetests.patch
deleted file mode 100644
index a29bb63..0000000
--- a/php-5.6.3-datetests.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/ext/date/tests/bug66985.phpt 2014-10-30 07:32:03.297693403 +0100
-+++ b/ext/date/tests/bug66985.phpt 2014-10-30 07:32:45.138877977 +0100
-@@ -3,7 +3,7 @@
- --FILE--
- <?php
- $zones = array(
-- "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "Factory", "GB-Eire",
-+ "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "GB-Eire",
- "GMT0", "Greenwich", "Hongkong", "Iceland", "Iran", "Israel", "Jamaica",
- "Japan", "Kwajalein", "Libya", "MST7MDT", "Navajo", "NZ-CHAT", "Poland",
- "Portugal", "PST8PDT", "Singapore", "Turkey", "Universal", "W-SU",
-@@ -45,11 +45,6 @@
- )
- DateTimeZone Object
- (
-- [timezone_type] => 3
-- [timezone] => Factory
--)
--DateTimeZone Object
--(
- [timezone_type] => 3
- [timezone] => GB-Eire
- )
diff --git a/php-7.0.10-datetests.patch b/php-7.0.10-datetests.patch
new file mode 100644
index 0000000..c3a65e9
--- /dev/null
+++ b/php-7.0.10-datetests.patch
@@ -0,0 +1,68 @@
+--- a/ext/date/tests/bug66985.phpt 2014-10-30 07:32:03.297693403 +0100
++++ b/ext/date/tests/bug66985.phpt 2014-10-30 07:32:45.138877977 +0100
+@@ -3,7 +3,7 @@
+ --FILE--
+ <?php
+ $zones = array(
+- "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "Factory", "GB-Eire",
++ "CST6CDT", "Cuba", "Egypt", "Eire", "EST5EDT", "GB-Eire",
+ "GMT0", "Greenwich", "Hongkong", "Iceland", "Iran", "Israel", "Jamaica",
+ "Japan", "Kwajalein", "Libya", "MST7MDT", "Navajo", "NZ-CHAT", "Poland",
+ "Portugal", "PST8PDT", "Singapore", "Turkey", "Universal", "W-SU",
+@@ -45,11 +45,6 @@
+ )
+ DateTimeZone Object
+ (
+- [timezone_type] => 3
+- [timezone] => Factory
+-)
+-DateTimeZone Object
+-(
+ [timezone_type] => 3
+ [timezone] => GB-Eire
+ )
+diff -up ./ext/date/tests/strtotime3-64bit.phpt.datetests ./ext/date/tests/strtotime3-64bit.phpt
+--- ./ext/date/tests/strtotime3-64bit.phpt.datetests 2016-07-21 02:23:03.000000000 +0200
++++ ./ext/date/tests/strtotime3-64bit.phpt 2016-07-26 07:39:45.713272263 +0200
+@@ -44,7 +44,7 @@ foreach ($strs as $str) {
+ }
+
+ ?>
+---EXPECT--
++--EXPECTF--
+ bool(false)
+ bool(false)
+ string(31) "Thu, 15 Jun 2006 00:00:00 +0100"
+@@ -53,7 +53,7 @@ bool(false)
+ string(31) "Fri, 16 Jun 2006 23:49:12 +0100"
+ bool(false)
+ string(31) "Fri, 16 Jun 2006 02:22:00 +0100"
+-string(31) "Sun, 16 Jun 0222 02:22:00 -0036"
++string(31) "Sun, 16 Jun 0222 02:22:00 %s"
+ string(31) "Fri, 16 Jun 2006 02:22:33 +0100"
+ bool(false)
+ string(31) "Tue, 02 Mar 2004 00:00:00 +0000"
+diff -up ./ext/date/tests/bug33414-2.phpt.datetests ./ext/date/tests/bug33414-2.phpt
+--- ./ext/date/tests/bug33414-2.phpt.datetests 2016-07-21 02:23:03.000000000 +0200
++++ ./ext/date/tests/bug33414-2.phpt 2016-07-26 07:28:10.323598643 +0200
+@@ -74,7 +74,7 @@ $strtotime_tstamp = strtotime("next Frid
+ print "result=".date("l Y-m-d H:i:s T I", $strtotime_tstamp)."\n";
+ print "wanted=Friday 00:00:00\n\n";
+ ?>
+---EXPECT--
++--EXPECTF--
+ TZ=Pacific/Rarotonga - wrong day.
+ tStamp=Thursday 1970-01-01 17:17:17 CKT 0
+ result=Tuesday 1970-01-06 00:00:00 CKT 0
+@@ -106,8 +106,8 @@ result=Tuesday 2005-04-12 00:00:00 CDT 1
+ wanted=Tuesday 00:00:00
+
+ TZ=Pacific/Pitcairn - wrong day.
+-tStamp=Thursday 1970-01-01 17:17:17 PNT 0
+-result=Wednesday 1970-01-07 00:00:00 PNT 0
++tStamp=Thursday 1970-%s
++result=Wednesday 1970-%s
+ wanted=Wednesday 00:00:00
+
+ TZ=Pacific/Fakaofo - wrong day.
+
diff --git a/php71.spec b/php71.spec
index 5b38dde..90dcc81 100644
--- a/php71.spec
+++ b/php71.spec
@@ -120,8 +120,8 @@
%global db_devel libdb-devel
%endif
-%global rcver beta1
-%global rpmrel 1
+%global rcver beta2
+%global rpmrel 2
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -182,7 +182,7 @@ Patch91: php-5.6.3-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
-Patch300: php-5.6.3-datetests.patch
+Patch300: php-7.0.10-datetests.patch
# Revert changes for pcre < 8.34
Patch301: php-7.0.0-oldpcre.patch
@@ -1994,6 +1994,9 @@ fi
%changelog
+* Wed Aug 3 2016 Remi Collet <remi@fedoraproject.org> 7.1.0-0.2.beta2
+- Update to 7.1.0beta2
+
* Sat Jul 23 2016 Remi Collet <remi@fedoraproject.org> 7.1.0-0.1.beta1
- Update to 7.1.0beta1