summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-17 11:27:14 +0200
committerRemi Collet <remi@remirepo.net>2019-06-17 11:27:14 +0200
commit0c6b697ba7df3078822b1b121cbae91dc908d9fd (patch)
tree7581fd3f8ae42955e181f4eb854ef12b84108574
parent4b5faa95acdf431e929235411b5105710b9589ae (diff)
use oracle client library version 19.3HEADmaster
-rw-r--r--php71.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php71.spec b/php71.spec
index b8f8e25..9402bb5 100644
--- a/php71.spec
+++ b/php71.spec
@@ -26,10 +26,12 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%ifarch ppc ppc64
-%global oraclever 10.2.0.2
-%else
+%if 0%{?rhel} == 6
%global oraclever 18.3
+%global oraclelib 18.1
+%else
+%global oraclever 19.3
+%global oraclelib 19.1
%endif
# Build for LiteSpeed Web Server (LSAPI)
@@ -112,7 +114,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -662,7 +664,7 @@ The extension is linked with Oracle client libraries %{oraclever}
(Oracle Instant Client). For details, see Oracle's note
"Oracle Client / Server Interoperability Support" (ID 207303.1).
-You must install libclntsh.so.%{oraclever} to use this package, provided
+You must install libclntsh.so.%{oraclelib} to use this package, provided
in the database installation, or in the free Oracle Instant Client
available from Oracle.
@@ -2083,6 +2085,9 @@ fi
%changelog
+* Mon Jun 17 2019 Remi Collet <remi@remirepo.net> - 7.1.30-2
+- use oracle client library version 19.3
+
* Tue May 28 2019 Remi Collet <remi@remirepo.net> - 7.1.30-1
- Update to 7.1.30 - http://www.php.net/releases/7_1_30.php