summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt6
-rw-r--r--php-7.1.7-httpd.patch28
-rw-r--r--php70.spec11
3 files changed, 36 insertions, 9 deletions
diff --git a/failed.txt b/failed.txt
index f72f7cb..418e069 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.0.27RC1 (2017-12-07)
+===== 7.0.27 (2018-01-04)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
@@ -8,11 +8,9 @@ $ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/fc24i/build.log:Tests failed : 0
/var/lib/mock/fc24x/build.log:Tests failed : 0
/var/lib/mock/fc25i/build.log:Tests failed : 0
-/var/lib/mock/fc25x/build.log:Tests failed : 1
+/var/lib/mock/fc25x/build.log:Tests failed : 0
-fc25:
- 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
1 proc_open give erratic test results :(
diff --git a/php-7.1.7-httpd.patch b/php-7.1.7-httpd.patch
new file mode 100644
index 0000000..acb3d2c
--- /dev/null
+++ b/php-7.1.7-httpd.patch
@@ -0,0 +1,28 @@
+Disable MPM detection
+
+mod_php is build twice
+- as NTS without option
+- as ZTS using --enable-maintainer-zts
+
+diff --git a/sapi/apache2handler/config.m4 b/sapi/apache2handler/config.m4
+index 2e64b21..ec4799f 100644
+--- a/sapi/apache2handler/config.m4
++++ b/sapi/apache2handler/config.m4
+@@ -116,17 +116,6 @@ if test "$PHP_APXS2" != "no"; then
+ ;;
+ esac
+
+- if test "$APACHE_VERSION" -lt 2004001; then
+- APXS_MPM=`$APXS -q MPM_NAME`
+- if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
+- PHP_BUILD_THREAD_SAFE
+- fi
+- else
+- APACHE_THREADED_MPM=`$APXS_HTTPD -V | grep 'threaded:.*yes'`
+- if test -n "$APACHE_THREADED_MPM"; then
+- PHP_BUILD_THREAD_SAFE
+- fi
+- fi
+ AC_MSG_RESULT(yes)
+ PHP_SUBST(APXS)
+ else
diff --git a/php70.spec b/php70.spec
index 79b4bb7..dcfcf6b 100644
--- a/php70.spec
+++ b/php70.spec
@@ -108,7 +108,7 @@
%endif
%global upver 7.0.27
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -144,6 +144,7 @@ Source52: 20-oci8.ini
Source99: php-fpm.init
# Build fixes
+Patch1: php-7.1.7-httpd.patch
Patch5: php-7.0.0-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
@@ -983,12 +984,9 @@ support for JavaScript Object Notation (JSON) to PHP.
%prep
echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzip}
-
-# ensure than current httpd use prefork MPM.
-httpd -V | grep -q 'threaded:.*yes' && exit 1
-
%setup -q -n php-%{upver}%{?rcver}
+%patch1 -p1 -b .mpmcheck
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
@@ -2033,6 +2031,9 @@ fi
%changelog
+* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 7.0.27-1
+- Update to 7.0.27 - http://www.php.net/releases/7_0_27.php
+
* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 7.0.27~RC1-1
- Update to 7.0.27RC1