summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--10-opcache.ini2
-rw-r--r--failed.txt33
-rw-r--r--php-7.0.0-systzdata-v13.patch (renamed from php-7.0.0-systzdata-v12.patch)11
-rw-r--r--php.conf23
-rw-r--r--php70.spec16
5 files changed, 37 insertions, 28 deletions
diff --git a/10-opcache.ini b/10-opcache.ini
index 7477caa..cfbff55 100644
--- a/10-opcache.ini
+++ b/10-opcache.ini
@@ -108,4 +108,4 @@ opcache.blacklist_filename=/etc/php.d/opcache*.blacklist
; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
; This should improve performance, but requires appropriate OS configuration.
-;opcache.huge_code_pages=1
+;opcache.huge_code_pages=0
diff --git a/failed.txt b/failed.txt
index 88d5164..b889806 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,27 +1,26 @@
-===== 7.0.0-0.5.RC3 (2015-09-17)
+===== 7.0.0-0.6.RC4 (2015-10-01)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/el6i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/el6x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
-/var/lib/mock/el7x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc21i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc21x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc22i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
+/var/lib/mock/el6i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
+/var/lib/mock/el6x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/el7x/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc21i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc22i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc22x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc23i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc23i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc23x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-el6x
- Test session_set_save_handler() function : test lazy_write [ext/session/tests/session_set_save_handler_variation6.phpt]
-fc21i,
+
+el6i, el6x, el7x
+ Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
+el6x, el7x
+ strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
+el7x
+ Test session_set_save_handler() function : basic functionality [ext/session/tests/session_set_save_handler_basic.phpt]
+fc22x
Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
-fc21i, fc22x, fc23i
- Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
-fc22i
- Bug #55259 (openssl extension does not get the DH parameters from DH key resource) [ext/openssl/tests/bug55259.phpt]
-fc21x
- Bug #69521 Segfault in gc_collect_cycles() [ext/standard/tests/streams/bug69521.phpt]
* proc_open give erratic test results :(
diff --git a/php-7.0.0-systzdata-v12.patch b/php-7.0.0-systzdata-v13.patch
index 560faef..5efc47d 100644
--- a/php-7.0.0-systzdata-v12.patch
+++ b/php-7.0.0-systzdata-v13.patch
@@ -2,6 +2,7 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
+r13: adapt for upstream changes to use PHP allocator
r12: adapt for upstream changes for new zic
r11: use canonical names to avoid more case sensitivity issues
round lat/long from zone.tab towards zero per builtin db
@@ -435,9 +436,9 @@ diff -up php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata php-7.0.0RC1/ext/date/li
+{
+ if (timezonedb_system) {
+ timelib_tzdb_index_entry *ent, lookup;
-+
++
+ lookup.id = (char *)timezone;
-+
++
+ ent = bsearch(&lookup, timezonedb_system->index,
+ timezonedb_system->index_size, sizeof lookup,
+ sysdbcmp);
@@ -609,8 +610,8 @@ diff -up php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata php-7.0.0RC1/ext/date/li
+ * if possible. */
+
+ if ((li = find_zone_info(system_location_table, timezone)) != NULL) {
-+ tmp->location.comments = strdup(li->comment);
-+ strncpy(tmp->location.country_code, li->code, 2);
++ tmp->location.comments = timelib_strdup(li->comment);
++ strncpy(tmp->location.country_code, li->code, 2);
+ tmp->location.longitude = li->longitude;
+ tmp->location.latitude = li->latitude;
+ tmp->bc = 1;
@@ -618,7 +619,7 @@ diff -up php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata php-7.0.0RC1/ext/date/li
+ else {
+ strcpy(tmp->location.country_code, "??");
+ tmp->bc = 0;
-+ tmp->location.comments = strdup("");
++ tmp->location.comments = timelib_strdup("");
+ }
+
+ /* Now done with the mmap segment - discard it. */
diff --git a/php.conf2 b/php.conf2
index 2c12ca8..fc6de6f 100644
--- a/php.conf2
+++ b/php.conf2
@@ -2,6 +2,9 @@
# Redirect to local php-fpm if mod_php (5 or 7) is not available
<IfModule !mod_php5.c>
<IfModule !mod_php7.c>
+ # Enable http authorization headers
+ SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
+
<FilesMatch \.php$>
SetHandler "proxy:fcgi://127.0.0.1:9000"
</FilesMatch>
diff --git a/php70.spec b/php70.spec
index d41ff5c..1db28da 100644
--- a/php70.spec
+++ b/php70.spec
@@ -132,8 +132,8 @@
%global db_devel libdb-devel
%endif
-%global rcver RC3
-%global rpmrel 5
+%global rcver RC4
+%global rpmrel 6
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -178,7 +178,7 @@ Patch21: php-7.0.0-odbctimer.patch
# Functional changes
Patch40: php-7.0.0-dlopen.patch
-Patch42: php-7.0.0-systzdata-v12.patch
+Patch42: php-7.0.0-systzdata-v13.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -955,7 +955,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch21 -p1 -b .odbctimer
%patch40 -p1 -b .dlopen
-%if 0%{?fedora} >= 19 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 5
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
@@ -972,7 +972,9 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
# security patches
# Fixes for tests
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 5
%patch300 -p1 -b .datetests
+%endif
%if %{with_libpcre}
if ! pkg-config libpcre --atleast-version 8.34 ; then
# Only apply when system libpcre < 8.34
@@ -1189,7 +1191,7 @@ ln -sf ../configure
--with-layout=GNU \
--with-kerberos \
--with-libxml-dir=%{_prefix} \
-%if 0%{?fedora} >= 19 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 5
--with-system-tzdata \
%endif
--with-mhash \
@@ -1999,6 +2001,10 @@ fi
%changelog
+* Wed Sep 30 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.6.RC4
+- Update to 7.0.0RC4
+- php-fpm: set http authorization headers
+
* Wed Sep 16 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.5.RC3
- Update to 7.0.0RC3
- disable zip extension (provided in php-pecl-zip)