summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--bug72564.patch67
-rw-r--r--failed.txt15
-rw-r--r--php70.spec8
3 files changed, 80 insertions, 10 deletions
diff --git a/bug72564.patch b/bug72564.patch
new file mode 100644
index 0000000..4d7e5c1
--- /dev/null
+++ b/bug72564.patch
@@ -0,0 +1,67 @@
+From 99d6e09c3d6679bb522836c833d0cfd4f79c6014 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Fri, 8 Jul 2016 10:46:33 +0200
+Subject: [PATCH] Fixed Bug #72564 boolean always deserialized as "true"
+
+---
+ ext/wddx/wddx.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/wddx/wddx.c b/ext/wddx/wddx.c
+index 2cc3c8b..cb0c01e 100644
+--- a/ext/wddx/wddx.c
++++ b/ext/wddx/wddx.c
+@@ -1013,9 +1013,9 @@ static void php_wddx_process_data(void *user_data, const XML_Char *s, int len)
+
+ case ST_BOOLEAN:
+ if (!strcmp((char *)s, "true")) {
+- Z_LVAL(ent->data) = 1;
++ ZVAL_TRUE(&ent->data);
+ } else if (!strcmp((char *)s, "false")) {
+- Z_LVAL(ent->data) = 0;
++ ZVAL_FALSE(&ent->data);
+ } else {
+ zval_ptr_dtor(&ent->data);
+ if (ent->varname) {
+--
+2.1.4
+
+From bfc42211d3cc5aa6cd2bdb10ef5004ce22099acb Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Fri, 8 Jul 2016 10:45:13 +0200
+Subject: [PATCH] add test for bug #72564 (7.x regression)
+
+---
+ ext/wddx/tests/bug72564.phpt | 20 ++++++++++++++++++++
+ 1 file changed, 20 insertions(+)
+ create mode 100644 ext/wddx/tests/bug72564.phpt
+
+diff --git a/ext/wddx/tests/bug72564.phpt b/ext/wddx/tests/bug72564.phpt
+new file mode 100644
+index 0000000..4711ef8
+--- /dev/null
++++ b/ext/wddx/tests/bug72564.phpt
+@@ -0,0 +1,20 @@
++--TEST--
++Bug #72564: wddx deserialization of boolean
++--SKIPIF--
++<?php if (!extension_loaded("wddx")) print "skip"; ?>
++--FILE--
++<?php
++ foreach([true, false, NULL] as $v) {
++ $x = wddx_serialize_value($v);
++ var_dump($x, wddx_deserialize($x));
++ }
++?>
++Done
++--EXPECT--
++string(84) "<wddxPacket version='1.0'><header/><data><boolean value='true'/></data></wddxPacket>"
++bool(true)
++string(85) "<wddxPacket version='1.0'><header/><data><boolean value='false'/></data></wddxPacket>"
++bool(false)
++string(68) "<wddxPacket version='1.0'><header/><data><null/></data></wddxPacket>"
++NULL
++Done
+--
+2.1.4
+
diff --git a/failed.txt b/failed.txt
index 69429e3..be4bc62 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,16 +1,16 @@
-===== 7.0.9RC1 (2016-07-08)
+===== 7.0.9 (2016-07-21)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 1
/var/lib/mock/el6x/build.log:Tests failed : 2
/var/lib/mock/el7x/build.log:Tests failed : 2
-/var/lib/mock/fc21i/build.log:Tests failed : 1
+/var/lib/mock/fc21i/build.log:Tests failed : 0
/var/lib/mock/fc21x/build.log:Tests failed : 0
/var/lib/mock/fc22i/build.log:Tests failed : 0
-/var/lib/mock/fc22x/build.log:Tests failed : 2
+/var/lib/mock/fc22x/build.log:Tests failed : 0
/var/lib/mock/fc23i/build.log:Tests failed : 0
-/var/lib/mock/fc23x/build.log:Tests failed : 0
+/var/lib/mock/fc23x/build.log:Tests failed : 1
/var/lib/mock/fc24i/build.log:Tests failed : 0
/var/lib/mock/fc24x/build.log:Tests failed : 0
@@ -19,11 +19,8 @@ el6i, el6x, el7x
Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
el6x, el7x
strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
-fc21i, fc22x
- Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
-fc22x
- php://input is empty when enable_post_data_reading=Off [tests/basic/bug67198.phpt]
-
+fc23x
+ Concatenating many small strings should not slowdown allocations [Zend/tests/concat_003.phpt]
* proc_open give erratic test results :(
diff --git a/php70.spec b/php70.spec
index db2d307..8557a69 100644
--- a/php70.spec
+++ b/php70.spec
@@ -120,7 +120,7 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
@@ -177,6 +177,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: bug72564.patch
# Security fixes (200+)
@@ -958,6 +959,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .bug72564
# security patches
@@ -1994,6 +1996,10 @@ fi
%changelog
+* Wed Jul 20 2016 Remi Collet <remi@fedoraproject.org> 7.0.9-1
+- Update to 7.0.9 - http://www.php.net/releases/7_0_9.php
+- wddx: add upstream patch for https://bugs.php.net/72564
+
* Wed Jul 6 2016 Remi Collet <remi@fedoraproject.org> 7.0.9-0.1.RC1
- Update to 7.0.9RC1