summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--10-opcache.ini4
-rw-r--r--php70.spec17
2 files changed, 16 insertions, 5 deletions
diff --git a/10-opcache.ini b/10-opcache.ini
index 8e127cb..84492a6 100644
--- a/10-opcache.ini
+++ b/10-opcache.ini
@@ -105,7 +105,3 @@ opcache.blacklist_filename=/etc/php.d/opcache*.blacklist
; Enables or disables checksum validation when script loaded from file cache.
;opcache.file_cache_consistency_checks=1
-
-; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
-; This should improve performance, but requires appropriate OS configuration.
-opcache.huge_code_pages=0
diff --git a/php70.spec b/php70.spec
index 0a43eed..b51394b 100644
--- a/php70.spec
+++ b/php70.spec
@@ -1096,8 +1096,14 @@ echo "d /run/php-fpm 755 root root" >php-fpm.tmpfiles
# Some extensions have their own configuration file
cp %{SOURCE50} 10-opcache.ini
-%ifarch x86_64
%if 0%{?rhel} != 6
+cat << EOF >>10-opcache.ini
+
+; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
+; This should improve performance, but requires appropriate OS configuration.
+opcache.huge_code_pages=0
+EOF
+%ifarch x86_64
sed -e '/opcache.huge_code_pages/s/0/1/' -i 10-opcache.ini
%endif
%endif
@@ -1215,6 +1221,9 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if 0%{?rhel} == 6
+ --disable-huge-code-pages \
+%endif
--enable-phpdbg \
--with-imap=shared --with-imap-ssl \
--enable-mbstring=shared \
@@ -1359,6 +1368,9 @@ build --includedir=%{_includedir}/php-zts \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+%if 0%{?rhel} == 6
+ --disable-huge-code-pages \
+%endif
--with-imap=shared --with-imap-ssl \
--enable-mbstring=shared \
--enable-mbregex \
@@ -1971,6 +1983,9 @@ fi
%changelog
+* Thu Dec 17 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-1.1
+- opcache: build with --disable-huge-code-pages on EL-6
+
* Wed Dec 16 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-1
- Update to 7.0.1
http://www.php.net/releases/7_0_1.php