summaryrefslogtreecommitdiffstats
path: root/php70.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-27 17:57:10 +0200
committerRemi Collet <remi@php.net>2022-09-27 17:57:10 +0200
commit9428c8a7a2178ae8c5e786ee492b3f55d0486d98 (patch)
treeb59d8684f6a68bede53e7cdbed54b4f2f8e83447 /php70.spec
parentd392b2255ef851a3170e805c6ffe098ae490a143 (diff)
phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
core: fix #81727 Don't mangle HTTP variable names that clash with ones that have a specific semantic meaning. CVE-2022-31629 use oracle client library version 21.7
Diffstat (limited to 'php70.spec')
-rw-r--r--php70.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php70.spec b/php70.spec
index ea383f3..7cc6a06 100644
--- a/php70.spec
+++ b/php70.spec
@@ -26,7 +26,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.6
+%global oraclever 21.7
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -109,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 33%{?dist}
+Release: 34%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -225,6 +225,8 @@ Patch253: php-bug81026.patch
Patch254: php-bug79971.patch
Patch255: php-bug81719.patch
Patch256: php-bug81720.patch
+Patch257: php-bug81727.patch
+Patch258: php-bug81726.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -344,7 +346,6 @@ Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
Requires: php-common%{?_isa} = %{version}-%{release}
-Requires(pre): /usr/sbin/useradd
%if %{with_systemd}
BuildRequires: systemd-devel
BuildRequires: systemd-units
@@ -369,6 +370,8 @@ Requires(pre): httpd-filesystem
Requires: httpd-filesystem >= 2.4.10
# php engine for Apache httpd webserver
Provides: php(httpd)
+%else
+Requires(pre): /usr/sbin/useradd
%endif
%if %{with_nginx}
# for /etc/nginx ownership
@@ -973,8 +976,8 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-# Upstream requires 4.0, we require 50 to ensure use of libicu-last
-BuildRequires: libicu-devel >= 69
+# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
+BuildRequires: libicu-devel = 69.1
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl, php70u-intl, php70w-intl
%endif
@@ -1135,6 +1138,8 @@ echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzi
%patch254 -p1 -b .bug79971
%patch255 -p1 -b .bug81719
%patch256 -p1 -b .bug81720
+%patch257 -p1 -b .bug81727
+%patch258 -p1 -b .bug81726
# Fixes for tests
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 5
@@ -2172,6 +2177,12 @@ fi
%changelog
+* Tue Sep 27 2022 Remi Collet <remi@remirepo.net> - 7.0.33-34
+- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
+- core: fix #81727 Don't mangle HTTP variable names that clash with ones
+ that have a specific semantic meaning. CVE-2022-31629
+- use oracle client library version 21.7
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.0.33-33
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626