summaryrefslogtreecommitdiffstats
path: root/php70.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-20 15:38:04 +0200
committerRemi Collet <remi@php.net>2021-10-20 15:38:04 +0200
commit2abeb5da5bd9b9566911f36ab5cadd40b2f4e306 (patch)
treeec2327eeb8dc1f2f233cb0c376b5a2d7b0f68d18 /php70.spec
parentd54b5fe857400d08b4281923f8d41bf9c8685962 (diff)
fix PHP-FPM oob R/W in root process leading to priv escalation
CVE-2021-21703 use libicu version 69 use oracle client library version 21.3
Diffstat (limited to 'php70.spec')
-rw-r--r--php70.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/php70.spec b/php70.spec
index 8b8b9ed..006cff5 100644
--- a/php70.spec
+++ b/php70.spec
@@ -26,7 +26,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.1
+%global oraclever 21.3
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -109,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 29%{?dist}
+Release: 31%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -221,6 +221,7 @@ Patch249: php-bug80710.patch
Patch250: php-bug81122.patch
Patch251: php-bug76450.patch
Patch252: php-bug81211.patch
+Patch253: php-bug81026.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -975,7 +976,7 @@ Group: System Environment/Libraries
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
# Upstream requires 4.0, we require 50 to ensure use of libicu-last
-BuildRequires: libicu-devel >= 50
+BuildRequires: libicu-devel >= 69
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl, php70u-intl, php70w-intl
%endif
@@ -1132,6 +1133,7 @@ echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzi
%patch250 -p1 -b .bug81122
%patch251 -p1 -b .bug76450
%patch252 -p1 -b .bug81211
+%patch253 -p1 -b .bug81026
# Fixes for tests
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 5
@@ -1637,7 +1639,7 @@ popd
%check
%if %runselftest
-cd build-apache
+cd build-fpm
# Run tests, using the CLI SAPI
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
@@ -2169,6 +2171,12 @@ fi
%changelog
+* Wed Oct 20 2021 Remi Collet <remi@remirepo.net> - 7.0.33-31
+- fix PHP-FPM oob R/W in root process leading to priv escalation
+ CVE-2021-21703
+- use libicu version 69
+- use oracle client library version 21.3
+
* Thu Aug 26 2021 Remi Collet <remi@remirepo.net> - 7.0.33-29
- Fix #81211 Symlinks are followed when creating PHAR archive