summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-04 13:58:41 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-04 13:58:41 +0200
commita02d1c753a2ed11e81513c814fe6f7280a0e4604 (patch)
tree5c692220a97421b59684485e617fa41cc65c2372
parent3cc341afe7acc6ccf1c337a04c5a1a2c6325ea50 (diff)
PHP 7.0.0RC2
-rw-r--r--10-opcache.ini (renamed from opcache.ini)9
-rw-r--r--20-oci8.ini53
-rw-r--r--failed.txt22
-rw-r--r--php.ini81
-rw-r--r--php70.spec19
5 files changed, 96 insertions, 88 deletions
diff --git a/opcache.ini b/10-opcache.ini
index de4377b..5ed5fbb 100644
--- a/opcache.ini
+++ b/10-opcache.ini
@@ -42,11 +42,6 @@ opcache.max_accelerated_files=4000
; size of the optimized code.
;opcache.save_comments=1
-; If disabled, PHPDoc comments are not loaded from SHM, so "Doc Comments"
-; may be always stored (save_comments=1), but not loaded by applications
-; that don't need them anyway.
-;opcache.load_comments=1
-
; If enabled, a fast shutdown sequence is used for the accelerated code
;opcache.fast_shutdown=0
@@ -93,6 +88,10 @@ opcache.blacklist_filename=/etc/php.d/opcache*.blacklist
; Useful for internal debugging only.
;opcache.protect_memory=0
+; Allows calling OPcache API functions only from PHP scripts which path is
+; started from specified string. The default "" means no restriction
+;opcache.restrict_api=
+
; Experimental file based opcode cache
; RPM note : file cache directory must be owned by process owner
; for mod_php, see /etc/httpd/conf.d/php.conf
diff --git a/20-oci8.ini b/20-oci8.ini
new file mode 100644
index 0000000..f1fe49a
--- /dev/null
+++ b/20-oci8.ini
@@ -0,0 +1,53 @@
+; Enable oci8 extension module
+extension=oci8.so
+
+; Connection: Enables privileged connections using external
+; credentials (OCI_SYSOPER, OCI_SYSDBA)
+; http://php.net/oci8.privileged-connect
+;oci8.privileged_connect = Off
+
+; Connection: The maximum number of persistent OCI8 connections per
+; process. Using -1 means no limit.
+; http://php.net/oci8.max-persistent
+;oci8.max_persistent = -1
+
+; Connection: The maximum number of seconds a process is allowed to
+; maintain an idle persistent connection. Using -1 means idle
+; persistent connections will be maintained forever.
+; http://php.net/oci8.persistent-timeout
+;oci8.persistent_timeout = -1
+
+; Connection: The number of seconds that must pass before issuing a
+; ping during oci_pconnect() to check the connection validity. When
+; set to 0, each oci_pconnect() will cause a ping. Using -1 disables
+; pings completely.
+; http://php.net/oci8.ping-interval
+;oci8.ping_interval = 60
+
+; Connection: Set this to a user chosen connection class to be used
+; for all pooled server requests with Oracle 11g Database Resident
+; Connection Pooling (DRCP). To use DRCP, this value should be set to
+; the same string for all web servers running the same application,
+; the database pool must be configured, and the connection string must
+; specify to use a pooled server.
+;oci8.connection_class =
+
+; High Availability: Using On lets PHP receive Fast Application
+; Notification (FAN) events generated when a database node fails. The
+; database must also be configured to post FAN events.
+;oci8.events = Off
+
+; Tuning: This option enables statement caching, and specifies how
+; many statements to cache. Using 0 disables statement caching.
+; http://php.net/oci8.statement-cache-size
+;oci8.statement_cache_size = 20
+
+; Tuning: Enables statement prefetching and sets the default number of
+; rows that will be fetched automatically after statement execution.
+; http://php.net/oci8.default-prefetch
+;oci8.default_prefetch = 100
+
+; Compatibility. Using On means oci_close() will not close
+; oci_connect() and oci_new_connect() connections.
+; http://php.net/oci8.old-oci-close-semantics
+;oci8.old_oci_close_semantics = Off
diff --git a/failed.txt b/failed.txt
index dfa839a..6c2910b 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,28 +1,18 @@
-===== 7.0.0-0.3.RC1
+===== 7.0.0-0.4.RC2 (2015-09-04)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/el6x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/el7x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/el7x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc21i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc22i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc22x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc21x/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc22i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc23i/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc23x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-el6i, fc22i
- Bug #53437 DateInterval unserialize bad data, 32 bit [ext/date/tests/bug53437_var3.phpt]
-
-fc22x
- Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
-
-el7x
- Test session_set_save_handler() function : test lazy_write [ext/session/tests/session_set_save_handler_variation6.phpt]
-fc22i
- Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
-fc22i, fc22x, el7x
+fc21x
Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
* proc_open give erratic test results :(
diff --git a/php.ini b/php.ini
index b0aebc2..569e807 100644
--- a/php.ini
+++ b/php.ini
@@ -939,6 +939,10 @@ cli_server.color = On
; http://php.net/pcre.recursion-limit
;pcre.recursion_limit=100000
+;Enables or disables JIT compilation of patterns. This requires the PCRE
+;library to be compiled with JIT support.
+;pcre.jit=1
+
[Pdo]
; Whether to pool ODBC connections. Can be one of "strict", "relaxed" or "off"
; http://php.net/pdo-odbc.connection-pooling
@@ -1062,64 +1066,6 @@ ibase.dateformat = "%Y-%m-%d"
; Default time format.
ibase.timeformat = "%H:%M:%S"
-[MySQL]
-; Allow accessing, from PHP's perspective, local files with LOAD DATA statements
-; http://php.net/mysql.allow_local_infile
-mysql.allow_local_infile = On
-
-; Allow or prevent persistent links.
-; http://php.net/mysql.allow-persistent
-mysql.allow_persistent = On
-
-; If mysqlnd is used: Number of cache slots for the internal result set cache
-; http://php.net/mysql.cache_size
-mysql.cache_size = 2000
-
-; Maximum number of persistent links. -1 means no limit.
-; http://php.net/mysql.max-persistent
-mysql.max_persistent = -1
-
-; Maximum number of links (persistent + non-persistent). -1 means no limit.
-; http://php.net/mysql.max-links
-mysql.max_links = -1
-
-; Default port number for mysql_connect(). If unset, mysql_connect() will use
-; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
-; compile-time value defined MYSQL_PORT (in that order). Win32 will only look
-; at MYSQL_PORT.
-; http://php.net/mysql.default-port
-mysql.default_port =
-
-; Default socket name for local MySQL connects. If empty, uses the built-in
-; MySQL defaults.
-; http://php.net/mysql.default-socket
-mysql.default_socket =
-
-; Default host for mysql_connect() (doesn't apply in safe mode).
-; http://php.net/mysql.default-host
-mysql.default_host =
-
-; Default user for mysql_connect() (doesn't apply in safe mode).
-; http://php.net/mysql.default-user
-mysql.default_user =
-
-; Default password for mysql_connect() (doesn't apply in safe mode).
-; Note that this is generally a *bad* idea to store passwords in this file.
-; *Any* user with PHP access can run 'echo get_cfg_var("mysql.default_password")
-; and reveal this password! And of course, any users with read access to this
-; file will be able to reveal the password as well.
-; http://php.net/mysql.default-password
-mysql.default_password =
-
-; Maximum time (in seconds) for connect timeout. -1 means no limit
-; http://php.net/mysql.connect-timeout
-mysql.connect_timeout = 60
-
-; Trace mode. When trace_mode is active (=On), warnings for table/index scans and
-; SQL-Errors will be displayed.
-; http://php.net/mysql.trace-mode
-mysql.trace_mode = Off
-
[MySQLi]
; Maximum number of persistent links. -1 means no limit.
@@ -1476,11 +1422,26 @@ url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
;session.upload_progress.min_freq = "1"
[Assertion]
+; Switch whether to compile assertions at all (to have no overhead at run-time)
+; -1: Do not compile at all
+; 0: Jump over assertion at run-time
+; 1: Execute assertions
+; Changing from or to a negative value is only possible in php.ini! (For turning assertions on and off at run-time, see assert.active, when zend.assertions = 1)
+; Default Value: 1
+; Development Value: 1
+; Production Value: -1
+; http://php.net/zend.assertions
+zend.assertions = -1
+
; Assert(expr); active by default.
; http://php.net/assert.active
;assert.active = On
-; Issue a PHP warning for each failed assertion.
+; Throw an AssertationException on failed assertions
+; http://php.net/assert.exception
+;assert.exception = On
+
+; Issue a PHP warning for each failed assertion. (Overridden by assert.exception if active)
; http://php.net/assert.warning
;assert.warning = On
@@ -1499,7 +1460,7 @@ url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
[mbstring]
; language for internal character representation.
-; This affects mb_send_mail() and mbstrig.detect_order.
+; This affects mb_send_mail() and mbstring.detect_order.
; http://php.net/mbstring.language
;mbstring.language = Japanese
diff --git a/php70.spec b/php70.spec
index 944edbe..f5ac385 100644
--- a/php70.spec
+++ b/php70.spec
@@ -14,7 +14,7 @@
%global pdover 20150127
# Extension version
%global opcachever 7.0.6-dev
-%global oci8ver 2.0.9
+%global oci8ver 2.1.0
%global zipver 1.13.0dev
%global jsonver 1.4.0
@@ -44,9 +44,7 @@
%global mysql_config %{_libdir}/mysql/mysql_config
# Optional components; pass "--with mssql" etc to rpmbuild.
-#global with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
-### TODO : create specific 20-oci8.ini configuration file ###
-%global with_oci8 0
+%global with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
%global with_libpcre 1
@@ -134,8 +132,8 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
-%global rpmrel 3
+%global rcver RC2
+%global rpmrel 4
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -163,8 +161,9 @@ Source12: php.conf2
Source13: nginx-fpm.conf
Source14: nginx-php.conf
# Configuration files for some extensions
-Source50: opcache.ini
+Source50: 10-opcache.ini
Source51: opcache-default.blacklist
+Source52: 20-oci8.ini
Source99: php-fpm.init
# Build fixes
@@ -1101,6 +1100,7 @@ echo "d /run/php-fpm 755 root root" >php-fpm.tmpfiles
# Some extensions have their own configuration file
cp %{SOURCE50} 10-opcache.ini
+cp %{SOURCE52} 20-oci8.ini
# Regenerated bison files
# to force, rm Zend/zend_{language,ini}_parser.[ch]
@@ -1997,6 +1997,11 @@ fi
%changelog
+* Fri Sep 4 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.4.RC2
+- Update to 7.0.0RC2
+- enable oci8 and pdo_oci extensions
+- sync php.ini with upstream php.ini-production
+
* Sat Aug 22 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.3.RC1
- Update to 7.0.0RC1