summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-28 15:15:49 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-28 15:15:49 +0100
commit7eaa62261f87bfba49a01c87a356466f14698aac (patch)
tree1d25d72a02d6bce2200dd5e25b5cfbbb4cb97119
parent83235b33c754117a8c70ca624c711fd87b6ca31c (diff)
PHP 7.0.17RC1
-rw-r--r--failed.txt10
-rw-r--r--php-7.0.17-dlopen.patch (renamed from php-7.0.0-dlopen.patch)18
-rw-r--r--php70.spec9
3 files changed, 20 insertions, 17 deletions
diff --git a/failed.txt b/failed.txt
index 609bccd..4b780dc 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,20 +1,20 @@
-===== 7.0.16 (2017-02-16)
+===== 7.0.17RC1 (2017-03-02)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el6i/build.log:Tests failed : 0
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/fc22i/build.log:Tests failed : 1
-/var/lib/mock/fc22x/build.log:Tests failed : 0
+/var/lib/mock/fc22i/build.log:Tests failed : 0
+/var/lib/mock/fc22x/build.log:Tests failed : 1
/var/lib/mock/fc23i/build.log:Tests failed : 0
/var/lib/mock/fc23x/build.log:Tests failed : 0
/var/lib/mock/fc24i/build.log:Tests failed : 0
-/var/lib/mock/fc24x/build.log:Tests failed : 0
+/var/lib/mock/fc24x/build.log:Tests failed : 1
/var/lib/mock/fc25i/build.log:Tests failed : 0
/var/lib/mock/fc25x/build.log:Tests failed : 0
-fc22i
+fc22x, fc24x
* Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
diff --git a/php-7.0.0-dlopen.patch b/php-7.0.17-dlopen.patch
index 4047460..37a461c 100644
--- a/php-7.0.0-dlopen.patch
+++ b/php-7.0.17-dlopen.patch
@@ -1,7 +1,7 @@
-diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespeed/lsapilib.c
---- php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen 2015-08-18 23:39:17.000000000 +0200
-+++ php-7.0.0RC1/sapi/litespeed/lsapilib.c 2015-08-22 07:46:31.729721983 +0200
-@@ -582,7 +582,7 @@ static int (*fp_lve_leave)(struct liblve
+diff -up php-7.0.17RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.17RC1/sapi/litespeed/lsapilib.c
+--- php-7.0.17RC1/sapi/litespeed/lsapilib.c.dlopen 2017-02-28 12:11:33.000000000 +0100
++++ php-7.0.17RC1/sapi/litespeed/lsapilib.c 2017-02-28 13:06:07.493838664 +0100
+@@ -616,7 +616,7 @@ static int (*fp_lve_leave)(struct liblve
static int (*fp_lve_jail)( struct passwd *, char *) = NULL;
static int lsapi_load_lve_lib()
{
@@ -10,16 +10,16 @@ diff -up php-7.0.0RC1/sapi/litespeed/lsapilib.c.dlopen php-7.0.0RC1/sapi/litespe
if (s_liblve)
{
fp_lve_is_available = dlsym(s_liblve, "lve_is_available");
-diff -up php-7.0.0RC1/Zend/zend_portability.h.dlopen php-7.0.0RC1/Zend/zend_portability.h
---- php-7.0.0RC1/Zend/zend_portability.h.dlopen 2015-08-18 23:39:16.000000000 +0200
-+++ php-7.0.0RC1/Zend/zend_portability.h 2015-08-22 07:46:31.729721983 +0200
-@@ -136,11 +136,11 @@
+diff -up php-7.0.17RC1/Zend/zend_portability.h.dlopen php-7.0.17RC1/Zend/zend_portability.h
+--- php-7.0.17RC1/Zend/zend_portability.h.dlopen 2017-02-28 13:06:07.493838664 +0100
++++ php-7.0.17RC1/Zend/zend_portability.h 2017-02-28 13:07:10.626118397 +0100
+@@ -146,11 +146,11 @@
# endif
# if defined(RTLD_GROUP) && defined(RTLD_WORLD) && defined(RTLD_PARENT)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
- # elif defined(RTLD_DEEPBIND)
+ # elif defined(RTLD_DEEPBIND) && !defined(__SANITIZE_ADDRESS__)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_DEEPBIND)
+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_DEEPBIND)
# else
diff --git a/php70.spec b/php70.spec
index d79af4f..31984d4 100644
--- a/php70.spec
+++ b/php70.spec
@@ -120,12 +120,12 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 7.0.16
+Version: 7.0.17
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -162,7 +162,7 @@ Patch8: php-7.0.2-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
-Patch40: php-7.0.0-dlopen.patch
+Patch40: php-7.0.17-dlopen.patch
Patch42: php-7.0.0-systzdata-v14.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
@@ -2055,6 +2055,9 @@ fi
%changelog
+* Tue Feb 28 2017 Remi Collet <remi@fedoraproject.org> 7.0.17-0.1.RC1
+- Update to 7.0.17RC1
+
* Tue Feb 14 2017 Remi Collet <remi@fedoraproject.org> 7.0.16-1
- Update to 7.0.16 - http://www.php.net/releases/7_0_16.php