summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
commit655986bcb013234c7c7574b6dbf97dc4be9ca2b2 (patch)
tree36a482b63b1731850a98578a94a72fef84a56573
parentc6d8131094231f24e4554499bc6f65f22ec03d3f (diff)
php/curl: add CURL_SSLVERSION_TLSv1_x constant
-rw-r--r--php-5.5.30-curl.patch14
-rw-r--r--php70.spec9
2 files changed, 22 insertions, 1 deletions
diff --git a/php-5.5.30-curl.patch b/php-5.5.30-curl.patch
new file mode 100644
index 0000000..0c72d56
--- /dev/null
+++ b/php-5.5.30-curl.patch
@@ -0,0 +1,14 @@
+diff -up php-5.5.30/ext/curl/interface.c.old php-5.5.30/ext/curl/interface.c
+--- php-5.5.30/ext/curl/interface.c.old 2015-12-14 13:58:27.911676702 +0100
++++ php-5.5.30/ext/curl/interface.c 2015-12-14 14:08:04.581124497 +0100
+@@ -1213,7 +1213,9 @@ PHP_MINIT_FUNCTION(curl)
+ REGISTER_CURL_CONSTANT(CURLSSLOPT_ALLOW_BEAST);
+ #endif
+
+-#if LIBCURL_VERSION_NUM >= 0x072200 /* Available since 7.34.0 */
++#if LIBCURL_VERSION_NUM >= 0x071300 /* Available since 7.19.0 (in upstream curl 7.34)
++ backported in RHEL-7 curl-7.29.0-16.el7 rhbz#1012136
++ backported in RHEL-6 curl-7.19.7-43.el6 rhbz#1036789 */
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_0);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_1);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_2);
diff --git a/php70.spec b/php70.spec
index 98ae71a..2936ee1 100644
--- a/php70.spec
+++ b/php70.spec
@@ -159,6 +159,7 @@ Patch5: php-7.0.0-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-7.0.0-libdb.patch
+Patch9: php-5.5.30-curl.patch
# Fixes for extension modules
# https://bugs.php.net/63171 no odbc call during timeout
@@ -219,7 +220,7 @@ BuildRequires: libtool-ltdl-devel
%if %{with_dtrace}
BuildRequires: systemtap-sdt-devel
%endif
-BuildRequires: bison
+#BuildRequires: bison
Obsoletes: php53, php53u, php54w, php55u, php55w, php56u, php56w, php70u, php70w
# Avoid obsoleting php54 from RHSCL
@@ -939,6 +940,9 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
%patch8 -p1 -b .libdb
+%if 0%{?rhel}
+%patch9 -p1 -b .curltls
+%endif
%patch21 -p1 -b .odbctimer
@@ -1967,6 +1971,9 @@ fi
%changelog
+* Mon Dec 14 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-0.2.0RC1
+- curl: add CURL_SSLVERSION_TLSv1_x constant
+
* Wed Dec 9 2015 Remi Collet <remi@fedoraproject.org> 7.0.1-0.1.0RC1
- Update to 7.0.1RC1
- drop --disable-huge-code-pages build option on EL-6,