summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-01 12:30:31 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-01 12:30:31 +0100
commit5d12e477d9765d83b93f094164bdccbbb5268c9c (patch)
treea307547c768b3c3c5095c4db3a17a68b843aec9f
parent018cc6fe0323824903b21b4dc5ee4503880c01bc (diff)
PHP 7.0.16RC1
-rw-r--r--failed.txt17
-rw-r--r--php-upstream.patch21
-rw-r--r--php70.spec9
3 files changed, 35 insertions, 12 deletions
diff --git a/failed.txt b/failed.txt
index 67bb83f..10d8f6b 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.0.15 (2017-01-19)
+===== 7.0.16RC1 (2017-02-02)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
@@ -6,20 +6,17 @@ $ grep -r 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/fc22i/build.log:Tests failed : 0
-/var/lib/mock/fc22x/build.log:Tests failed : 0
-/var/lib/mock/fc23i/build.log:Tests failed : 1
-/var/lib/mock/fc23x/build.log:Tests failed : 1
-/var/lib/mock/fc24i/build.log:Tests failed : 2
+/var/lib/mock/fc22x/build.log:Tests failed : 1
+/var/lib/mock/fc23i/build.log:Tests failed : 0
+/var/lib/mock/fc23x/build.log:Tests failed : 0
+/var/lib/mock/fc24i/build.log:Tests failed : 0
/var/lib/mock/fc24x/build.log:Tests failed : 0
/var/lib/mock/fc25i/build.log:Tests failed : 0
/var/lib/mock/fc25x/build.log:Tests failed : 0
-fc23i, fc23x
- * Test session_set_save_handler() function : basic functionality [ext/session/tests/session_set_save_handler_basic.phpt]
-fc24i
- * Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
- * Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
+fc22x
+ php://input is empty when enable_post_data_reading=Off [tests/basic/bug67198.phpt]
* proc_open give erratic test results :(
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..2bd7f17
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,21 @@
+From 0f1ae93bfa2feb3d0fd0b8d3036148df8ef856e2 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Wed, 1 Feb 2017 10:25:30 +0100
+Subject: [PATCH] fix test for 32bits (int -> float)
+
+---
+ ext/standard/tests/serialize/bug72731.phpt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/standard/tests/serialize/bug72731.phpt b/ext/standard/tests/serialize/bug72731.phpt
+index 3d7d1e7..020fb32 100644
+--- a/ext/standard/tests/serialize/bug72731.phpt
++++ b/ext/standard/tests/serialize/bug72731.phpt
+@@ -14,5 +14,5 @@ $poc = 'O:8:"stdClass":1:{i:0;O:3:"obj":1:{s:4:"ryat";R:1;}}';
+ var_dump(unserialize($poc));
+
+ ?>
+---EXPECT--
+-int(73588229205)
++--EXPECTF--
++%s(73588229205)
diff --git a/php70.spec b/php70.spec
index f9897a5..df51ca8 100644
--- a/php70.spec
+++ b/php70.spec
@@ -120,12 +120,12 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
+%global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 7.0.15
+Version: 7.0.16
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -177,6 +177,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -1029,6 +1030,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .upstream
# security patches
@@ -2059,6 +2061,9 @@ fi
%changelog
+* Wed Feb 1 2017 Remi Collet <remi@fedoraproject.org> 7.0.16-0.1.RC1
+- Update to 7.0.16RC1
+
* Tue Jan 17 2017 Remi Collet <remi@fedoraproject.org> 7.0.15-1
- Update to 7.0.15 - http://www.php.net/releases/7_0_15.php