summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-31 08:08:09 +0200
committerRemi Collet <remi@remirepo.net>2017-08-31 08:08:09 +0200
commit4da90a6dbe183230702326981ccef28750f697b0 (patch)
treefa6bf51771d01542ddad8b0b25d8578e3470d06c
parent9521d89db2884a5f4ffa59896e0f00266137aeaa (diff)
add patch for EL-6, fix undefined symbol: sqlite3_errstr
-rw-r--r--php-upstream.patch30
-rw-r--r--php70.spec7
2 files changed, 36 insertions, 1 deletions
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..448fd7c
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,30 @@
+From 3239f6d6798d86fdbf8e03aa741d9990bcfffe79 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 31 Aug 2017 07:55:45 +0200
+Subject: [PATCH] move AC_DEFINE in the right position (in bundled lib
+ conditon)
+
+---
+ ext/sqlite3/config0.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
+index 0e5fbc5..78fd622 100644
+--- a/ext/sqlite3/config0.m4
++++ b/ext/sqlite3/config0.m4
+@@ -85,11 +85,11 @@ if test $PHP_SQLITE3 != "no"; then
+ other_flags="$other_flags -DSQLITE_ENABLE_ICU=1"
+ fi
+
++ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
+ PHP_INSTALL_HEADERS([ext/sqlite3/libsqlite/sqlite3.h])
+ fi
+
+- AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ AC_DEFINE(HAVE_SQLITE3,1,[ ])
+
+ sqlite3_sources="sqlite3.c $sqlite3_extra_sources"
+--
+2.1.4
+
diff --git a/php70.spec b/php70.spec
index f68d537..9cf9415 100644
--- a/php70.spec
+++ b/php70.spec
@@ -113,7 +113,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -166,6 +166,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -1011,6 +1012,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -2030,6 +2032,9 @@ fi
%changelog
+* Thu Aug 31 2017 Remi Collet <remi@fedoraproject.org> - 7.0.23-2
+- add patch for EL-6, fix undefined symbol: sqlite3_errstr
+
* Tue Aug 29 2017 Remi Collet <remi@fedoraproject.org> - 7.0.23-1
- Update to 7.0.23 - http://www.php.net/releases/7_0_23.php