summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt12
-rw-r--r--php-5.4.7-odbctimer.patch58
-rw-r--r--php56.spec15
3 files changed, 13 insertions, 72 deletions
diff --git a/failed.txt b/failed.txt
index 693a1ac..b566c47 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,12 +1,12 @@
-===== 5.6.20 (2016-03-31)
+===== 5.6.21 (2016-04-28)
$ grep -r 'Tests failed' /var/lib/mock/56*/build.log
-/var/lib/mock/el5i/build.log:Tests failed : 8
-/var/lib/mock/el5x/build.log:Tests failed : 7
-/var/lib/mock/el6i/build.log:Tests failed : 6
-/var/lib/mock/el6x/build.log:Tests failed : 5
-/var/lib/mock/el7x/build.log:Tests failed : 5
+/var/lib/mock/el5i/build.log:Tests failed : 8
+/var/lib/mock/el5x/build.log:Tests failed : 7
+/var/lib/mock/el6i/build.log:Tests failed : 6
+/var/lib/mock/el6x/build.log:Tests failed : 5
+/var/lib/mock/el7x/build.log:Tests failed : 5
/var/lib/mock/fc21i/build.log:Tests failed : 2
/var/lib/mock/fc21x/build.log:Tests failed : 0
/var/lib/mock/fc22i/build.log:Tests failed : 2
diff --git a/php-5.4.7-odbctimer.patch b/php-5.4.7-odbctimer.patch
deleted file mode 100644
index 88c4da4..0000000
--- a/php-5.4.7-odbctimer.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 657494235eafe048e9fa6a19dcdb3c73a0cbe6ec Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 27 Sep 2012 13:45:32 +0200
-Subject: [PATCH] Fixed bug #63171, script hangs if odbc call during timeout
-
----
- ext/odbc/php_odbc.c | 21 ++++++++++++++-------
- 1 file changed, 14 insertions(+), 7 deletions(-)
-
-diff --git a/ext/odbc/php_odbc.c b/ext/odbc/php_odbc.c
-index 52d46b2..2169e65 100644
---- a/ext/odbc/php_odbc.c
-+++ b/ext/odbc/php_odbc.c
-@@ -431,7 +431,8 @@ static void _free_odbc_result(zend_rsrc_list_entry *rsrc TSRMLS_DC)
- efree(res->values);
- res->values = NULL;
- }
-- if (res->stmt) {
-+ /* If aborted via timer expiration, don't try to call any unixODBC function */
-+ if (res->stmt && !(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
- #if defined(HAVE_SOLID) || defined(HAVE_SOLID_30) || defined(HAVE_SOLID_35)
- SQLTransact(res->conn_ptr->henv, res->conn_ptr->hdbc,
- (SQLUSMALLINT) SQL_COMMIT);
-@@ -484,9 +485,12 @@ static void _close_odbc_conn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
- }
- }
-
-- safe_odbc_disconnect(conn->hdbc);
-- SQLFreeConnect(conn->hdbc);
-- SQLFreeEnv(conn->henv);
-+ /* If aborted via timer expiration, don't try to call any unixODBC function */
-+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
-+ safe_odbc_disconnect(conn->hdbc);
-+ SQLFreeConnect(conn->hdbc);
-+ SQLFreeEnv(conn->henv);
-+ }
- efree(conn);
- ODBCG(num_links)--;
- }
-@@ -512,9 +516,12 @@ static void _close_odbc_pconn(zend_rsrc_list_entry *rsrc TSRMLS_DC)
- }
- }
-
-- safe_odbc_disconnect(conn->hdbc);
-- SQLFreeConnect(conn->hdbc);
-- SQLFreeEnv(conn->henv);
-+ /* If aborted via timer expiration, don't try to call any unixODBC function */
-+ if (!(PG(connection_status) & PHP_CONNECTION_TIMEOUT)) {
-+ safe_odbc_disconnect(conn->hdbc);
-+ SQLFreeConnect(conn->hdbc);
-+ SQLFreeEnv(conn->henv);
-+ }
- free(conn);
-
- ODBCG(num_links)--;
---
-1.7.10
-
diff --git a/php56.spec b/php56.spec
index 5030bfa..6f6905c 100644
--- a/php56.spec
+++ b/php56.spec
@@ -15,7 +15,7 @@
# Extension version
%global fileinfover 1.0.5
%global opcachever 7.0.6-dev
-%global oci8ver 2.0.10
+%global oci8ver 2.0.11
# Use for first build of PHP (before pecl/zip and pecl/jsonc)
%global php_bootstrap 0
@@ -145,7 +145,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.6.20
+Version: 5.6.21
Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -184,10 +184,6 @@ Patch7: php-5.3.0-recode.patch
Patch8: php-5.6.17-libdb.patch
Patch9: php-5.5.30-curl.patch
-# Fixes for extension modules
-# https://bugs.php.net/63171 no odbc call during timeout
-Patch21: php-5.4.7-odbctimer.patch
-
# Functional changes
Patch40: php-5.4.0-dlopen.patch
Patch42: php-5.6.13-systzdata-v12.patch
@@ -951,8 +947,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch9 -p1 -b .curltls
%endif
-%patch21 -p1 -b .odbctimer
-
%patch40 -p1 -b .dlopen
%if 0%{?fedora} >= 19 || 0%{?rhel} >= 5
%patch42 -p1 -b .systzdata
@@ -1987,6 +1981,11 @@ fi
%changelog
+* Thu Apr 28 2016 Remi Collet <remi@fedoraproject.org> 5.6.21-1
+- Update to 5.6.21
+ http://www.php.net/releases/5_6_21.php
+- bump oci8 version to 2.0.11
+
* Thu Mar 31 2016 Remi Collet <remi@fedoraproject.org> 5.6.20-1
- Update to 5.6.20
http://www.php.net/releases/5_6_20.php