summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt21
-rw-r--r--php-5.6.8-openssltests.patch112
-rw-r--r--php56.spec22
3 files changed, 29 insertions, 126 deletions
diff --git a/failed.txt b/failed.txt
index ad20dc5..2b535e0 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,24 +1,27 @@
-===== 5.6.9
+===== 5.6.10
$ grep -r 'Tests failed' /var/lib/mock/56*/build.log
-/var/lib/mock/el5i/build.log:Tests failed : 6 ( 0.0%) ( 0.1%)
+/var/lib/mock/el5i/build.log:Tests failed : 4 ( 0.0%) ( 0.1%)
/var/lib/mock/el5x/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
-/var/lib/mock/el6i/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
+/var/lib/mock/el6i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
/var/lib/mock/el6x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/el7x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc20i/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc20i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
/var/lib/mock/fc20x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc21i/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc21i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
/var/lib/mock/fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc22i/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc22i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
/var/lib/mock/fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+
el5i, el6i, fc20i, fc21i, fc22i
- Test getdate() function : usage variation - Passing high positive and negative float values to timestamp. [ext/date/tests/getdate_variation7.phpt]
- Test localtime() function : usage variation - Passing higher positive and negetive float values to timestamp. [ext/date/tests/localtime_variation3.phpt]
- Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
+ [1] Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
+
el5i, el5x
openssl_x509_parse() basic test for OpenSSL 0.9 [ext/openssl/tests/openssl_x509_parse_basic_v9.phpt]
sni_server [ext/openssl/tests/sni_server.phpt]
Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
+
+[1] known issue, not fix found
+[2] ext/openssl erratic results... unable to connect to ssl://127.0.0.1:64321
diff --git a/php-5.6.8-openssltests.patch b/php-5.6.8-openssltests.patch
deleted file mode 100644
index a989ac7..0000000
--- a/php-5.6.8-openssltests.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-From 32484e3f5fc04f127199399a0ee52594912fa66a Mon Sep 17 00:00:00 2001
-From: Rasmus Lerdorf <rasmus@lerdorf.com>
-Date: Wed, 8 Apr 2015 09:55:55 -0700
-Subject: [PATCH] Remove SSLv3 test dependencies SSLv3 is going away. Debian8
- already ships with an openssl with no SSLv3 support which was causing these
- tests to fail.
-
----
- ext/openssl/tests/session_meta_capture.phpt | 6 ------
- ext/openssl/tests/stream_crypto_flags_001.phpt | 4 ----
- ext/openssl/tests/stream_crypto_flags_003.phpt | 6 +-----
- ext/openssl/tests/streams_crypto_method.phpt | 3 ++-
- 4 files changed, 3 insertions(+), 16 deletions(-)
-
-diff --git a/ext/openssl/tests/session_meta_capture.phpt b/ext/openssl/tests/session_meta_capture.phpt
-index f1f9610..a09d7e8 100644
---- a/ext/openssl/tests/session_meta_capture.phpt
-+++ b/ext/openssl/tests/session_meta_capture.phpt
-@@ -35,11 +35,6 @@
-
- phpt_wait();
-
-- stream_context_set_option($clientCtx, 'ssl', 'crypto_method', STREAM_CRYPTO_METHOD_SSLv3_CLIENT);
-- stream_socket_client($serverUri, $errno, $errstr, 1, $clientFlags, $clientCtx);
-- $meta = stream_context_get_options($clientCtx)['ssl']['session_meta'];
-- var_dump($meta['protocol']);
--
- stream_context_set_option($clientCtx, 'ssl', 'crypto_method', STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT);
- stream_socket_client($serverUri, $errno, $errstr, 1, $clientFlags, $clientCtx);
- $meta = stream_context_get_options($clientCtx)['ssl']['session_meta'];
-@@ -59,7 +54,6 @@ CODE;
- include 'ServerClientTestCase.inc';
- ServerClientTestCase::getInstance()->run($clientCode, $serverCode);
- --EXPECTF--
--string(5) "SSLv3"
- string(5) "TLSv1"
- string(7) "TLSv1.1"
- string(7) "TLSv1.2"
-diff --git a/ext/openssl/tests/stream_crypto_flags_001.phpt b/ext/openssl/tests/stream_crypto_flags_001.phpt
-index f988886..1ba9309 100644
---- a/ext/openssl/tests/stream_crypto_flags_001.phpt
-+++ b/ext/openssl/tests/stream_crypto_flags_001.phpt
-@@ -32,9 +32,6 @@ $clientCode = <<<'CODE'
-
- phpt_wait();
-
-- stream_context_set_option($clientCtx, 'ssl', 'crypto_method', STREAM_CRYPTO_METHOD_SSLv3_CLIENT);
-- var_dump(stream_socket_client($serverUri, $errno, $errstr, 1, $clientFlags, $clientCtx));
--
- stream_context_set_option($clientCtx, 'ssl', 'crypto_method', STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT);
- var_dump(stream_socket_client($serverUri, $errno, $errstr, 1, $clientFlags, $clientCtx));
-
-@@ -47,4 +44,3 @@ ServerClientTestCase::getInstance()->run($clientCode, $serverCode);
- --EXPECTF--
- resource(%d) of type (stream)
- resource(%d) of type (stream)
--resource(%d) of type (stream)
-diff --git a/ext/openssl/tests/stream_crypto_flags_003.phpt b/ext/openssl/tests/stream_crypto_flags_003.phpt
-index 30ca7a7..28cb640 100644
---- a/ext/openssl/tests/stream_crypto_flags_003.phpt
-+++ b/ext/openssl/tests/stream_crypto_flags_003.phpt
-@@ -13,7 +13,7 @@ $serverCode = <<<'CODE'
- $serverCtx = stream_context_create(['ssl' => [
- 'local_cert' => __DIR__ . '/bug54992.pem',
-
-- // Only accept SSLv3 and TLSv1.2 connections
-+ // Only accept TLSv1.2 connections
- 'crypto_method' => STREAM_CRYPTO_METHOD_SSLv3_SERVER | STREAM_CRYPTO_METHOD_TLSv1_2_SERVER,
- ]]);
-
-@@ -40,9 +40,6 @@ $clientCode = <<<'CODE'
- stream_context_set_option($clientCtx, 'ssl', 'crypto_method', STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT);
- var_dump(stream_socket_client($serverUri, $errno, $errstr, 1, $clientFlags, $clientCtx));
-
-- stream_context_set_option($clientCtx, 'ssl', 'crypto_method', STREAM_CRYPTO_METHOD_SSLv3_CLIENT);
-- var_dump(stream_socket_client($serverUri, $errno, $errstr, 1, $clientFlags, $clientCtx));
--
- stream_context_set_option($clientCtx, 'ssl', 'crypto_method', STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT);
- var_dump(@stream_socket_client($serverUri, $errno, $errstr, 1, $clientFlags, $clientCtx));
-
-@@ -54,7 +51,6 @@ include 'ServerClientTestCase.inc';
- ServerClientTestCase::getInstance()->run($clientCode, $serverCode);
- --EXPECTF--
- resource(%d) of type (stream)
--resource(%d) of type (stream)
- bool(false)
- bool(false)
-
-diff --git a/ext/openssl/tests/streams_crypto_method.phpt b/ext/openssl/tests/streams_crypto_method.phpt
-index 84f7934..f8ec864 100644
---- a/ext/openssl/tests/streams_crypto_method.phpt
-+++ b/ext/openssl/tests/streams_crypto_method.phpt
-@@ -4,6 +4,7 @@ Specific crypto method for ssl:// transports.
- <?php
- if (!extension_loaded("openssl")) die("skip openssl not loaded");
- if (!function_exists("proc_open")) die("skip no proc_open");
-+if (OPENSSL_VERSION_NUMBER < 0x10001001) die("skip OpenSSLv1.0.1 required");
- --FILE--
- <?php
- $serverCode = <<<'CODE'
-@@ -37,7 +38,7 @@ $clientCode = <<<'CODE'
- $serverUri = "https://127.0.0.1:64321/";
- $clientFlags = STREAM_CLIENT_CONNECT;
- $clientCtx = stream_context_create(['ssl' => [
-- 'crypto_method' => STREAM_CRYPTO_METHOD_SSLv3_CLIENT,
-+ 'crypto_method' => STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT,
- 'verify_peer' => false,
- 'verify_peer_name' => false
- ]]);
---
-2.1.4
-
diff --git a/php56.spec b/php56.spec
index b43975d..4e1d6a3 100644
--- a/php56.spec
+++ b/php56.spec
@@ -1,9 +1,19 @@
+# remirepo spec file for php 5.6
+# with backport stuff, adapted from
+#
+# Fedora spec file for php
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
# API/ABI check
%global apiver 20131106
%global zendver 20131226
%global pdover 20080721
# Extension version
-%global opcachever 7.0.4-dev
+%global opcachever 7.0.6-dev
%global oci8ver 2.0.9
# Use for first build of PHP (before pecl/zip and pecl/jsonc)
@@ -131,7 +141,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.6.9
+Version: 5.6.10
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
%else
@@ -205,8 +215,6 @@ Patch91: php-5.6.3-oci8conf.patch
Patch300: php-5.6.3-datetests.patch
# Revert changes for pcre < 8.34
Patch301: php-5.6.0-oldpcre.patch
-# Backported from 7.0
-Patch302: php-5.6.8-openssltests.patch
# WIP
@@ -971,7 +979,6 @@ rm -rf ext/json
%patch301 -p1 -b .pcre834
%endif
%endif
-%patch302 -p1 -b .sslv3
# WIP patch
@@ -1959,6 +1966,11 @@ fi
%changelog
+* Thu Jun 11 2015 Remi Collet <remi@fedoraproject.org> 5.6.10-1
+- Update to 5.6.10
+ http://www.php.net/releases/5_6_10.php
+- opcache is now 7.0.6-dev
+
* Fri May 15 2015 Remi Collet <remi@fedoraproject.org> 5.6.9-1
- Update to 5.6.9
http://www.php.net/releases/5_6_9.php