summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt44
-rw-r--r--php-upstream.patch47
-rw-r--r--php56.spec7
3 files changed, 29 insertions, 69 deletions
diff --git a/failed.txt b/failed.txt
index 6d34bfa..50c4fd1 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,36 +1,40 @@
-===== 5.6.27RC1 (2016-09-29)
+===== 5.6.27 (2016-10-14)
$ grep -r 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/el5i/build.log:Tests failed : 8
-/var/lib/mock/el5x/build.log:Tests failed : 2
-/var/lib/mock/el6i/build.log:Tests failed : 5
+/var/lib/mock/el5i/build.log:Tests failed : 10
+/var/lib/mock/el5x/build.log:Tests failed : 5
+/var/lib/mock/el6i/build.log:Tests failed : 6
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
-/var/lib/mock/fc22i/build.log:Tests failed : 3
+/var/lib/mock/fc22i/build.log:Tests failed : 2
/var/lib/mock/fc22x/build.log:Tests failed : 0
/var/lib/mock/fc23i/build.log:Tests failed : 2
/var/lib/mock/fc23x/build.log:Tests failed : 0
-/var/lib/mock/fc24i/build.log:Tests failed : 2
-/var/lib/mock/fc24x/build.log:Tests failed : 0
+/var/lib/mock/fc24i/build.log:Tests failed : 5
+/var/lib/mock/fc24x/build.log:Tests failed : 3
+el5i, el5x, fc24i, fc24x
+ *** Bug #20382 [2] (strtotime ("Monday", $date) produces wrong result on DST changeover) [ext/date/tests/bug20382-2.phpt]
+ *** Bug #33414 [1] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-1.phpt]
+ *** Bug #33415 [1] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-1.phpt]
el5i, el5x
- openssl_error_string() tests [ext/openssl/tests/openssl_error_string_basic.phpt]
-el5i
- Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
+ openssl_error_string() tests [ext/openssl/tests/openssl_error_string_basic.phpt]
el5i, el5x
- sni_server [ext/openssl/tests/sni_server.phpt]
-fc22i
- openssl_pkey_new() basic usage tests [ext/openssl/tests/openssl_pkey_new_basic.phpt]
+ sni_server [ext/openssl/tests/sni_server.phpt]
el5i, el6i, fc21i, fc22i, fc23i, fc24i
- Bug #53437 DateInterval unserialize bad data, 32 bit [ext/date/tests/bug53437_var3.phpt]
- Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
+ Bug #53437 DateInterval unserialize bad data, 32 bit [ext/date/tests/bug53437_var3.phpt]
+ ** Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
+el6i
+ openssl_pkey_new() basic usage tests [ext/openssl/tests/openssl_pkey_new_basic.phpt]
el5i, el6i
- Test date_sunrise() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunrise_variation9.phpt]
- Test date_sunset() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunset_variation9.phpt]
- Test getdate() function : usage variation - Passing high positive and negative float values to timestamp. [ext/date/tests/getdate_variation7.phpt]
+ Test date_sunrise() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunrise_variation9.phpt]
+ Test date_sunset() function : usage variation - Passing high positive and negative float values to time argument. [ext/date/tests/date_sunset_variation9.phpt]
+ Test getdate() function : usage variation - Passing high positive and negative float values to timestamp. [ext/date/tests/getdate_variation7.phpt]
-[1] #64146 known issue, no fix found
-[2] proc_open erratic results...
+* proc_open have erratic results... :(
+** #64146 known issue, no fix found
+*** Related to tzdata 2016g (f24+) vs 2016f
+
diff --git a/php-upstream.patch b/php-upstream.patch
deleted file mode 100644
index ecd9d45..0000000
--- a/php-upstream.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 55237fe153694f5501636a49e387f36297037e4a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Thu, 15 Sep 2016 13:27:20 +0200
-Subject: [PATCH] fix ZTS build
-
----
- ext/mysqlnd/mysqlnd_wireprotocol.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ext/mysqlnd/mysqlnd_wireprotocol.c b/ext/mysqlnd/mysqlnd_wireprotocol.c
-index 855a25c..844330f 100644
---- a/ext/mysqlnd/mysqlnd_wireprotocol.c
-+++ b/ext/mysqlnd/mysqlnd_wireprotocol.c
-@@ -1610,7 +1610,7 @@ php_mysqlnd_rowp_read_text_protocol_aux(MYSQLND_MEMORY_POOL_CHUNK * row_buffer,
- const unsigned long len = php_mysqlnd_net_field_length(&p);
-
- if (len != MYSQLND_NULL_LENGTH && ((p + len) > packet_end)) {
-- php_error_docref(NULL, E_WARNING, "Malformed server packet. Field length pointing "MYSQLND_SZ_T_SPEC
-+ php_error_docref(NULL TSRMLS_CC, E_WARNING, "Malformed server packet. Field length pointing "MYSQLND_SZ_T_SPEC
- " bytes after end of packet", (p + len) - packet_end - 1);
- DBG_RETURN(FAIL);
- }
---
-2.1.4
-
-From 3c117d4136d26c8d6e4127c89b2160c477f45e11 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Thu, 15 Sep 2016 15:32:39 +0200
-Subject: [PATCH] fix test (32bits)
-
----
- ext/standard/tests/strings/str_pad_variation5.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ext/standard/tests/strings/str_pad_variation5.phpt b/ext/standard/tests/strings/str_pad_variation5.phpt
-index cd979a1..4e1b1a9 100644
---- a/ext/standard/tests/strings/str_pad_variation5.phpt
-+++ b/ext/standard/tests/strings/str_pad_variation5.phpt
-@@ -31,4 +31,4 @@ var_dump( str_pad($input, $pad_length) );
- --EXPECTF--
- *** Testing str_pad() function: with large value for for 'pad_length' argument ***
-
--Fatal error: Allowed memory size of 134217728 bytes exhausted%s(tried to allocate 2147483648 bytes) in %s on line %d
-+Fatal error: String allocation overflow, max size is 2147483647 in %s on line %d
---
-2.1.4
-
diff --git a/php56.spec b/php56.spec
index 776a97e..f77ae49 100644
--- a/php56.spec
+++ b/php56.spec
@@ -143,7 +143,7 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
@@ -956,7 +956,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%endif
%patch40 -p1 -b .dlopen
-%if 0%{?fedora} >= 19 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 23 || 0%{?rhel} >= 5
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
@@ -1997,6 +1997,9 @@ fi
%changelog
+* Fri Oct 14 2016 Remi Collet <remi@fedoraproject.org> 5.6.27-1
+- Update to 5.6.27 - http://www.php.net/releases/5_6_27.php
+
* Thu Sep 29 2016 Remi Collet <remi@fedoraproject.org> 5.6.27-0.1.RC1
- update to 5.6.27RC1