summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-12 13:29:47 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-12 13:29:47 +0200
commitfc01aa049d89ecb6470fa5c67c2158ffe8c8c5f4 (patch)
tree4f31420d47f9673584f5d2420fc5c508234954a3
parent2265543d9b60aa7a546eb29f3b72f49452c920b8 (diff)
PHP 5.6.0RC1 (test build)
-rw-r--r--php-bug67878.patch201
-rw-r--r--php56.spec11
2 files changed, 6 insertions, 206 deletions
diff --git a/php-bug67878.patch b/php-bug67878.patch
deleted file mode 100644
index c2669cf..0000000
--- a/php-bug67878.patch
+++ /dev/null
@@ -1,201 +0,0 @@
-From e02616866fe2461836dc8f7f6e369b3b25644cc4 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Thu, 21 Aug 2014 09:09:21 +0200
-Subject: [PATCH] Fix bug #67878 program_prefix not honoured in man pages
-
-- add @program_prefix@ in php, phpize and php-config man pages
-- set date to 2014
-- fix "SEE ALSO" alignment
----
- sapi/cli/php.1.in | 34 +++++++++++++++++-----------------
- scripts/man1/php-config.1.in | 14 +++++++-------
- scripts/man1/phpize.1.in | 14 +++++++-------
- 3 files changed, 31 insertions(+), 31 deletions(-)
-
-diff --git a/sapi/cli/php.1.in b/sapi/cli/php.1.in
-index 4d536df..c062f3d 100644
---- a/sapi/cli/php.1.in
-+++ b/sapi/cli/php.1.in
-@@ -1,24 +1,24 @@
--.TH PHP 1 "2014" "The PHP Group" "Scripting Language"
-+.TH @program_prefix@php 1 "2014" "The PHP Group" "Scripting Language"
- .SH NAME
--php \- PHP Command Line Interface 'CLI'
-+@program_prefix@php \- PHP Command Line Interface 'CLI'
- .P
--php-cgi \- PHP Common Gateway Interface 'CGI' command
-+@program_prefix@php-cgi \- PHP Common Gateway Interface 'CGI' command
- .SH SYNOPSIS
--.B php
-+.B @program_prefix@php
- [options] [
- .B \-f\fP ]
- .IR file
- [[\-\-]
- .IR args.\|.\|. ]
- .LP
--.B php
-+.B @program_prefix@php
- [options]
- .B \-r
- .IR code
- [[\-\-]
- .IR args.\|.\|. ]
- .LP
--.B php
-+.B @program_prefix@php
- [options] [\-B
- .IR begin_code ]
- .B \-R
-@@ -28,7 +28,7 @@ php-cgi \- PHP Common Gateway Interface 'CGI' command
- [[\-\-]
- .IR args.\|.\|. ]
- .LP
--.B php
-+.B @program_prefix@php
- [options] [\-B
- .IR begin_code ]
- .B \-F
-@@ -38,13 +38,13 @@ php-cgi \- PHP Common Gateway Interface 'CGI' command
- [[\-\-]
- .IR args.\|.\|. ]
- .LP
--.B php
-+.B @program_prefix@php
- [options] \-\- [
- .IR args.\|.\|. ]
- .LP
--\fBphp \fP[options] \fB\-a\fP
-+\fB@program_prefix@php \fP[options] \fB\-a\fP
- .LP
--.B php
-+.B @program_prefix@php
- [options] \-S
- .IR addr:port
- [\-t
-@@ -374,35 +374,35 @@ The standard configuration file will only be used when
- cannot be found.
- .SH EXAMPLES
- .TP 5
--\fIphp \-r 'echo "Hello World\\n";'\fP
-+\fI@program_prefix@php \-r 'echo "Hello World\\n";'\fP
- This command simply writes the text "Hello World" to standard out.
- .TP
--\fIphp \-r 'print_r(gd_info());'\fP
-+\fI@program_prefix@php \-r 'print_r(gd_info());'\fP
- This shows the configuration of your gd extension. You can use this
- to easily check which image formats you can use. If you have any
- dynamic modules you may want to use the same ini file that php uses
- when executed from your webserver. There are more extensions which
- have such a function. For dba use:
- .RS
--\fIphp \-r 'print_r(dba_handlers(1));'\fP
-+\fI@program_prefix@php \-r 'print_r(dba_handlers(1));'\fP
- .RE
- .TP
--\fIphp \-R 'echo strip_tags($argn)."\\n";'\fP
-+\fI@program_prefix@php \-R 'echo strip_tags($argn)."\\n";'\fP
- This PHP command strips off the HTML tags line by line and outputs the
- result. To see how it works you can first look at the following PHP command
- \'\fIphp \-d html_errors=1 \-i\fP\' which uses PHP to output HTML formatted
- configuration information. If you then combine those two
- \'\fIphp \.\.\.|php \.\.\.\fP\' you'll see what happens.
- .TP
--\fIphp \-E 'echo "Lines: $argi\\n";'\fP
-+\fI@program_prefix@php \-E 'echo "Lines: $argi\\n";'\fP
- Using this PHP command you can count the lines being input.
- .TP
--\fIphp \-R '@$l+=count(file($argn));' \-E 'echo "Lines:$l\\n";'\fP
-+\fI@program_prefix@php \-R '@$l+=count(file($argn));' \-E 'echo "Lines:$l\\n";'\fP
- In this example PHP expects each input line being a file. It counts all lines
- of the files specified by each input line and shows the summarized result.
- You may combine this with tools like find and change the php scriptlet.
- .TP
--\fIphp \-R 'echo "$argn\\n"; fgets(STDIN);'\fP
-+\fI@program_prefix@php \-R 'echo "$argn\\n"; fgets(STDIN);'\fP
- Since you have access to STDIN from within \-B \-R \-F and \-E you can skip
- certain input lines with your code. But note that in such cases $argi only
- counts the lines being processed by php itself. Having read this you will
-diff --git a/scripts/man1/php-config.1.in b/scripts/man1/php-config.1.in
-index 5c60408..ae2ee56 100644
---- a/scripts/man1/php-config.1.in
-+++ b/scripts/man1/php-config.1.in
-@@ -1,12 +1,12 @@
--.TH php\-config 1 "2010" "The PHP Group" "Scripting Language"
-+.TH @program_prefix@php\-config 1 "2014" "The PHP Group" "Scripting Language"
- .SH NAME
--php\-config \- get information about PHP configuration and compile options
-+@program_prefix@php\-config \- get information about PHP configuration and compile options
- .SH SYNOPSIS
--.B php\-config
-+.B @program_prefix@php\-config
- [options]
- .LP
- .SH DESCRIPTION
--.B php\-config
-+.B @program_prefix@php\-config
- is a simple shell script for obtaining information about installed PHP configuration.
- .SH OPTIONS
- .TP 15
-@@ -57,15 +57,15 @@ PHP version
- .PD 0
- .B \-\-vernum
- PHP version as integer
--.TP
-+.RS
- .PD 1
- .P
- .SH SEE ALSO
--.BR php (1)
-+.BR @program_prefix@php (1)
- .SH VERSION INFORMATION
- This manpage describes \fBphp\fP, version @PHP_VERSION@.
- .SH COPYRIGHT
--Copyright \(co 1997\-2010 The PHP Group
-+Copyright \(co 1997\-2014 The PHP Group
- .LP
- This source file is subject to version 3.01 of the PHP license,
- that is bundled with this package in the file LICENSE, and is
-diff --git a/scripts/man1/phpize.1.in b/scripts/man1/phpize.1.in
-index 8f62f86..e49adb1 100644
---- a/scripts/man1/phpize.1.in
-+++ b/scripts/man1/phpize.1.in
-@@ -1,12 +1,12 @@
--.TH phpize 1 "2010" "The PHP Group" "Scripting Language"
-+.TH @program_prefix@phpize 1 "2014" "The PHP Group" "Scripting Language"
- .SH NAME
--phpize \- prepare a PHP extension for compiling
-+@program_prefix@phpize \- prepare a PHP extension for compiling
- .SH SYNOPSIS
--.B phpize
-+.B @program_prefix@phpize
- [options]
- .LP
- .SH DESCRIPTION
--.B phpize
-+.B @program_prefix@phpize
- is a shell script to prepare PHP extension for compiling.
- .SH OPTIONS
- .TP 15
-@@ -24,15 +24,15 @@ Prints usage information
- .PD 1
- .B \-v
- Prints API version information
--.TP
-+.RS
- .PD 1
- .P
- .SH SEE ALSO
--.BR php (1)
-+.BR @program_prefix@php (1)
- .SH VERSION INFORMATION
- This manpage describes \fBphp\fP, version @PHP_VERSION@.
- .SH COPYRIGHT
--Copyright \(co 1997\-2010 The PHP Group
-+Copyright \(co 1997\-2014 The PHP Group
- .LP
- This source file is subject to version 3.01 of the PHP license,
- that is bundled with this package in the file LICENSE, and is
---
-1.9.2
-
diff --git a/php56.spec b/php56.spec
index 056deec..f764a9e 100644
--- a/php56.spec
+++ b/php56.spec
@@ -121,13 +121,13 @@
%endif
#global snapdate 201405061030
-#global rcver RC4
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.6.0
+Version: 5.6.1
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.22.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 1%{?dist}.2
%endif
@@ -189,7 +189,6 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug67878.patch
# Security fixes (200+)
@@ -939,7 +938,6 @@ rm -rf ext/json
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .b67878
# security patches
@@ -1919,6 +1917,9 @@ fi
%changelog
+* Fri Sep 12 2014 Remi Collet <rcollet@redhat.com> 5.6.1-0.1.RC1
+- php 5.6.1RC1
+
* Wed Sep 3 2014 Remi Collet <remi@fedoraproject.org> 5.6.0-1.2
- ensure gd-last 2.1.0-3, with libvpx support, is used