summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-25 16:29:10 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-25 16:29:10 +0200
commitfb3206235dc02be196fedb1b47fa7e4297f3002c (patch)
tree81d94ca2b6f29d09d1ec0306b57006e92e549466
parentb98e5d58a214073ea53e98d62a7ba4a6d01a78d4 (diff)
php 5.6: dont display timezone version in phpinfo (tzdata patch v11)
-rw-r--r--php-5.3.1-systzdata-v11.patch (renamed from php-5.3.1-systzdata-v10.patch)18
-rw-r--r--php56.spec7
2 files changed, 22 insertions, 3 deletions
diff --git a/php-5.3.1-systzdata-v10.patch b/php-5.3.1-systzdata-v11.patch
index b262fae..1097a26 100644
--- a/php-5.3.1-systzdata-v10.patch
+++ b/php-5.3.1-systzdata-v11.patch
@@ -2,7 +2,8 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
-r10 : make timezone case insensitive
+r11: dont display version in phpinfo
+r10: make timezone case insensitive
r9: fix another compile error without --with-system-tzdata configured (Michael Heimpold)
r8: fix compile error without --with-system-tzdata configured
r7: improve check for valid timezone id to exclude directories
@@ -633,3 +634,18 @@ r1: initial revision
+ fi
+fi
+
+--- a/ext/date/php_date.c.old 2014-07-25 16:21:32.562376600 +0200
++++ b/ext/date/php_date.c 2014-07-25 16:21:42.731424669 +0200
+@@ -887,8 +887,12 @@
+
+ php_info_print_table_start();
+ php_info_print_table_row(2, "date/time support", "enabled");
++#ifdef HAVE_SYSTEM_TZDATA
++ php_info_print_table_row(2, "Timezone Database", "system");
++#else
+ php_info_print_table_row(2, "\"Olson\" Timezone Database Version", tzdb->version);
+ php_info_print_table_row(2, "Timezone Database", php_date_global_timezone_db_enabled ? "external" : "internal");
++#endif
+ php_info_print_table_row(2, "Default timezone", guess_timezone(tzdb TSRMLS_CC));
+ php_info_print_table_end();
+
diff --git a/php56.spec b/php56.spec
index ae421a6..08586cd 100644
--- a/php56.spec
+++ b/php56.spec
@@ -121,7 +121,7 @@ Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.6.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.17.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.18.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 1%{?dist}
%endif
@@ -168,7 +168,7 @@ Patch21: php-5.4.7-odbctimer.patch
# Functional changes
Patch40: php-5.4.0-dlopen.patch
-Patch42: php-5.3.1-systzdata-v10.patch
+Patch42: php-5.3.1-systzdata-v11.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -1919,6 +1919,9 @@ fi
%changelog
+* Fri Jul 25 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.18.RC2
+- dont display timezone version in phpinfo (tzdata patch v11)
+
* Sat Jul 19 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.17.RC2
- test build for #67635