summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-15 10:33:31 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-15 10:33:31 +0200
commitf3cd2b868bca54a9cbea6d1573976c793db16537 (patch)
tree4e2eb8fac9c40f8a7741e83a963fca5c029e3f55
parent3d50ed259025de75e3dd284b58a3ba0222ff4c80 (diff)
PHP 5.6.9
-rw-r--r--failed56
-rw-r--r--php-5.6.9-systzdata-v12.patch (renamed from php-5.6.3-systzdata-v11.patch)123
-rw-r--r--php56.spec10
3 files changed, 72 insertions, 117 deletions
diff --git a/failed b/failed
deleted file mode 100644
index 7bbc6a5..0000000
--- a/failed
+++ /dev/null
@@ -1,56 +0,0 @@
-=====================================================================
- FC20 i386 - June 19 - 5.6.0RC1
-=====================================================================
-1 FAILED TEST SUMMARY
----------------------------------------------------------------------
-Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-=====================================================================
- FC20 x86_64 - June 19 - 5.6.0RC1
-=====================================================================
-0 FAILED TEST SUMMARY
----------------------------------------------------------------------
-=====================================================================
- FC19 i386 - June 19 - 5.6.0RC1
-=====================================================================
-1 FAILED TEST SUMMARY
----------------------------------------------------------------------
-Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-=====================================================================
- FC19 x86_64 - June 19 - 5.6.0RC1
-=====================================================================
-0 FAILED TEST SUMMARY
----------------------------------------------------------------------
-=====================================================================
- EL7 x86_64 - June 19 - 5.6.0RC1
-=====================================================================
-0 FAILED TEST SUMMARY
----------------------------------------------------------------------
-=====================================================================
- EL6 i386 - June 19 - 5.6.0RC1
-=====================================================================
-1 FAILED TEST SUMMARY
----------------------------------------------------------------------
-Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-=====================================================================
- EL6 x86_64 - June 19 - 5.6.0RC1
-=====================================================================
-0 FAILED TEST SUMMARY
----------------------------------------------------------------------
-=====================================================================
- EL5 i386 - June 19 - 5.6.0RC1
-=====================================================================
-4 FAILED TEST SUMMARY
----------------------------------------------------------------------
-Bug #64802: openssl_x509_parse fails to parse subject properly in some cases [ext/openssl/tests/bug64802.phpt]
-sni_server [ext/openssl/tests/sni_server.phpt]
-Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
-Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-=====================================================================
- EL5 x86_64 - June 19 - 5.6.0RC1
-=====================================================================
-3 FAILED TEST SUMMARY
----------------------------------------------------------------------
-Bug #64802: openssl_x509_parse fails to parse subject properly in some cases [ext/openssl/tests/bug64802.phpt]
-sni_server [ext/openssl/tests/sni_server.phpt]
-Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
-=====================================================================
diff --git a/php-5.6.3-systzdata-v11.patch b/php-5.6.9-systzdata-v12.patch
index bfca49b..aa3277c 100644
--- a/php-5.6.3-systzdata-v11.patch
+++ b/php-5.6.9-systzdata-v12.patch
@@ -2,13 +2,14 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
+r12: adapt for upstream changes for new zic
r11: use canonical names to avoid more case sensitivity issues
round lat/long from zone.tab towards zero per builtin db
r10: make timezone case insensitive
r9: fix another compile error without --with-system-tzdata configured (Michael Heimpold)
r8: fix compile error without --with-system-tzdata configured
r7: improve check for valid timezone id to exclude directories
-r6: fix fd leak in r5, fix country code/BC flag use in
+r6: fix fd leak in r5, fix country code/BC flag use in
timezone_identifiers_list() using system db,
fix use of PECL timezonedb to override system db,
r5: reverts addition of "System/Localtime" fake tzname.
@@ -19,10 +20,9 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
r2: add filesystem trawl to set up name alias index
r1: initial revision
-diff --git a/ext/date/lib/parse_tz.c b/ext/date/lib/parse_tz.c
-index 5d2aec9..671b398 100644
---- a/ext/date/lib/parse_tz.c
-+++ b/ext/date/lib/parse_tz.c
+diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/lib/parse_tz.c
+--- php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata 2015-04-30 00:00:18.000000000 +0200
++++ php-5.6.9RC1/ext/date/lib/parse_tz.c 2015-04-30 06:36:47.019617321 +0200
@@ -20,6 +20,16 @@
#include "timelib.h"
@@ -53,25 +53,18 @@ index 5d2aec9..671b398 100644
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
# if defined(__LITTLE_ENDIAN__)
-@@ -51,9 +66,14 @@
-
- static void read_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
+@@ -53,6 +68,10 @@ static int read_preamble(const unsigned
{
-- /* skip ID */
-- *tzf += 4;
--
-+ if (memcmp(tzf, "TZif", 4) == 0) {
-+ *tzf += 20;
-+ return;
-+ }
-+
-+ /* skip ID */
-+ *tzf += 4;
-+
- /* read BC flag */
- tz->bc = (**tzf == '\1');
- *tzf += 1;
-@@ -256,7 +276,418 @@ void timelib_dump_tzinfo(timelib_tzinfo *tz)
+ uint32_t version;
+
++ if (memcmp(*tzf, "TZif", 4) == 0) {
++ *tzf += 20;
++ return 0;
++ }
+ /* read ID */
+ version = (*tzf)[3] - '0';
+ *tzf += 4;
+@@ -296,7 +315,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
}
}
@@ -491,11 +484,11 @@ index 5d2aec9..671b398 100644
{
int left = 0, right = tzdb->index_size - 1;
#ifdef HAVE_SETLOCALE
-@@ -295,36 +726,135 @@ static int seek_to_tz_position(const unsigned char **tzf, char *timezone, const
+@@ -335,21 +765,87 @@ static int seek_to_tz_position(const uns
return 0;
}
-+static int seek_to_tz_position(const unsigned char **tzf, char *timezone,
++static int seek_to_tz_position(const unsigned char **tzf, char *timezone,
+ char **map, size_t *maplen,
+ const timelib_tzdb *tzdb)
+{
@@ -507,15 +500,14 @@ index 5d2aec9..671b398 100644
+ if (orig == NULL) {
+ return 0;
+ }
-+
++
+ (*tzf) = (unsigned char *)orig ;
+ *map = orig;
-+
-+ return 1;
++ return 1;
+ }
-+ else
++ else
+#endif
-+ {
++ {
+ return inmem_seek_to_tz_position(tzf, timezone, tzdb);
+ }
+}
@@ -530,11 +522,10 @@ index 5d2aec9..671b398 100644
+ tmp->data = NULL;
+ create_zone_index(tmp);
+ system_location_table = create_location_table();
-+ fake_data_segment(tmp, system_location_table);
++ fake_data_segment(tmp, system_location_table);
+ timezonedb_system = tmp;
+ }
+
-+
+ return timezonedb_system;
+#else
return &timezonedb_builtin;
@@ -558,45 +549,54 @@ index 5d2aec9..671b398 100644
- return (seek_to_tz_position(&tzf, timezone, tzdb));
+
+#ifdef HAVE_SYSTEM_TZDATA
-+ if (tzdb == timezonedb_system) {
-+ char fname[PATH_MAX];
-+ struct stat st;
-+
-+ if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
-+ return 0;
-+ }
-+
-+ if (system_location_table) {
-+ if (find_zone_info(system_location_table, timezone) != NULL) {
-+ /* found in cache */
-+ return 1;
-+ }
-+ }
-+
-+ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
-+
-+ return stat(fname, &st) == 0 && is_valid_tzfile(&st);
-+ }
-+#endif
++ if (tzdb == timezonedb_system) {
++ char fname[PATH_MAX];
++ struct stat st;
+
++ if (timezone[0] == '\0' || strstr(timezone, "..") != NULL) {
++ return 0;
++ }
++
++ if (system_location_table) {
++ if (find_zone_info(system_location_table, timezone) != NULL) {
++ /* found in cache */
++ return 1;
++ }
++ }
++
++ snprintf(fname, sizeof fname, ZONEINFO_PREFIX "/%s", canonical_tzname(timezone));
++
++ return stat(fname, &st) == 0 && is_valid_tzfile(&st);
++ }
++#endif
+ return (inmem_seek_to_tz_position(&tzf, timezone, tzdb));
}
+ static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
+@@ -374,24 +870,54 @@ static void read_64bit_header(const unsi
timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
{
const unsigned char *tzf;
+ char *memmap = NULL;
+ size_t maplen;
timelib_tzinfo *tmp;
+ int version;
- if (seek_to_tz_position(&tzf, timezone, tzdb)) {
+ if (seek_to_tz_position(&tzf, timezone, &memmap, &maplen, tzdb)) {
tmp = timelib_tzinfo_ctor(timezone);
- read_preamble(&tzf, tmp);
+ version = read_preamble(&tzf, tmp);
read_header(&tzf, tmp);
read_transistions(&tzf, tmp);
read_types(&tzf, tmp);
+- if (version == 2) {
+- skip_64bit_preamble(&tzf, tmp);
+- read_64bit_header(&tzf, tmp);
+- skip_64bit_transistions(&tzf, tmp);
+- skip_64bit_types(&tzf, tmp);
+- skip_posix_string(&tzf, tmp);
+- }
- read_location(&tzf, tmp);
+
+#ifdef HAVE_SYSTEM_TZDATA
@@ -624,16 +624,22 @@ index 5d2aec9..671b398 100644
+ } else
+#endif
+ {
++ if (version == 2) {
++ skip_64bit_preamble(&tzf, tmp);
++ read_64bit_header(&tzf, tmp);
++ skip_64bit_transistions(&tzf, tmp);
++ skip_64bit_types(&tzf, tmp);
++ skip_posix_string(&tzf, tmp);
++ }
+ /* PHP-style - use the embedded info. */
+ read_location(&tzf, tmp);
-+ }
++ }
} else {
tmp = NULL;
}
-diff --git a/ext/date/lib/timelib.m4 b/ext/date/lib/timelib.m4
-index c725572..4c837c7 100644
---- a/ext/date/lib/timelib.m4
-+++ b/ext/date/lib/timelib.m4
+diff -up php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata php-5.6.9RC1/ext/date/lib/timelib.m4
+--- php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata 2015-04-30 00:00:18.000000000 +0200
++++ php-5.6.9RC1/ext/date/lib/timelib.m4 2015-04-30 06:32:08.549500385 +0200
@@ -78,3 +78,17 @@ stdlib.h
dnl Check for strtoll, atoll
@@ -652,4 +658,3 @@ index c725572..4c837c7 100644
+ fi
+fi
+
-
diff --git a/php56.spec b/php56.spec
index ba60e22..b43975d 100644
--- a/php56.spec
+++ b/php56.spec
@@ -131,7 +131,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.6.8
+Version: 5.6.9
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
%else
@@ -183,7 +183,7 @@ Patch21: php-5.4.7-odbctimer.patch
# Functional changes
Patch40: php-5.4.0-dlopen.patch
-Patch42: php-5.6.3-systzdata-v11.patch
+Patch42: php-5.6.9-systzdata-v12.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -1003,6 +1003,8 @@ mkdir build-cgi build-apache build-embedded \
rm ext/date/tests/timezone_location_get.phpt
rm ext/date/tests/timezone_version_get.phpt
rm ext/date/tests/timezone_version_get_basic1.phpt
+# Should be skipped but fails sometime
+rm ext/standard/tests/file/file_get_contents_error001.phpt
# fails sometime
rm ext/sockets/tests/mcast_ipv?_recv.phpt
# cause stack exhausion
@@ -1957,6 +1959,10 @@ fi
%changelog
+* Fri May 15 2015 Remi Collet <remi@fedoraproject.org> 5.6.9-1
+- Update to 5.6.9
+ http://www.php.net/releases/5_6_9.php
+
* Thu Apr 16 2015 Remi Collet <remi@fedoraproject.org> 5.6.8-1
- Update to 5.6.8
http://www.php.net/releases/5_6_8.php