summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-07 16:24:07 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-07 16:24:07 +0100
commitf27cc6e50cf7d027df0aca5a627adbe3130b2385 (patch)
tree43e965f60039e2cb46ae8f82247271e9a5530b6c
parentee870e0fdf1d6de70e4368f9cb9acd810c5f73ce (diff)
php 5.6: adapt for F24
-rw-r--r--failed.txt6
-rw-r--r--macros.php2
-rw-r--r--php56.spec34
3 files changed, 21 insertions, 21 deletions
diff --git a/failed.txt b/failed.txt
index aa19c3b..e8bde1b 100644
--- a/failed.txt
+++ b/failed.txt
@@ -15,15 +15,17 @@ $ grep -r 'Tests failed' /var/lib/mock/56*/build.log
/var/lib/mock/fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc23i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/fc23x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc24i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc24x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
el5i, el5x
openssl_x509_parse() basic test for OpenSSL 0.9 [ext/openssl/tests/openssl_x509_parse_basic_v9.phpt]
sni_server [ext/openssl/tests/sni_server.phpt]
Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
-el5i, el6i, fc20i, fc21i, fc22i, fc23i
+el5i, el6i, fc20i, fc21i, fc22i, fc23i, fc24i
Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-fc20i, fc21i, fc22i, fc23i
+fc20i, fc21i, fc22i, fc23i, fc24i
Bug #53437 DateInterval unserialize bad data, 32 bit [ext/date/tests/bug53437_var3.phpt]
el6x, el7x, fc20x
strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
diff --git a/macros.php b/macros.php
index 784d601..0c750a7 100644
--- a/macros.php
+++ b/macros.php
@@ -17,3 +17,5 @@
%__php %{_bindir}/php
%__ztsphp %{_bindir}/zts-php
+
+
diff --git a/php56.spec b/php56.spec
index 87dd224..5e95e82 100644
--- a/php56.spec
+++ b/php56.spec
@@ -146,11 +146,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.6.19
-%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
-%else
-Release: 1%{?dist}
-%endif
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -158,14 +154,10 @@ License: PHP and Zend and BSD
Group: Development/Languages
URL: http://www.php.net/
-%if 0%{?snapdate}
-Source0: http://snaps.php.net/php5.6-%{snapdate}.tar.xz
-%else
# Need to download official tarball and strip non-free stuff
# wget http://www.php.net/distributions/php-%%{version}%%{?rcver}.tar.xz
# ./strip.sh %%{version}
Source0: php-%{version}%{?rcver}-strip.tar.xz
-%endif
Source1: php.conf
Source2: php.ini
Source3: macros.php
@@ -254,9 +246,6 @@ BuildRequires: libzip-devel >= 0.11
%if %{with_dtrace}
BuildRequires: systemtap-sdt-devel
%endif
-%if 0%{?snapdate}
-BuildRequires: bison
-%endif
Obsoletes: php53, php53u, php54w, php55u, php55w, php56u, php56w
# Avoid obsoleting php54 from RHSCL
@@ -952,12 +941,7 @@ echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzi
# ensure than current httpd use prefork MPM.
httpd -V | grep -q 'threaded:.*yes' && exit 1
-%if 0%{?snapdate}
-%setup -q -n php5.6-%{snapdate}
-rm -rf ext/json
-%else
%setup -q -n php-%{version}%{?rcver}
-%endif
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
@@ -1038,8 +1022,8 @@ sed -e 's/64321/64322/' -i ext/openssl/tests/*.phpt
# Safety check for API version change.
pver=$(sed -n '/#define PHP_VERSION /{s/.* "//;s/".*$//;p}' main/php_version.h)
-if test "x${pver}" != "x%{version}%{?rcver}%{?snapdate:-dev}"; then
- : Error: Upstream PHP version is now ${pver}, expecting %{version}%{?rcver}%{?snapdate:-dev}.
+if test "x${pver}" != "x%{version}%{?rcver}"; then
+ : Error: Upstream PHP version is now ${pver}, expecting %{version}%{?rcver}.
: Update the version/rcver macros and rebuild.
exit 1
fi
@@ -1551,6 +1535,9 @@ install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
+%if 0%{?fedora} >= 24
+install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/peclxml
+%endif
%if %{with_lsws}
install -m 755 build-apache/sapi/litespeed/php $RPM_BUILD_ROOT%{_bindir}/lsphp
@@ -1727,6 +1714,9 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "/zts/d" \
%endif
< %{SOURCE3} > macros.php
+%if 0%{?fedora} >= 24
+echo '%pecl_xmldir %{_localstatedir}/lib/php/peclxml' >>macros.php
+%endif
install -m 644 -D macros.php \
$RPM_BUILD_ROOT%{macrosdir}/macros.php
@@ -1864,6 +1854,9 @@ fi
%dir %{_libdir}/php-zts/modules
%endif
%dir %{_localstatedir}/lib/php
+%if 0%{?fedora} >= 24
+%dir %{_localstatedir}/lib/php/peclxml
+%endif
%dir %{_datadir}/php
%files cli
@@ -1994,6 +1987,9 @@ fi
%changelog
+* Mon Mar 7 2016 Remi Collet <remi@fedoraproject.org> 5.6.19-2
+- adapt for F24: define %%pecl_xmldir and own it
+
* Thu Mar 3 2016 Remi Collet <remi@fedoraproject.org> 5.6.19-1
- Update to 5.6.19
http://www.php.net/releases/5_6_19.php