summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-28 08:18:12 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-28 08:18:12 +0200
commited3bb798ee62a117f4466b065bf7ba1e278285f6 (patch)
tree7d02a2d3ceefafd261fdcae9ca18b7ef7d981a9a
parenteb74832b17769e1d2f98e95ece542cc423a2b5ec (diff)
PHP 5.6.0 is GA ! :)
-rw-r--r--php-bug67878.patch201
-rw-r--r--php56.spec28
2 files changed, 221 insertions, 8 deletions
diff --git a/php-bug67878.patch b/php-bug67878.patch
new file mode 100644
index 0000000..c2669cf
--- /dev/null
+++ b/php-bug67878.patch
@@ -0,0 +1,201 @@
+From e02616866fe2461836dc8f7f6e369b3b25644cc4 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 21 Aug 2014 09:09:21 +0200
+Subject: [PATCH] Fix bug #67878 program_prefix not honoured in man pages
+
+- add @program_prefix@ in php, phpize and php-config man pages
+- set date to 2014
+- fix "SEE ALSO" alignment
+---
+ sapi/cli/php.1.in | 34 +++++++++++++++++-----------------
+ scripts/man1/php-config.1.in | 14 +++++++-------
+ scripts/man1/phpize.1.in | 14 +++++++-------
+ 3 files changed, 31 insertions(+), 31 deletions(-)
+
+diff --git a/sapi/cli/php.1.in b/sapi/cli/php.1.in
+index 4d536df..c062f3d 100644
+--- a/sapi/cli/php.1.in
++++ b/sapi/cli/php.1.in
+@@ -1,24 +1,24 @@
+-.TH PHP 1 "2014" "The PHP Group" "Scripting Language"
++.TH @program_prefix@php 1 "2014" "The PHP Group" "Scripting Language"
+ .SH NAME
+-php \- PHP Command Line Interface 'CLI'
++@program_prefix@php \- PHP Command Line Interface 'CLI'
+ .P
+-php-cgi \- PHP Common Gateway Interface 'CGI' command
++@program_prefix@php-cgi \- PHP Common Gateway Interface 'CGI' command
+ .SH SYNOPSIS
+-.B php
++.B @program_prefix@php
+ [options] [
+ .B \-f\fP ]
+ .IR file
+ [[\-\-]
+ .IR args.\|.\|. ]
+ .LP
+-.B php
++.B @program_prefix@php
+ [options]
+ .B \-r
+ .IR code
+ [[\-\-]
+ .IR args.\|.\|. ]
+ .LP
+-.B php
++.B @program_prefix@php
+ [options] [\-B
+ .IR begin_code ]
+ .B \-R
+@@ -28,7 +28,7 @@ php-cgi \- PHP Common Gateway Interface 'CGI' command
+ [[\-\-]
+ .IR args.\|.\|. ]
+ .LP
+-.B php
++.B @program_prefix@php
+ [options] [\-B
+ .IR begin_code ]
+ .B \-F
+@@ -38,13 +38,13 @@ php-cgi \- PHP Common Gateway Interface 'CGI' command
+ [[\-\-]
+ .IR args.\|.\|. ]
+ .LP
+-.B php
++.B @program_prefix@php
+ [options] \-\- [
+ .IR args.\|.\|. ]
+ .LP
+-\fBphp \fP[options] \fB\-a\fP
++\fB@program_prefix@php \fP[options] \fB\-a\fP
+ .LP
+-.B php
++.B @program_prefix@php
+ [options] \-S
+ .IR addr:port
+ [\-t
+@@ -374,35 +374,35 @@ The standard configuration file will only be used when
+ cannot be found.
+ .SH EXAMPLES
+ .TP 5
+-\fIphp \-r 'echo "Hello World\\n";'\fP
++\fI@program_prefix@php \-r 'echo "Hello World\\n";'\fP
+ This command simply writes the text "Hello World" to standard out.
+ .TP
+-\fIphp \-r 'print_r(gd_info());'\fP
++\fI@program_prefix@php \-r 'print_r(gd_info());'\fP
+ This shows the configuration of your gd extension. You can use this
+ to easily check which image formats you can use. If you have any
+ dynamic modules you may want to use the same ini file that php uses
+ when executed from your webserver. There are more extensions which
+ have such a function. For dba use:
+ .RS
+-\fIphp \-r 'print_r(dba_handlers(1));'\fP
++\fI@program_prefix@php \-r 'print_r(dba_handlers(1));'\fP
+ .RE
+ .TP
+-\fIphp \-R 'echo strip_tags($argn)."\\n";'\fP
++\fI@program_prefix@php \-R 'echo strip_tags($argn)."\\n";'\fP
+ This PHP command strips off the HTML tags line by line and outputs the
+ result. To see how it works you can first look at the following PHP command
+ \'\fIphp \-d html_errors=1 \-i\fP\' which uses PHP to output HTML formatted
+ configuration information. If you then combine those two
+ \'\fIphp \.\.\.|php \.\.\.\fP\' you'll see what happens.
+ .TP
+-\fIphp \-E 'echo "Lines: $argi\\n";'\fP
++\fI@program_prefix@php \-E 'echo "Lines: $argi\\n";'\fP
+ Using this PHP command you can count the lines being input.
+ .TP
+-\fIphp \-R '@$l+=count(file($argn));' \-E 'echo "Lines:$l\\n";'\fP
++\fI@program_prefix@php \-R '@$l+=count(file($argn));' \-E 'echo "Lines:$l\\n";'\fP
+ In this example PHP expects each input line being a file. It counts all lines
+ of the files specified by each input line and shows the summarized result.
+ You may combine this with tools like find and change the php scriptlet.
+ .TP
+-\fIphp \-R 'echo "$argn\\n"; fgets(STDIN);'\fP
++\fI@program_prefix@php \-R 'echo "$argn\\n"; fgets(STDIN);'\fP
+ Since you have access to STDIN from within \-B \-R \-F and \-E you can skip
+ certain input lines with your code. But note that in such cases $argi only
+ counts the lines being processed by php itself. Having read this you will
+diff --git a/scripts/man1/php-config.1.in b/scripts/man1/php-config.1.in
+index 5c60408..ae2ee56 100644
+--- a/scripts/man1/php-config.1.in
++++ b/scripts/man1/php-config.1.in
+@@ -1,12 +1,12 @@
+-.TH php\-config 1 "2010" "The PHP Group" "Scripting Language"
++.TH @program_prefix@php\-config 1 "2014" "The PHP Group" "Scripting Language"
+ .SH NAME
+-php\-config \- get information about PHP configuration and compile options
++@program_prefix@php\-config \- get information about PHP configuration and compile options
+ .SH SYNOPSIS
+-.B php\-config
++.B @program_prefix@php\-config
+ [options]
+ .LP
+ .SH DESCRIPTION
+-.B php\-config
++.B @program_prefix@php\-config
+ is a simple shell script for obtaining information about installed PHP configuration.
+ .SH OPTIONS
+ .TP 15
+@@ -57,15 +57,15 @@ PHP version
+ .PD 0
+ .B \-\-vernum
+ PHP version as integer
+-.TP
++.RS
+ .PD 1
+ .P
+ .SH SEE ALSO
+-.BR php (1)
++.BR @program_prefix@php (1)
+ .SH VERSION INFORMATION
+ This manpage describes \fBphp\fP, version @PHP_VERSION@.
+ .SH COPYRIGHT
+-Copyright \(co 1997\-2010 The PHP Group
++Copyright \(co 1997\-2014 The PHP Group
+ .LP
+ This source file is subject to version 3.01 of the PHP license,
+ that is bundled with this package in the file LICENSE, and is
+diff --git a/scripts/man1/phpize.1.in b/scripts/man1/phpize.1.in
+index 8f62f86..e49adb1 100644
+--- a/scripts/man1/phpize.1.in
++++ b/scripts/man1/phpize.1.in
+@@ -1,12 +1,12 @@
+-.TH phpize 1 "2010" "The PHP Group" "Scripting Language"
++.TH @program_prefix@phpize 1 "2014" "The PHP Group" "Scripting Language"
+ .SH NAME
+-phpize \- prepare a PHP extension for compiling
++@program_prefix@phpize \- prepare a PHP extension for compiling
+ .SH SYNOPSIS
+-.B phpize
++.B @program_prefix@phpize
+ [options]
+ .LP
+ .SH DESCRIPTION
+-.B phpize
++.B @program_prefix@phpize
+ is a shell script to prepare PHP extension for compiling.
+ .SH OPTIONS
+ .TP 15
+@@ -24,15 +24,15 @@ Prints usage information
+ .PD 1
+ .B \-v
+ Prints API version information
+-.TP
++.RS
+ .PD 1
+ .P
+ .SH SEE ALSO
+-.BR php (1)
++.BR @program_prefix@php (1)
+ .SH VERSION INFORMATION
+ This manpage describes \fBphp\fP, version @PHP_VERSION@.
+ .SH COPYRIGHT
+-Copyright \(co 1997\-2010 The PHP Group
++Copyright \(co 1997\-2014 The PHP Group
+ .LP
+ This source file is subject to version 3.01 of the PHP license,
+ that is bundled with this package in the file LICENSE, and is
+--
+1.9.2
+
diff --git a/php56.spec b/php56.spec
index aeda759..d78d81e 100644
--- a/php56.spec
+++ b/php56.spec
@@ -121,7 +121,7 @@
%endif
#global snapdate 201405061030
-%global rcver RC4
+#global rcver RC4
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -189,6 +189,7 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-bug67878.patch
# Security fixes (200+)
@@ -929,6 +930,7 @@ rm -rf ext/json
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .b67878
# security patches
@@ -1183,12 +1185,14 @@ build --libdir=%{_libdir}/php \
--with-mysql=shared,mysqlnd \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=%{mysql_sock} \
+%if %{with_oci8}
%ifarch x86_64
- %{?_with_oci8:--with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever}} \
+ --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
%else
- %{?_with_oci8:--with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever}} \
+ --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
+%endif
+ --with-pdo-oci=shared,instantclient,/usr,%{oraclever} \
%endif
- %{?_with_oci8:--with-pdo-oci=shared,instantclient,/usr,%{oraclever}} \
--with-interbase=shared,%{_libdir}/firebird \
--with-pdo-firebird=shared,%{_libdir}/firebird \
--enable-dom=shared \
@@ -1322,12 +1326,14 @@ build --includedir=%{_includedir}/php-zts \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=%{mysql_sock} \
--enable-mysqlnd-threading \
+%if %{with_oci8}
%ifarch x86_64
- %{?_with_oci8:--with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever}} \
+ --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
%else
- %{?_with_oci8:--with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever}} \
+ --with-oci8=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
+%endif
+ --with-pdo-oci=shared,instantclient,/usr,%{oraclever} \
%endif
- %{?_with_oci8:--with-pdo-oci=shared,instantclient,/usr,%{oraclever}} \
--with-interbase=shared,%{_libdir}/firebird \
--with-pdo-firebird=shared,%{_libdir}/firebird \
--enable-dom=shared \
@@ -1540,7 +1546,9 @@ for mod in pgsql odbc ldap snmp xmlrpc imap \
%if %{with_zip}
zip \
%endif
- %{?_with_oci8:oci8} %{?_with_oci8:pdo_oci} \
+%if %{with_oci8}
+ oci8 pdo_oci \
+%endif
interbase pdo_firebird \
%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
sqlite3 \
@@ -1902,6 +1910,10 @@ fi
%changelog
+* Thu Aug 28 2014 Remi Collet <remi@fedoraproject.org> 5.6.0-1
+- PHP 5.6.0 is GA
+- fix ZTS man pages, upstream patch for 67878
+
* Wed Aug 20 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.22.RC4
- backport rawhide stuff for F21+ and httpd-filesystem
with support for SetHandler to proxy_fcgi