summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-13 15:27:12 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-13 15:27:12 +0100
commit7370046877d5a9423bddd72f0c3b91dc61791dcc (patch)
tree913a0749453b21db1828d16355f8597fbddbefc3
parent3e0e6bbce114c07938dd029c3c780b339a98b9af (diff)
PHP 5.6.3
-rw-r--r--php-bug68074.patch60
-rw-r--r--php-gmp41.patch27
-rw-r--r--php56.spec9
3 files changed, 35 insertions, 61 deletions
diff --git a/php-bug68074.patch b/php-bug68074.patch
deleted file mode 100644
index 04451c1..0000000
--- a/php-bug68074.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 0d776ef87b7b0c1e970c424cc5dcdf4cd6f500ac Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 24 Sep 2014 10:34:55 +0200
-Subject: [PATCH] Fix bug #68074 Allow to use system cipher list instead of
- hardcoded value
-
----
- ext/openssl/config0.m4 | 6 ++++++
- ext/openssl/xp_ssl.c | 9 ++++++---
- 2 files changed, 12 insertions(+), 3 deletions(-)
-
-diff --git a/ext/openssl/config0.m4 b/ext/openssl/config0.m4
-index a97114f..701e488 100644
---- a/ext/openssl/config0.m4
-+++ b/ext/openssl/config0.m4
-@@ -8,6 +8,9 @@ PHP_ARG_WITH(openssl, for OpenSSL support,
- PHP_ARG_WITH(kerberos, for Kerberos support,
- [ --with-kerberos[=DIR] OPENSSL: Include Kerberos support], no, no)
-
-+PHP_ARG_WITH(system-ciphers, whether to use system default cipher list instead of hardcoded value,
-+[ --with-system-ciphers OPENSSL: Use system default cipher list instead of hardcoded value], no, no)
-+
- if test "$PHP_OPENSSL" != "no"; then
- PHP_NEW_EXTENSION(openssl, openssl.c xp_ssl.c, $ext_shared)
- PHP_SUBST(OPENSSL_SHARED_LIBADD)
-@@ -25,4 +28,7 @@ if test "$PHP_OPENSSL" != "no"; then
- ], [
- AC_MSG_ERROR([OpenSSL check failed. Please check config.log for more information.])
- ])
-+ if test "$PHP_SYSTEM_CIPHERS" != "no"; then
-+ AC_DEFINE(USE_OPENSSL_SYSTEM_CIPHERS,1,[ Use system default cipher list instead of hardcoded value ])
-+ fi
- fi
-diff --git a/ext/openssl/xp_ssl.c b/ext/openssl/xp_ssl.c
-index de9e991..2f81dc7 100644
---- a/ext/openssl/xp_ssl.c
-+++ b/ext/openssl/xp_ssl.c
-@@ -1476,13 +1476,16 @@ int php_openssl_setup_crypto(php_stream *stream,
- }
-
- GET_VER_OPT_STRING("ciphers", cipherlist);
-+#ifndef USE_OPENSSL_SYSTEM_CIPHERS
- if (!cipherlist) {
- cipherlist = OPENSSL_DEFAULT_STREAM_CIPHERS;
- }
-- if (SSL_CTX_set_cipher_list(sslsock->ctx, cipherlist) != 1) {
-- return FAILURE;
-+#endif
-+ if (cipherlist) {
-+ if (SSL_CTX_set_cipher_list(sslsock->ctx, cipherlist) != 1) {
-+ return FAILURE;
-+ }
- }
--
- if (FAILURE == set_local_cert(sslsock->ctx, stream TSRMLS_CC)) {
- return FAILURE;
- }
---
-2.1.0
-
diff --git a/php-gmp41.patch b/php-gmp41.patch
new file mode 100644
index 0000000..5db1acd
--- /dev/null
+++ b/php-gmp41.patch
@@ -0,0 +1,27 @@
+From 1b156207446e0c5ec8a9476ad0966b5daa82f516 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 13 Nov 2014 13:08:00 +0100
+Subject: [PATCH] Fix build with gmp < 4.2
+
+See 3d6d863ccbd10d212352462b587ae1573af4f1d1
+and acd7fcf55f81955e4837c750a5e45f83d3c55ba2
+---
+ ext/gmp/gmp.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/gmp/gmp.c b/ext/gmp/gmp.c
+index e9c1ad3..de61f1c 100644
+--- a/ext/gmp/gmp.c
++++ b/ext/gmp/gmp.c
+@@ -1776,7 +1776,7 @@ static void gmp_init_random(TSRMLS_D)
+ #if GMP_42_OR_NEWER
+ gmp_randinit_mt(GMPG(rand_state));
+ #else
+- gmp_randinit_lc_2exp(GMPG(rand_state), 32L);
++ gmp_randinit_lc_2exp_size(GMPG(rand_state), 32L);
+ #endif
+ /* Seed */
+ gmp_randseed_ui(GMPG(rand_state), GENERATE_SEED());
+--
+2.1.0
+
diff --git a/php56.spec b/php56.spec
index 7db2508..fe0fd6e 100644
--- a/php56.spec
+++ b/php56.spec
@@ -127,7 +127,7 @@
%endif
#global snapdate 201405061030
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -197,6 +197,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-gmp41.patch
# Security fixes (200+)
@@ -954,6 +955,7 @@ rm -rf ext/json
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .gmp41
# security patches
@@ -1943,6 +1945,11 @@ fi
%changelog
+* Thu Nov 13 2014 Remi Collet <remi@fedoraproject.org> 5.6.3-1
+- Update to PHP 5.6.3
+ http://php.net/releases/5_6_3.php
+- add upstream patch for EL-5 and gmp 4.1
+
* Thu Oct 30 2014 Remi Collet <rcollet@redhat.com> 5.6.3-0.4.RC1
- php 5.6.3RC1 (refreshed, phpdbg changes reverted)