summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-08 18:30:07 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-08 18:30:07 +0200
commit2a986cc7ff0e927f0264ca32699d19396ea874a8 (patch)
treeb9a915336996e2e498a1b8be3a49de01fb234e00
parentb1dc4792f5abc0b42c72b9a5d579abe3246cb4d0 (diff)
php 5.6: numerical prefix, .user.ini, ifmodule
-rw-r--r--php.conf55
-rw-r--r--php56.spec24
2 files changed, 54 insertions, 25 deletions
diff --git a/php.conf b/php.conf
index 7000043..730867e 100644
--- a/php.conf
+++ b/php.conf
@@ -1,9 +1,16 @@
#
-# Cause the PHP interpreter to handle files with a .php extension.
-#
-<FilesMatch \.php$>
- SetHandler application/x-httpd-php
-</FilesMatch>
+# The following lines prevent .user.ini files from being viewed by Web clients.
+#
+<Files ".user.ini">
+ <IfModule mod_authz_core.c>
+ Require all denied
+ </IfModule>
+ <IfModule !mod_authz_core.c>
+ Order allow,deny
+ Deny from all
+ Satisfy All
+ </IfModule>
+</Files>
#
# Allow php to handle Multiviews
@@ -16,18 +23,28 @@ AddType text/html .php
#
DirectoryIndex index.php
-#
-# Uncomment the following lines to allow PHP to pretty-print .phps
-# files as PHP source code:
-#
-#<FilesMatch \.phps$>
-# SetHandler application/x-httpd-php-source
-#</FilesMatch>
+# mod_php options
+<IfModule mod_php5.c>
+ #
+ # Cause the PHP interpreter to handle files with a .php extension.
+ #
+ <FilesMatch \.php$>
+ SetHandler application/x-httpd-php
+ </FilesMatch>
-#
-# Apache specific PHP configuration options
-# those can be override in each configured vhost
-#
-php_value session.save_handler "files"
-php_value session.save_path "/var/lib/php/session"
-php_value soap.wsdl_cache_dir "/var/lib/php/wsdlcache"
+ #
+ # Uncomment the following lines to allow PHP to pretty-print .phps
+ # files as PHP source code:
+ #
+ #<FilesMatch \.phps$>
+ # SetHandler application/x-httpd-php-source
+ #</FilesMatch>
+
+ #
+ # Apache specific PHP configuration options
+ # those can be override in each configured vhost
+ #
+ php_value session.save_handler "files"
+ php_value session.save_path "/var/lib/php/session"
+ php_value soap.wsdl_cache_dir "/var/lib/php/wsdlcache"
+</IfModule>
diff --git a/php56.spec b/php56.spec
index 9a581b2..15dc98a 100644
--- a/php56.spec
+++ b/php56.spec
@@ -120,7 +120,7 @@ Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.6.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.4.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.5.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 1%{?dist}
%endif
@@ -1009,7 +1009,7 @@ chmod 644 README.*
echo "d /run/php-fpm 755 root root" >php-fpm.tmpfiles
# Some extensions have their own configuration file
-cp %{SOURCE50} .
+cp %{SOURCE50} 10-opcache.ini
# Regenerated bison files
# to force, rm Zend/zend_{language,ini}_parser.[ch]
@@ -1561,10 +1561,17 @@ for mod in pgsql odbc ldap snmp xmlrpc imap \
mysql mysqli pdo_mysql \
%endif
; do
-if [ "$mod" = "wddx" ]
-then ini=xml_${mod}.ini
-else ini=${mod}.ini
-fi
+ case $mod in
+ opcache)
+ # Zend extensions
+ ini=10-${mod}.ini;;
+ pdo_*|mysqlnd_*|wddx|xmlreader|xmlrpc)
+ # Extensions with dependencies on 20-*
+ ini=30-${mod}.ini;;
+ *)
+ # Extensions with no dependency
+ ini=20-${mod}.ini;;
+ esac
if [ -f ${ini} ]; then
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
@@ -1898,6 +1905,11 @@ fi
%changelog
+* Tue Apr 8 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.5.201403261230
+- add numerical prefix to extension configuration files
+- prevent .user.ini files from being viewed by Web clients
+- load php directives only when mod_php is active
+
* Wed Mar 26 2014 Remi Collet <remi@fedoraproject.org> 5.6.0-0.4.201403261230
- new snapshot php5.6-201403261230
- oci8 version 2.0.9