summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-11 17:25:27 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-11 17:25:27 +0200
commit1a65e7f8823e02cd7295385d85157c8c991f10cc (patch)
tree5d3e2bcf45f6b196272d4084a62f1da7233dec49
parentdda4ebb554174cd11083f6157e616f419d62e98b (diff)
PHP 5.6: work on failed tests
-rw-r--r--failed22
-rw-r--r--php-5.6.0-noNO.patch43
-rw-r--r--php-5.6.0-openssl.patch32
-rw-r--r--php56.spec15
4 files changed, 92 insertions, 20 deletions
diff --git a/failed b/failed
index 0fada33..6102a6a 100644
--- a/failed
+++ b/failed
@@ -1,45 +1,37 @@
=====================================================================
FC20 i386 - June 10
=====================================================================
-3 FAILED TEST SUMMARY
+2 FAILED TEST SUMMARY
---------------------------------------------------------------------
Bug #41523 (strtotime('0000-00-00 00:00:00') is parsed as 1999-11-30) (32 bit) [ext/date/tests/bug41523.phpt]
Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-Test setlocale() function : usage variations - Setting all available locales in the platform [ext/standard/tests/strings/setlocale_variation2.phpt]
=====================================================================
FC20 x86_64 - June 10
=====================================================================
-3 FAILED TEST SUMMARY
+0 FAILED TEST SUMMARY
---------------------------------------------------------------------
-Test setlocale() function : usage variations - Setting all available locales in the platform [ext/standard/tests/strings/setlocale_variation2.phpt]
=====================================================================
FC19 i386
=====================================================================
-8 FAILED TEST SUMMARY
+2 FAILED TEST SUMMARY
---------------------------------------------------------------------
Bug #41523 (strtotime('0000-00-00 00:00:00') is parsed as 1999-11-30) (32 bit) [ext/date/tests/bug41523.phpt]
Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-Test setlocale() function : usage variations - Setting all available locales in the platform [ext/standard/tests/strings/setlocale_variation2.phpt]
=====================================================================
- 1 FC19 x86_64 - June 10
+ FC19 x86_64 - June 10
=====================================================================
-FAILED TEST SUMMARY
+0 FAILED TEST SUMMARY
---------------------------------------------------------------------
-Test setlocale() function : usage variations - Setting all available locales in the platform [ext/standard/tests/strings/setlocale_variation2.phpt]
=====================================================================
EL7 x86_64 - June 10
=====================================================================
-3 FAILED TEST SUMMARY
+0 FAILED TEST SUMMARY
---------------------------------------------------------------------
-Testing openssl_spki_verify()
-Creates SPKAC for all available key sizes & signature algorithms and tests for valid signature [ext/openssl/tests/openssl_spki_verify.phpt]
-Test setlocale() function : usage variations - Setting all available locales in the platform [ext/standard/tests/strings/setlocale_variation2.phpt]
=====================================================================
EL6 i386 - June 10
=====================================================================
-3 FAILED TEST SUMMARY
+2 FAILED TEST SUMMARY
---------------------------------------------------------------------
-Bug #54268 (Double free when destroy_zend_class fails) [Zend/tests/bug54268.phpt]
Bug #41523 (strtotime('0000-00-00 00:00:00') is parsed as 1999-11-30) (32 bit) [ext/date/tests/bug41523.phpt]
Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
=====================================================================
diff --git a/php-5.6.0-noNO.patch b/php-5.6.0-noNO.patch
new file mode 100644
index 0000000..52f54ab
--- /dev/null
+++ b/php-5.6.0-noNO.patch
@@ -0,0 +1,43 @@
+--- ext/standard/tests/strings/setlocale_variation2.phpt.orig 2014-06-11 16:10:00.259326468 +0200
++++ ext/standard/tests/strings/setlocale_variation2.phpt 2014-06-11 16:16:14.396138997 +0200
+@@ -52,6 +52,7 @@
+ //try different locale names
+ $failure_locale = array();
+ $success_count = 0;
++$expected = 0;
+
+ echo "-- Test setlocale() with all available locale in the system --\n";
+ // gather all locales installed in the system(stored $all_system_locales),
+@@ -61,6 +62,10 @@
+ if(setlocale(LC_ALL,$value )){
+ $success_count++;
+ }
++ else if ($value == 'no_NO.ISO-8859-1') {
++ // ignore this one, see rhbz #971416
++ $expected++;
++ }
+ else{
+ //failure values are put in to an array $failure_locale
+ $failure_locale[] = $value;
+@@ -69,11 +74,11 @@
+
+ echo "No of locales found on the machine = ".count($all_system_locales)."\n";
+ echo "No of setlocale() success = ".$success_count."\n";
+-echo "Expected no of failures = 0\n";
++echo "Expected no of failures = $expected\n";
+ echo "Test ";
+ // check if there were any failure of setlocale() function earlier, if any
+ // failure then dump the list of failing locales
+-if($success_count != count($all_system_locales)){
++if(($success_count + $expected) != count($all_system_locales)){
+ echo "FAILED\n";
+ echo "Names of locale() for which setlocale() failed ...\n";
+ var_dump($failure_locale);
+@@ -89,6 +94,6 @@
+ -- Test setlocale() with all available locale in the system --
+ No of locales found on the machine = %d
+ No of setlocale() success = %d
+-Expected no of failures = 0
++Expected no of failures = %d
+ Test PASSED
+ Done
diff --git a/php-5.6.0-openssl.patch b/php-5.6.0-openssl.patch
new file mode 100644
index 0000000..4167d2d
--- /dev/null
+++ b/php-5.6.0-openssl.patch
@@ -0,0 +1,32 @@
+--- ext/openssl/tests/openssl_spki_verify.phpt.orig 2014-06-11 16:52:01.794416390 +0200
++++ ext/openssl/tests/openssl_spki_verify.phpt 2014-06-11 16:53:34.629855059 +0200
+@@ -17,9 +17,7 @@
+ '4096'=>4096);
+
+ /* array of available hashings to test */
+-$algo = array('md4'=>OPENSSL_ALGO_MD4,
+- 'md5'=>OPENSSL_ALGO_MD5,
+- 'sha1'=>OPENSSL_ALGO_SHA1,
++$algo = array('sha1'=>OPENSSL_ALGO_SHA1,
+ 'sha224'=>OPENSSL_ALGO_SHA224,
+ 'sha256'=>OPENSSL_ALGO_SHA256,
+ 'sha384'=>OPENSSL_ALGO_SHA384,
+@@ -58,18 +56,6 @@
+ bool(true)
+ bool(false)
+ bool(true)
+-bool(false)
+-bool(true)
+-bool(false)
+-bool(true)
+-bool(false)
+-bool(true)
+-bool(false)
+-bool(true)
+-bool(false)
+-bool(true)
+-bool(false)
+-bool(true)
+ bool(false)
+ bool(true)
+ bool(false)
diff --git a/php56.spec b/php56.spec
index 308d3f1..d708280 100644
--- a/php56.spec
+++ b/php56.spec
@@ -197,6 +197,10 @@ Patch105: php-bug67413.patch
# Fixes for tests (300+)
# Revert changes for pcre < 8.34
Patch301: php-5.6.0-oldpcre.patch
+# see https://bugzilla.redhat.com/971416
+Patch302: php-5.6.0-noNO.patch
+# modern distro refuse to verify md4/md5 digests
+Patch303: php-5.6.0-openssl.patch
# WIP
@@ -929,6 +933,8 @@ rm -rf ext/json
%patch301 -p1 -b .pcre834
%endif
%endif
+%patch302 -p0 -b .971416
+%patch303 -p0 -b .md4md5
# WIP patch
@@ -957,9 +963,11 @@ mkdir build-cgi build-apache build-embedded \
# ----- Manage known as failed test -------
# affected by systzdata patch
-rm -f ext/date/tests/timezone_location_get.phpt
+rm ext/date/tests/timezone_location_get.phpt
# fails sometime
-rm -f ext/sockets/tests/mcast_ipv?_recv.phpt
+rm ext/sockets/tests/mcast_ipv?_recv.phpt
+# cause stack exhausion
+rm Zend/tests/bug54268.phpt
# Safety check for API version change.
pver=$(sed -n '/#define PHP_VERSION /{s/.* "//;s/".*$//;p}' main/php_version.h)
@@ -1393,9 +1401,6 @@ popd
%if %runselftest
cd build-apache
-# Increase stack size (required by bug54268.phpt)
-ulimit -s 32712
-
# Run tests, using the CLI SAPI
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
export SKIP_ONLINE_TESTS=1