summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-03 15:22:41 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-03 15:22:41 +0200
commit192fb529d508703c6799be60bf4bc10cd8bfe5b5 (patch)
tree58890c5ae652d45d9f827a79ba73525028188df3
parente557501fc3f793676fe77a9efe5a3eb292dba996 (diff)
PHP 5.6.13
-rw-r--r--failed.txt17
-rw-r--r--php-5.6.13-systzdata-v12.patch (renamed from php-5.6.9-systzdata-v12.patch)27
-rw-r--r--php56.spec8
3 files changed, 29 insertions, 23 deletions
diff --git a/failed.txt b/failed.txt
index 35dfeab..90e3ed1 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,29 +1,32 @@
-===== 5.6.12
+===== 5.6.13 (2015-09-03)
$ grep -r 'Tests failed' /var/lib/mock/56*/build.log
/var/lib/mock/el5i/build.log:Tests failed : 5 ( 0.0%) ( 0.1%)
/var/lib/mock/el5x/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
-/var/lib/mock/el6i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/el6i/build.log:Tests failed : 3 ( 0.0%) ( 0.0%)
/var/lib/mock/el6x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/el7x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc20i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/fc20x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/fc21i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/fc22i/build.log:Tests failed : 1 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc22i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc23i/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/fc23x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-el5i, el6i, fc20i, fc21i, fc22i
+el6i
+ Capture SSL session meta array in stream context [ext/openssl/tests/session_meta_capture.phpt]
+el5i, el6i, fc20i, fc21i, fc22i, fc23i
Bug #53437 DateInterval unserialize bad data, 32 bit [ext/date/tests/bug53437_var3.phpt]
- [1] Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
-
+ Bug #64146 (serialize incorrectly saving objects when they are cloned) [ext/standard/tests/serialize/bug64146.phpt]
el5i, el5x
openssl_x509_parse() basic test for OpenSSL 0.9 [ext/openssl/tests/openssl_x509_parse_basic_v9.phpt]
sni_server [ext/openssl/tests/sni_server.phpt]
Specific protocol method specification [ext/openssl/tests/stream_crypto_flags_004.phpt]
-[1] known issue, no fix found
+[1] #64146 known issue, no fix found
[2] proc_open erratic results...
diff --git a/php-5.6.9-systzdata-v12.patch b/php-5.6.13-systzdata-v12.patch
index aa3277c..8981212 100644
--- a/php-5.6.9-systzdata-v12.patch
+++ b/php-5.6.13-systzdata-v12.patch
@@ -20,9 +20,9 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
r2: add filesystem trawl to set up name alias index
r1: initial revision
-diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/lib/parse_tz.c
---- php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata 2015-04-30 00:00:18.000000000 +0200
-+++ php-5.6.9RC1/ext/date/lib/parse_tz.c 2015-04-30 06:36:47.019617321 +0200
+diff -up php-5.6.13/ext/date/lib/parse_tz.c.systzdata php-5.6.13/ext/date/lib/parse_tz.c
+--- php-5.6.13/ext/date/lib/parse_tz.c.systzdata 2015-09-03 02:02:45.000000000 +0200
++++ php-5.6.13/ext/date/lib/parse_tz.c 2015-09-03 12:50:52.555576944 +0200
@@ -20,6 +20,16 @@
#include "timelib.h"
@@ -40,11 +40,10 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
#include <stdio.h>
#ifdef HAVE_LOCALE_H
-@@ -31,7 +41,12 @@
- #else
- #include <strings.h>
+@@ -33,7 +43,11 @@
#endif
-+
+
+ #define TIMELIB_SUPPORTS_V2DATA
+#ifndef HAVE_SYSTEM_TZDATA
#include "timezonedb.h"
+#endif
@@ -53,7 +52,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
# if defined(__LITTLE_ENDIAN__)
-@@ -53,6 +68,10 @@ static int read_preamble(const unsigned
+@@ -55,6 +69,10 @@ static int read_preamble(const unsigned
{
uint32_t version;
@@ -64,7 +63,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
/* read ID */
version = (*tzf)[3] - '0';
*tzf += 4;
-@@ -296,7 +315,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
+@@ -298,7 +316,418 @@ void timelib_dump_tzinfo(timelib_tzinfo
}
}
@@ -484,7 +483,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
{
int left = 0, right = tzdb->index_size - 1;
#ifdef HAVE_SETLOCALE
-@@ -335,21 +765,87 @@ static int seek_to_tz_position(const uns
+@@ -337,21 +766,87 @@ static int seek_to_tz_position(const uns
return 0;
}
@@ -573,7 +572,7 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
}
static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
-@@ -374,24 +870,54 @@ static void read_64bit_header(const unsi
+@@ -376,24 +871,54 @@ static void read_64bit_header(const unsi
timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
{
const unsigned char *tzf;
@@ -637,9 +636,9 @@ diff -up php-5.6.9RC1/ext/date/lib/parse_tz.c.systzdata php-5.6.9RC1/ext/date/li
} else {
tmp = NULL;
}
-diff -up php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata php-5.6.9RC1/ext/date/lib/timelib.m4
---- php-5.6.9RC1/ext/date/lib/timelib.m4.systzdata 2015-04-30 00:00:18.000000000 +0200
-+++ php-5.6.9RC1/ext/date/lib/timelib.m4 2015-04-30 06:32:08.549500385 +0200
+diff -up php-5.6.13/ext/date/lib/timelib.m4.systzdata php-5.6.13/ext/date/lib/timelib.m4
+--- php-5.6.13/ext/date/lib/timelib.m4.systzdata 2015-09-03 02:02:45.000000000 +0200
++++ php-5.6.13/ext/date/lib/timelib.m4 2015-09-03 12:49:43.247226154 +0200
@@ -78,3 +78,17 @@ stdlib.h
dnl Check for strtoll, atoll
diff --git a/php56.spec b/php56.spec
index ffb2eb8..44313cc 100644
--- a/php56.spec
+++ b/php56.spec
@@ -147,7 +147,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.6.12
+Version: 5.6.13
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
%else
@@ -199,7 +199,7 @@ Patch21: php-5.4.7-odbctimer.patch
# Functional changes
Patch40: php-5.4.0-dlopen.patch
-Patch42: php-5.6.9-systzdata-v12.patch
+Patch42: php-5.6.13-systzdata-v12.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -1987,6 +1987,10 @@ fi
%changelog
+* Thu Sep 3 2015 Remi Collet <remi@fedoraproject.org> 5.6.13-1
+- Update to 5.6.13
+ http://www.php.net/releases/5_6_13.php
+
* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> 5.6.12-1
- Update to 5.6.12
http://www.php.net/releases/5_6_12.php