summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-19 15:40:46 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-19 15:40:46 +0200
commit0654391b7ffcd50fe49c8de4384d0132bc5805ac (patch)
treecf8e46734281be2161dea108f5c863971ff96f0b
parenteb0afc8ac64bcf380915e53fa58ba9413e95cc41 (diff)
php-config: reports all built sapis
-rw-r--r--php-5.2.4-embed.patch12
-rw-r--r--php-5.6.3-embed.patch24
-rw-r--r--php56.spec2
3 files changed, 25 insertions, 13 deletions
diff --git a/php-5.2.4-embed.patch b/php-5.2.4-embed.patch
deleted file mode 100644
index a9d5416..0000000
--- a/php-5.2.4-embed.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- php-5.2.4/sapi/embed/config.m4.embed
-+++ php-5.2.4/sapi/embed/config.m4
-@@ -12,7 +12,8 @@ if test "$PHP_EMBED" != "no"; then
- case "$PHP_EMBED" in
- yes|shared)
- PHP_EMBED_TYPE=shared
-- INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(prefix)/lib; \$(INSTALL) -m 0755 $SAPI_SHARED \$(INSTALL_ROOT)\$(prefix)/lib"
-+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS -release \$(PHP_MAJOR_VERSION).\$(PHP_MINOR_VERSION)"
-+ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(libdir); \$(LIBTOOL) --mode=install \$(INSTALL) -m 0755 \$(OVERALL_TARGET) \$(INSTALL_ROOT)\$(libdir)"
- ;;
- static)
- PHP_EMBED_TYPE=static
diff --git a/php-5.6.3-embed.patch b/php-5.6.3-embed.patch
new file mode 100644
index 0000000..d9c04f6
--- /dev/null
+++ b/php-5.6.3-embed.patch
@@ -0,0 +1,24 @@
+--- php-5.6.3/sapi/embed/config.m4.embed
++++ php-5.6.3/sapi/embed/config.m4
+@@ -12,7 +12,8 @@ if test "$PHP_EMBED" != "no"; then
+ case "$PHP_EMBED" in
+ yes|shared)
+ PHP_EMBED_TYPE=shared
+- INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(prefix)/lib; \$(INSTALL) -m 0755 $SAPI_SHARED \$(INSTALL_ROOT)\$(prefix)/lib"
++ EXTRA_LDFLAGS="$EXTRA_LDFLAGS -release \$(PHP_MAJOR_VERSION).\$(PHP_MINOR_VERSION)"
++ INSTALL_IT="\$(mkinstalldirs) \$(INSTALL_ROOT)\$(libdir); \$(LIBTOOL) --mode=install \$(INSTALL) -m 0755 \$(OVERALL_TARGET) \$(INSTALL_ROOT)\$(libdir)"
+ ;;
+ static)
+ PHP_EMBED_TYPE=static
+diff -up php-5.5.30/scripts/php-config.in.old php-5.5.30/scripts/php-config.in
+--- php-5.5.30/scripts/php-config.in.old 2015-10-19 15:17:31.944747715 +0200
++++ php-5.5.30/scripts/php-config.in 2015-10-19 15:17:58.278858083 +0200
+@@ -18,7 +18,7 @@ exe_extension="@EXEEXT@"
+ php_cli_binary=NONE
+ php_cgi_binary=NONE
+ configure_options="@CONFIGURE_OPTIONS@"
+-php_sapis="@PHP_INSTALLED_SAPIS@"
++php_sapis="apache2handler embed fpm @PHP_INSTALLED_SAPIS@"
+
+ # Set php_cli_binary and php_cgi_binary if available
+ for sapi in $php_sapis; do
diff --git a/php56.spec b/php56.spec
index c4cc581..1472ee6 100644
--- a/php56.spec
+++ b/php56.spec
@@ -189,7 +189,7 @@ Source99: php-fpm.init
# Build fixes
Patch5: php-5.6.3-includedir.patch
-Patch6: php-5.2.4-embed.patch
+Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-5.6.3-libdb.patch