summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-20 07:45:16 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-20 07:45:16 +0200
commit84b6dd5c1d998012d90f3ac5043e2cc593196c37 (patch)
treead7d843b2347aebb1236c7658e420403d540f7ba /Makefile
more-php56-php-extras: new package for rh-php56 on softwarecollections.org
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..6d8cadb
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+SRCDIR := $(shell pwd)
+NAME := php-extras
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
+
+debug:
+ time rpmbuild $(RPMDEFINES) --with debug -bb $(NAME).spec
+
+srpm:
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define "scl rh-php56" --define "scl_prefix rh-php56-" -bs $(NAME).spec