summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-17 08:01:16 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-17 08:01:16 +0200
commitf9def6e5cbe9649d39e35bcc5aee7bc5f025fc51 (patch)
tree7be1798a7604d9ef073921b88914e64f2df2f335
parentc39fe5234f51f5dc90aa2579e70961f76d5b2f45 (diff)
PHP: fix test for rhbz #971416
-rw-r--r--php-5.4.30-noNO.patch43
-rw-r--r--php-5.5.14-noNO.patch43
-rw-r--r--php55.spec8
3 files changed, 93 insertions, 1 deletions
diff --git a/php-5.4.30-noNO.patch b/php-5.4.30-noNO.patch
new file mode 100644
index 0000000..52f54ab
--- /dev/null
+++ b/php-5.4.30-noNO.patch
@@ -0,0 +1,43 @@
+--- ext/standard/tests/strings/setlocale_variation2.phpt.orig 2014-06-11 16:10:00.259326468 +0200
++++ ext/standard/tests/strings/setlocale_variation2.phpt 2014-06-11 16:16:14.396138997 +0200
+@@ -52,6 +52,7 @@
+ //try different locale names
+ $failure_locale = array();
+ $success_count = 0;
++$expected = 0;
+
+ echo "-- Test setlocale() with all available locale in the system --\n";
+ // gather all locales installed in the system(stored $all_system_locales),
+@@ -61,6 +62,10 @@
+ if(setlocale(LC_ALL,$value )){
+ $success_count++;
+ }
++ else if ($value == 'no_NO.ISO-8859-1') {
++ // ignore this one, see rhbz #971416
++ $expected++;
++ }
+ else{
+ //failure values are put in to an array $failure_locale
+ $failure_locale[] = $value;
+@@ -69,11 +74,11 @@
+
+ echo "No of locales found on the machine = ".count($all_system_locales)."\n";
+ echo "No of setlocale() success = ".$success_count."\n";
+-echo "Expected no of failures = 0\n";
++echo "Expected no of failures = $expected\n";
+ echo "Test ";
+ // check if there were any failure of setlocale() function earlier, if any
+ // failure then dump the list of failing locales
+-if($success_count != count($all_system_locales)){
++if(($success_count + $expected) != count($all_system_locales)){
+ echo "FAILED\n";
+ echo "Names of locale() for which setlocale() failed ...\n";
+ var_dump($failure_locale);
+@@ -89,6 +94,6 @@
+ -- Test setlocale() with all available locale in the system --
+ No of locales found on the machine = %d
+ No of setlocale() success = %d
+-Expected no of failures = 0
++Expected no of failures = %d
+ Test PASSED
+ Done
diff --git a/php-5.5.14-noNO.patch b/php-5.5.14-noNO.patch
new file mode 100644
index 0000000..52f54ab
--- /dev/null
+++ b/php-5.5.14-noNO.patch
@@ -0,0 +1,43 @@
+--- ext/standard/tests/strings/setlocale_variation2.phpt.orig 2014-06-11 16:10:00.259326468 +0200
++++ ext/standard/tests/strings/setlocale_variation2.phpt 2014-06-11 16:16:14.396138997 +0200
+@@ -52,6 +52,7 @@
+ //try different locale names
+ $failure_locale = array();
+ $success_count = 0;
++$expected = 0;
+
+ echo "-- Test setlocale() with all available locale in the system --\n";
+ // gather all locales installed in the system(stored $all_system_locales),
+@@ -61,6 +62,10 @@
+ if(setlocale(LC_ALL,$value )){
+ $success_count++;
+ }
++ else if ($value == 'no_NO.ISO-8859-1') {
++ // ignore this one, see rhbz #971416
++ $expected++;
++ }
+ else{
+ //failure values are put in to an array $failure_locale
+ $failure_locale[] = $value;
+@@ -69,11 +74,11 @@
+
+ echo "No of locales found on the machine = ".count($all_system_locales)."\n";
+ echo "No of setlocale() success = ".$success_count."\n";
+-echo "Expected no of failures = 0\n";
++echo "Expected no of failures = $expected\n";
+ echo "Test ";
+ // check if there were any failure of setlocale() function earlier, if any
+ // failure then dump the list of failing locales
+-if($success_count != count($all_system_locales)){
++if(($success_count + $expected) != count($all_system_locales)){
+ echo "FAILED\n";
+ echo "Names of locale() for which setlocale() failed ...\n";
+ var_dump($failure_locale);
+@@ -89,6 +94,6 @@
+ -- Test setlocale() with all available locale in the system --
+ No of locales found on the machine = %d
+ No of setlocale() success = %d
+-Expected no of failures = 0
++Expected no of failures = %d
+ Test PASSED
+ Done
diff --git a/php55.spec b/php55.spec
index 6723a4f..d306ada 100644
--- a/php55.spec
+++ b/php55.spec
@@ -124,7 +124,7 @@ Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.14
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.2.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 3%{?dist}
%endif
@@ -193,6 +193,8 @@ Patch91: php-5.3.7-oci8conf.patch
# Fixes for tests (300+)
# Revert change for pcre 8.34
Patch301: php-5.5.10-pcre834.patch
+# see https://bugzilla.redhat.com/971416
+Patch302: php-5.5.14-noNO.patch
# WIP
@@ -914,6 +916,7 @@ rm -rf ext/json
%patch301 -p1 -R -b .pcre84
%endif
%endif
+%patch302 -p0 -b .971416
# WIP patch
@@ -1894,6 +1897,9 @@ fi
%changelog
+* Tue Jun 17 2014 Remi Collet <rcollet@redhat.com> 5.5.14-0.2.RC1
+- fix test for rhbz #971416
+
* Tue Jun 17 2014 Remi Collet <rcollet@redhat.com> 5.5.14-0.1.RC1
- Test build of 5.5.14RC1