summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-21 08:33:35 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-21 08:33:35 +0200
commite95f0fabb1434d5414af12858ae8697a4bc1c20d (patch)
tree4bd655c3df8928cecf93e6b3bb9e569543c0b35b
parent34c4efbb45da165553ae66756706a65cb24a378e (diff)
php 5.5.16, revert fix for 67724 because of 67865
-rw-r--r--php-bug67865.patch64
-rw-r--r--php55.spec3
2 files changed, 67 insertions, 0 deletions
diff --git a/php-bug67865.patch b/php-bug67865.patch
new file mode 100644
index 0000000..e5cc8cd
--- /dev/null
+++ b/php-bug67865.patch
@@ -0,0 +1,64 @@
+From 46ee0e087e5bd6520051cb66d765fc428c51b1a4 Mon Sep 17 00:00:00 2001
+From: Stanislav Malyshev <stas@php.net>
+Date: Wed, 20 Aug 2014 13:15:22 -0700
+Subject: [PATCH] Revert "Fixed Bug #67724"
+
+This reverts commit e4ff7f2ee346d641715694209e61704c9e815483.
+Reverted since it causes https://bugs.php.net/bug.php?id=67865
+---
+ ext/zlib/tests/bug67724.gz.gz | Bin 171 -> 0 bytes
+ ext/zlib/tests/bug67724.phpt | 26 --------------------------
+ ext/zlib/zlib_filter.c | 3 +--
+ 3 files changed, 1 insertion(+), 28 deletions(-)
+ delete mode 100644 ext/zlib/tests/bug67724.gz.gz
+ delete mode 100644 ext/zlib/tests/bug67724.phpt
+
+diff --git a/ext/zlib/tests/bug67724.phpt b/ext/zlib/tests/bug67724.phpt
+deleted file mode 100644
+index 1e5026f..0000000
+--- a/ext/zlib/tests/bug67724.phpt
++++ /dev/null
+@@ -1,26 +0,0 @@
+---TEST--
+-Bug #67724 (chained zlib filters silently fail with large amounts of data)
+---SKIPIF--
+-<?php
+-extension_loaded("zlib") or die("skip need ext/zlib");
+-?>
+---FILE--
+-<?php
+-echo "Test\n";
+-
+-$f = fopen(__DIR__."/bug67724.gz.gz", "rb")
+- or die(current(error_get_last()));
+-stream_filter_append($f, "zlib.inflate", STREAM_FILTER_READ, ["window" => 30]);
+-stream_filter_append($f, "zlib.inflate", STREAM_FILTER_READ, ["window" => 30]);
+-for ($i = 0; !feof($f); $i += strlen(fread($f, 0x1000)))
+- ;
+-fclose($f);
+-
+-var_dump($i);
+-
+-?>
+-DONE
+---EXPECT--
+-Test
+-int(25600000)
+-DONE
+diff --git a/ext/zlib/zlib_filter.c b/ext/zlib/zlib_filter.c
+index 47a68e2..2054ec2 100644
+--- a/ext/zlib/zlib_filter.c
++++ b/ext/zlib/zlib_filter.c
+@@ -302,8 +302,7 @@ static php_stream_filter *php_zlib_filter_create(const char *filtername, zval *f
+
+ data->strm.zalloc = (alloc_func) php_zlib_alloc;
+ data->strm.zfree = (free_func) php_zlib_free;
+- data->strm.avail_out = data->outbuf_len = 0x8000;
+- data->inbuf_len = 2048;
++ data->strm.avail_out = data->outbuf_len = data->inbuf_len = 2048;
+ data->strm.next_in = data->inbuf = (Bytef *) pemalloc(data->inbuf_len, persistent);
+ if (!data->inbuf) {
+ php_error_docref(NULL TSRMLS_CC, E_WARNING, "Failed allocating %zd bytes", data->inbuf_len);
+--
+1.9.2
+
diff --git a/php55.spec b/php55.spec
index de72d57..ed95090 100644
--- a/php55.spec
+++ b/php55.spec
@@ -190,6 +190,7 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-bug67865.patch
# Security fixes (200+)
@@ -938,6 +939,7 @@ rm -rf ext/json
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .bug67865
# security patches
@@ -1945,6 +1947,7 @@ fi
- Update to 5.5.16
http://www.php.net/releases/5_5_16.php
- fix zts-php-config --php-binary output #1124605
+- revert fix for 67724 because of 67865
* Thu Jul 24 2014 Remi Collet <remi@fedoraproject.org> 5.5.15-1
- Update to 5.5.15