summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-02-21 15:20:02 +0100
committerRemi Collet <fedora@famillecollet.com>2013-02-21 15:20:02 +0100
commite6efa1b9885369453e2b0e87eede87efea70f3a4 (patch)
treea4ab72a1adb3a67ef87b84a8d929b3f91b6fc001
parent7ab030c1e2ad7bc18a802cecb69903c161ece077 (diff)
php 5.5: add patch to fix ZTS biuld (from upstream)
-rw-r--r--php-5.5.0-wip.patch39
-rw-r--r--php55.spec2
2 files changed, 41 insertions, 0 deletions
diff --git a/php-5.5.0-wip.patch b/php-5.5.0-wip.patch
new file mode 100644
index 0000000..22be618
--- /dev/null
+++ b/php-5.5.0-wip.patch
@@ -0,0 +1,39 @@
+X-Git-Url: http://git.php.net/?p=php-src.git;a=blobdiff_plain;f=ext%2Fsoap%2Fphp_xml.c;h=939385557df326205e62d7d4ae343da1fa6ab02f;hp=a74ec02f435cba9b951d2f3cdd2421acd3a3663b;hb=1e9bc5677505585173ac105c997a09c095f34d1d;hpb=b5d267aa95aec1e89dc34f0bcc3c46576354cd26
+
+diff --git a/ext/soap/php_xml.c b/ext/soap/php_xml.c
+index a74ec02..9393855 100644
+--- a/ext/soap/php_xml.c
++++ b/ext/soap/php_xml.c
+@@ -100,9 +100,9 @@ xmlDocPtr soap_xmlParseFile(const char *filename TSRMLS_DC)
+ ctxt->sax->warning = NULL;
+ ctxt->sax->error = NULL;
+ /*ctxt->sax->fatalError = NULL;*/
+- old = php_libxml_disable_entity_loader(1);
++ old = php_libxml_disable_entity_loader(1 TSRMLS_CC);
+ xmlParseDocument(ctxt);
+- php_libxml_disable_entity_loader(old);
++ php_libxml_disable_entity_loader(old TSRMLS_CC);
+ if (ctxt->wellFormed) {
+ ret = ctxt->myDoc;
+ if (ret->URL == NULL && ctxt->directory != NULL) {
+@@ -133,6 +133,8 @@ xmlDocPtr soap_xmlParseMemory(const void *buf, size_t buf_size)
+ xmlParserCtxtPtr ctxt = NULL;
+ xmlDocPtr ret;
+
++ TSRMLS_FETCH();
++
+ /*
+ xmlInitParser();
+ */
+@@ -148,9 +150,9 @@ xmlDocPtr soap_xmlParseMemory(const void *buf, size_t buf_size)
+ #if LIBXML_VERSION >= 20703
+ ctxt->options |= XML_PARSE_HUGE;
+ #endif
+- old = php_libxml_disable_entity_loader(1);
++ old = php_libxml_disable_entity_loader(1 TSRMLS_CC);
+ xmlParseDocument(ctxt);
+- php_libxml_disable_entity_loader(old);
++ php_libxml_disable_entity_loader(old TSRMLS_CC);
+ if (ctxt->wellFormed) {
+ ret = ctxt->myDoc;
+ if (ret->URL == NULL && ctxt->directory != NULL) {
diff --git a/php55.spec b/php55.spec
index 32197c7..b3ec273 100644
--- a/php55.spec
+++ b/php55.spec
@@ -125,6 +125,7 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# WIP
+Patch99: php-5.5.0-wip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -784,6 +785,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch47 -p1 -b .phpinfo
%patch91 -p1 -b .remi-oci8
+%patch99 -p1 -b .wip
# wip patches