summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-25 16:38:56 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-25 16:38:56 +0100
commita78ef013a257bddda133d61c2a5fdac988bd0359 (patch)
tree9406ba69797aaaa317ed6a6f71f6429cd189f832
parent8adc8922546110ae8fa61817514c34acf819a527 (diff)
php 5.5: new snapshot, generated parser using system bison, test for https://bugs.php.net/64503
-rw-r--r--php-5.5.0-wip.patch29
-rw-r--r--php55.spec27
2 files changed, 48 insertions, 8 deletions
diff --git a/php-5.5.0-wip.patch b/php-5.5.0-wip.patch
new file mode 100644
index 0000000..dd2481d
--- /dev/null
+++ b/php-5.5.0-wip.patch
@@ -0,0 +1,29 @@
+diff --git a/Zend/zend_language_parser.y b/Zend/zend_language_parser.y
+index ccbc9b1..6a9a24a 100644
+--- a/Zend/zend_language_parser.y
++++ b/Zend/zend_language_parser.y
+@@ -41,17 +41,19 @@ static YYSIZE_T zend_yytnamerr(char*, const char*);
+
+ #define YYERROR_VERBOSE
+ #define YYSTYPE znode
+-#ifdef ZTS
+-# define YYPARSE_PARAM tsrm_ls
+-# define YYLEX_PARAM tsrm_ls
+-#endif
+-
+
+ %}
+
+ %pure_parser
+ %expect 3
+
++%code requires {
++#ifdef ZTS
++# define YYPARSE_PARAM tsrm_ls
++# define YYLEX_PARAM tsrm_ls
++#endif
++}
++
+ %token END 0 "end of file"
+ %left T_INCLUDE T_INCLUDE_ONCE T_EVAL T_REQUIRE T_REQUIRE_ONCE
+ %token T_INCLUDE "include (T_INCLUDE)"
diff --git a/php55.spec b/php55.spec
index 152a080..f4665ba 100644
--- a/php55.spec
+++ b/php55.spec
@@ -3,7 +3,7 @@
%global zendver 20121212
%global pdover 20080721
# Extension version
-%global opcachever 7.0.1-dev
+%global opcachever 7.0.2-dev
%global oci8ver 1.4.9
# Adds -z now to the linker flags
@@ -72,14 +72,14 @@
%global db_devel libdb-devel
%endif
-%global snapdate 201303201430
+%global snapdate 201303251230
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.20.%{?snapdate}%{?rcver}%{?dist}.1
+Release: 0.21.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 2%{?dist}
%endif
@@ -139,6 +139,8 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# WIP
+Patch99: php-5.5.0-wip.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -325,9 +327,9 @@ Summary: The Zend Optimizer+
Group: Development/Languages
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-Obsoletes: php-pecl-zendoptimizerplus
-Provides: php-pecl-zendoptimizerplus = %{opcachever}
-Provides: php-pecl-zendoptimizerplus%{?_isa} = %{opcachever}
+Obsoletes: php-pecl-zendopcache
+Provides: php-pecl-zendopcache = %{opcachever}
+Provides: php-pecl-zendopcache%{?_isa} = %{opcachever}
Provides: php-pecl(opcache) = %{opcachever}
Provides: php-pecl(opcache)%{?_isa} = %{opcachever}
# Only one opcode cache could be enabled
@@ -832,6 +834,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# wip patches
+%patch99 -p1 -b .wip
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -928,6 +931,10 @@ echo "d /run/php-fpm 755 root root" >php-fpm.tmpfiles
# Some extensions have their own configuration file
cp %{SOURCE50} .
+# Regenerated bison files
+rm Zend/zend_{language,ini}_parser.[ch]
+./genfiles
+
%build
%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
@@ -995,7 +1002,7 @@ ln -sf ../configure
--with-jpeg-dir=%{_prefix} \
--with-openssl \
%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
- --with-pcre-regex=%{_prefix} \
+ --with-pcre-regex=%{_prefix} \
%endif
--with-zlib \
--with-layout=GNU \
@@ -1004,7 +1011,7 @@ ln -sf ../configure
--enable-ucd-snmp-hack \
--with-libxml-dir=%{_prefix} \
%if 0%{?fedora} >= 16 || 0%{?rhel} >= 5
- --with-system-tzdata \
+ --with-system-tzdata \
%endif
--with-mhash \
%if %{with_dtrace}
@@ -1773,6 +1780,10 @@ fi
%changelog
+* Mon Mar 25 2013 Remi Collet <remi@fedoraproject.org> 5.5.0-0.21-201303251230
+- new snapshot
+- generated parser using system bison, test for https://bugs.php.net/64503
+
* Wed Mar 20 2013 Remi Collet <remi@fedoraproject.org> 5.5.0-0.20-201303201430
- new snapshot (beta1)