summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-12-20 19:17:38 +0100
committerRemi Collet <fedora@famillecollet.com>2013-12-20 19:17:38 +0100
commit969a883bb4e40fbd79a2ef10b03188425fdc5b02 (patch)
tree1190b6cf33214c2a5b02481e8906a349dda0c9be
parent6b7325afdad74d6446f29b7ebc8bf9d416fbd71b (diff)
php 5.5: test build for https://bugs.php.net/66331
-rw-r--r--php-wip.patch12
-rw-r--r--php55.spec20
2 files changed, 26 insertions, 6 deletions
diff --git a/php-wip.patch b/php-wip.patch
new file mode 100644
index 0000000..7908956
--- /dev/null
+++ b/php-wip.patch
@@ -0,0 +1,12 @@
+diff -up Zend/zend_compile.c.old Zend/zend_compile.c
+--- Zend/zend_compile.c.old 2013-12-20 18:54:27.817018413 +0100
++++ Zend/zend_compile.c 2013-12-20 18:54:37.015050252 +0100
+@@ -3209,7 +3209,7 @@ static zend_bool zend_do_perform_impleme
+ }
+
+ /* by-ref constraints on arguments are invariant */
+- if (fe->common.arg_info[i].pass_by_reference != proto->common.arg_info[i].pass_by_reference) {
++ if ((fe->common.arg_info[i].pass_by_reference>0) != (proto->common.arg_info[i].pass_by_reference>0)) {
+ return 0;
+ }
+ }
diff --git a/php55.spec b/php55.spec
index be2b0b9..cfcd6e8 100644
--- a/php55.spec
+++ b/php55.spec
@@ -108,7 +108,7 @@ Version: 5.5.7
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.4.%{?snapdate}%{?rcver}%{?dist}
%else
-Release: 1%{?dist}
+Release: 1%{?dist}.1
%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -165,6 +165,9 @@ Patch46: php-5.4.9-fixheader.patch
# drop "Configure command" from phpinfo output
Patch47: php-5.4.9-phpinfo.patch
+# RC Patch
+Patch91: php-5.3.7-oci8conf.patch
+
# Upstream fixes
# 66060 Heap buffer over-read in DateInterval
Patch100: php-bug66060.patch
@@ -177,11 +180,8 @@ Patch102: php-bugarm.patch
# Fixes for tests
-# RC Patch
-Patch91: php-5.3.7-oci8conf.patch
-
# WIP
-#Patch102: php-wip3.patch
+Patch200: php-wip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -889,11 +889,16 @@ rm -rf ext/json
%patch91 -p1 -b .remi-oci8
-# wip patches
+# upstream patches
%patch100 -p1 -b .bug66060
%patch101 -p1 -b .bug66218
%patch102 -p1 -b .bugarm
+# security patches
+
+# WIP patch
+%patch200 -p0 -b .wip
+
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
cp TSRM/LICENSE TSRM_LICENSE
@@ -1867,6 +1872,9 @@ fi
%changelog
+* Sat Dec 20 2013 Remi Collet <rcollet@redhat.com> 5.5.7-1.1
+- test build for https://bugs.php.net/66331
+
* Wed Dec 11 2013 Remi Collet <rcollet@redhat.com> 5.5.7-1
- update to 5.5.7, fix for CVE-2013-6420
- fix zend_register_functions breaks reflection, php bug 66218