summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-14 10:57:28 +0200
committerRemi Collet <remi@remirepo.net>2018-09-14 10:57:28 +0200
commit8d7778b180a2bae4dd69f32c3d3b404784f78ff5 (patch)
tree83ad21887922d93f002bd5b255ff9d02e3bdf11e
parent0a0c58dff2291870b56cec15fabf27119179c997 (diff)
fix #76582: XSS due to the header Transfer-Encoding: chunked
-rw-r--r--bug76582.patch23
-rw-r--r--php55.spec7
2 files changed, 29 insertions, 1 deletions
diff --git a/bug76582.patch b/bug76582.patch
new file mode 100644
index 0000000..fd35f43
--- /dev/null
+++ b/bug76582.patch
@@ -0,0 +1,23 @@
+From 23b057742e3cf199612fa8050ae86cae675e214e Mon Sep 17 00:00:00 2001
+From: Stanislav Malyshev <stas@php.net>
+Date: Sat, 28 Jul 2018 22:16:29 -0700
+Subject: [PATCH] Fix for bug #76582
+
+The brigade seems to end up in a messed up state if something fails
+in shutdown, so we clean it up.
+---
+ sapi/apache2handler/sapi_apache2.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/sapi/apache2handler/sapi_apache2.c b/sapi/apache2handler/sapi_apache2.c
+index 6fa2521c3847..0ebca9bca863 100644
+--- a/sapi/apache2handler/sapi_apache2.c
++++ b/sapi/apache2handler/sapi_apache2.c
+@@ -678,6 +678,7 @@ zend_first_try {
+ if (!parent_req) {
+ php_apache_request_dtor(r TSRMLS_CC);
+ ctx->request_processed = 1;
++ apr_brigade_cleanup(brigade);
+ bucket = apr_bucket_eos_create(r->connection->bucket_alloc);
+ APR_BRIGADE_INSERT_TAIL(brigade, bucket);
+
diff --git a/php55.spec b/php55.spec
index 9477b1c..b9e09b3 100644
--- a/php55.spec
+++ b/php55.spec
@@ -141,7 +141,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.38
-Release: 8%{?dist}
+Release: 9%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -259,6 +259,7 @@ Patch153: bug73773.patch
Patch154: bug69090.patch
Patch155: bug73549.patch
Patch156: bug75981.patch
+Patch157: bug76582.patch
# Security fixes (200+)
@@ -1081,6 +1082,7 @@ rm -rf ext/json
%patch154 -p1 -b .bug69090
%patch155 -p1 -b .bug73549
%patch156 -p1 -b .bug75981
+%patch157 -p1 -b .bug75981
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -2105,6 +2107,9 @@ EOF
%changelog
+* Fri Sep 14 2018 Remi Collet <remi@remirepo.net> - 5.5.38-9
+- fix #76582: XSS due to the header Transfer-Encoding: chunked
+
* Thu Mar 1 2018 Remi Collet <remi@remirepo.net> - 5.5.38-8
- fix #73549: Use after free when stream is passed to imagepng
- fix #75981: stack-buffer-overflow while parsing HTTP response