summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-18 14:28:59 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-18 14:28:59 +0200
commit787f87769ad867dcb11e96cb95c05a1af1c5e2a6 (patch)
tree5e7ed17b8d984b08031bb285c00c7bf539d4ad58
parent9af7958e7aad9226d6465252b1f71df6c9897981 (diff)
php-5.5.0-0.26.201304181030
-rw-r--r--opcache.ini2
-rw-r--r--php-5.5.0-system-libzip.patch (renamed from php-5.4.5-system-libzip.patch)80
-rw-r--r--php55.spec26
3 files changed, 54 insertions, 54 deletions
diff --git a/opcache.ini b/opcache.ini
index ef6e0e0..0b85b67 100644
--- a/opcache.ini
+++ b/opcache.ini
@@ -1,5 +1,5 @@
; Enable Zend OPcache extension module
-zend_extension=@EXTPATH@/opcache.so
+zend_extension=opcache.so
; Determines if Zend OPCache is enabled
opcache.enable=1
diff --git a/php-5.4.5-system-libzip.patch b/php-5.5.0-system-libzip.patch
index 897fb87..409af5d 100644
--- a/php-5.4.5-system-libzip.patch
+++ b/php-5.5.0-system-libzip.patch
@@ -1,22 +1,14 @@
-diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
---- php-5.4.5RC1/ext/zip/config.m4.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/config.m4 2012-07-07 15:56:41.418171233 +0200
-@@ -13,65 +13,116 @@
+diff -up php5.5-201304181030/ext/zip/config.m4.systzip php5.5-201304181030/ext/zip/config.m4
+--- php5.5-201304181030/ext/zip/config.m4.systzip 2012-12-05 11:40:39.000000000 +0100
++++ php5.5-201304181030/ext/zip/config.m4 2013-04-18 13:17:32.144550036 +0200
+@@ -13,65 +13,116 @@ fi
PHP_ARG_WITH(pcre-dir, pcre install prefix,
[ --with-pcre-dir ZIP: pcre install prefix], no, no)
--if test "$PHP_ZIP" != "no"; then
+PHP_ARG_WITH(libzip, libzip,
+[ --with-libzip[=DIR] ZIP: use libzip], no, no)
-
-- if test "$PHP_ZLIB_DIR" != "no" && test "$PHP_ZLIB_DIR" != "yes"; then
-- if test -f "$PHP_ZLIB_DIR/include/zlib/zlib.h"; then
-- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
-- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include/zlib"
-- elif test -f "$PHP_ZLIB_DIR/include/zlib.h"; then
-- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
-- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include"
-+if test "$PHP_ZIP" != "no"; then
++
+ if test "$PHP_ZIP" != "no"; then
+ if test "$PHP_LIBZIP" != "no"; then
+
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
@@ -32,7 +24,14 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
+ LIBZIP_CFLAGS=`$PKG_CONFIG libzip --cflags`
+ LIBZIP_LIBDIR=`$PKG_CONFIG libzip --variable=libdir`
+ AC_MSG_RESULT(from pkgconfig: found in $LIBZIP_LIBDIR)
-+
+
+- if test "$PHP_ZLIB_DIR" != "no" && test "$PHP_ZLIB_DIR" != "yes"; then
+- if test -f "$PHP_ZLIB_DIR/include/zlib/zlib.h"; then
+- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
+- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include/zlib"
+- elif test -f "$PHP_ZLIB_DIR/include/zlib.h"; then
+- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
+- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include"
else
- AC_MSG_ERROR([Can not find zlib headers under "$PHP_ZLIB_DIR"])
+ for i in /usr/local /usr; do
@@ -43,12 +42,12 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
+ break
+ fi
+ done
-+ fi
+ fi
+
+ if test -z "$LIBZIP_LIBDIR"; then
+ AC_MSG_RESULT(not found)
+ AC_MSG_ERROR(Please reinstall the libzip distribution)
- fi
++ fi
+
+ dnl Could not think of a simple way to check libzip for overwrite support
+ PHP_CHECK_LIBRARY(zip, zip_open,
@@ -160,7 +159,7 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
lib/zip_fread.c lib/zip_open.c lib/zip_source_filep.c \
lib/zip_strerror.c lib/zip_close.c lib/zip_error_get.c \
lib/zip_file_error_get.c lib/zip_free.c lib/zip_rename.c \
-@@ -98,10 +149,11 @@
+@@ -98,10 +149,11 @@ yes
lib/zip_source_open.c lib/zip_source_pkware.c lib/zip_source_pop.c \
lib/zip_source_read.c lib/zip_source_stat.c"
@@ -176,13 +175,14 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
dnl so we always include the known-good working hack.
PHP_ADD_MAKEFILE_FRAGMENT
-diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
---- php-5.4.5RC1/ext/zip/php_zip.c.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/php_zip.c 2012-07-07 15:59:12.728676026 +0200
-@@ -29,8 +29,232 @@
- #include "ext/standard/php_string.h"
+diff -up php5.5-201304181030/ext/zip/php_zip.c.systzip php5.5-201304181030/ext/zip/php_zip.c
+--- php5.5-201304181030/ext/zip/php_zip.c.systzip 2013-04-10 22:36:34.000000000 +0200
++++ php5.5-201304181030/ext/zip/php_zip.c 2013-04-18 13:23:29.997871990 +0200
+@@ -30,8 +30,233 @@
#include "ext/pcre/php_pcre.h"
+ #include "ext/standard/php_filestat.h"
#include "php_zip.h"
++
+#if defined(HAVE_LIBZIP)
+#include <zip.h>
+
@@ -278,7 +278,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
+struct zip_source {
+ struct zip_source *src;
+ union {
-+ zip_source_callback f;
++ zip_source_callback f;
+ zip_source_layered_callback l;
+ } cb;
+ void *ud;
@@ -363,7 +363,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
+_zip_error_set(struct zip_error *err, int ze, int se)
+{
+ if (err) {
-+ err->zip_err = ze;
++ err->zip_err = ze;
+ err->sys_err = se;
+ }
+}
@@ -412,7 +412,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
/* zip_open is a macro for renaming libzip zipopen, so we need to use PHP_NAMED_FUNCTION */
static PHP_NAMED_FUNCTION(zif_zip_open);
-@@ -1624,6 +1848,10 @@ static ZIPARCHIVE_METHOD(addEmptyDir)
+@@ -1631,6 +1856,10 @@ static ZIPARCHIVE_METHOD(addEmptyDir)
}
idx = zip_stat(intern, s, 0, &sb);
@@ -423,7 +423,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
if (idx >= 0) {
RETVAL_FALSE;
} else {
-@@ -1846,6 +2074,10 @@ static ZIPARCHIVE_METHOD(addFromString)
+@@ -1853,6 +2082,10 @@ static ZIPARCHIVE_METHOD(addFromString)
}
cur_idx = zip_name_locate(intern, (const char *)name, 0);
@@ -434,7 +434,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
/* TODO: fix _zip_replace */
if (cur_idx >= 0) {
if (zip_delete(intern, cur_idx) == -1) {
-@@ -2870,5 +3098,9 @@ static PHP_MINFO_FUNCTION(zip)
+@@ -2877,5 +3110,9 @@ static PHP_MINFO_FUNCTION(zip)9
php_info_print_table_row(2, "Zip version", PHP_ZIP_VERSION_STRING);
- php_info_print_table_row(2, "Libzip version", LIBZIP_VERSION);
+#if defined(HAVE_LIBZIP)
@@ -445,9 +445,9 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
php_info_print_table_end();
}
-diff -up php-5.4.5RC1/ext/zip/php_zip.h.systzip php-5.4.5RC1/ext/zip/php_zip.h
---- php-5.4.5RC1/ext/zip/php_zip.h.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/php_zip.h 2012-07-07 15:57:34.845319432 +0200
+diff -up php5.5-201304181030/ext/zip/php_zip.h.systzip php5.5-201304181030/ext/zip/php_zip.h
+--- php5.5-201304181030/ext/zip/php_zip.h.systzip 2013-01-01 11:36:17.000000000 +0100
++++ php5.5-201304181030/ext/zip/php_zip.h 2013-04-18 13:17:32.147550046 +0200
@@ -28,7 +28,11 @@ extern zend_module_entry zip_module_entr
#include "TSRM.h"
#endif
@@ -460,9 +460,9 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.h.systzip php-5.4.5RC1/ext/zip/php_zip.h
#define PHP_ZIP_VERSION_STRING "1.11.0"
-diff -up php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip php-5.4.5RC1/ext/zip/tests/bug38943.phpt
---- php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/tests/bug38943.phpt 2012-07-07 15:56:41.422171242 +0200
+diff -up php5.5-201304181030/ext/zip/tests/bug38943.phpt.systzip php5.5-201304181030/ext/zip/tests/bug38943.phpt
+--- php5.5-201304181030/ext/zip/tests/bug38943.phpt.systzip 2012-12-05 11:40:39.000000000 +0100
++++ php5.5-201304181030/ext/zip/tests/bug38943.phpt 2013-04-18 13:17:32.147550046 +0200
@@ -27,7 +27,7 @@ array(1) {
[0]=>
int(1)
@@ -472,9 +472,9 @@ diff -up php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip php-5.4.5RC1/ext/zip/t
["test":"myZip":private]=>
int(0)
["testp"]=>
-diff -up php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip php-5.4.5RC1/ext/zip/tests/pecl12414.phpt
---- php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/tests/pecl12414.phpt 2012-07-07 15:56:41.422171242 +0200
+diff -up php5.5-201304181030/ext/zip/tests/pecl12414.phpt.systzip php5.5-201304181030/ext/zip/tests/pecl12414.phpt
+--- php5.5-201304181030/ext/zip/tests/pecl12414.phpt.systzip 2012-12-05 11:40:39.000000000 +0100
++++ php5.5-201304181030/ext/zip/tests/pecl12414.phpt 2013-04-18 13:17:32.148550050 +0200
@@ -5,6 +5,8 @@ Bug #12414 ( extracting files from damag
/*$ */
if(!extension_loaded('zip')) die('skip');
@@ -484,9 +484,9 @@ diff -up php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip php-5.4.5RC1/ext/zip/
--FILE--
<?php
$filename = 'MYLOGOV2.GFX';
-diff -up php-5.4.5RC1/ext/zip/zip_stream.c.systzip php-5.4.5RC1/ext/zip/zip_stream.c
---- php-5.4.5RC1/ext/zip/zip_stream.c.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/zip_stream.c 2012-07-07 15:56:41.423171244 +0200
+diff -up php5.5-201304181030/ext/zip/zip_stream.c.systzip php5.5-201304181030/ext/zip/zip_stream.c
+--- php5.5-201304181030/ext/zip/zip_stream.c.systzip 2012-12-05 11:40:39.000000000 +0100
++++ php5.5-201304181030/ext/zip/zip_stream.c 2013-04-18 13:17:32.149550054 +0200
@@ -6,7 +6,11 @@
#if HAVE_ZIP
#ifdef ZEND_ENGINE_2
diff --git a/php55.spec b/php55.spec
index 87b5491..f046818 100644
--- a/php55.spec
+++ b/php55.spec
@@ -72,14 +72,14 @@
%global db_devel libdb-devel
%endif
-#global snapdate 201304040630
-%global rcver beta3
+%global snapdate 201304181030
+#global rcver beta3
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.25.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.26.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 2%{?dist}
%endif
@@ -126,15 +126,13 @@ Patch42: php-5.3.1-systzdata-v10.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use system libzip instead of bundled one
-Patch44: php-5.4.5-system-libzip.patch
+Patch44: php-5.5.0-system-libzip.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.4.8-ldap_r.patch
# Make php_config.h constant across builds
Patch46: php-5.4.9-fixheader.patch
# drop "Configure command" from phpinfo output
Patch47: php-5.4.9-phpinfo.patch
-# Allow wildcard il opcache.backlist_filename
-Patch48: php-5.5.0-opcache.patch
# Fixes for tests
@@ -832,7 +830,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%endif
%patch46 -p1 -b .fixheader
%patch47 -p1 -b .phpinfo
-%patch48 -p1 -b .opcache
%patch91 -p1 -b .remi-oci8
@@ -978,8 +975,7 @@ mkdir Zend && cp ../Zend/zend_{language,ini}_{parser,scanner}.[ch] Zend
fi
# Always static:
-# date, filter, libxml, reflection, spl: not supported
-# ereg: build options vary per SAPI
+# date, ereg, filter, libxml, reflection, spl: not supported
# hash: for PHAR_SIG_SHA256 and PHAR_SIG_SHA512
# session: dep on hash, used by soap and wddx
# pcre: used by filter, zip
@@ -1463,10 +1459,8 @@ then ini=xml_${mod}.ini
else ini=${mod}.ini
fi
if [ -f ${ini} ]; then
- sed -e 's:@EXTPATH@:%{_libdir}/php/modules:' \
- ${ini} >$RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
- sed -e 's:@EXTPATH@:%{_libdir}/php-zts/modules:' \
- ${ini} >$RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
+ cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
+ cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
else
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini} <<EOF
; Enable ${mod} extension module
@@ -1781,6 +1775,12 @@ fi
%changelog
+* Thu Apr 18 2013 Remi Collet <remi@fedoraproject.org> 5.5.0-0.26-201304181030
+- new snapshot
+- zend_extension doesn't requires full path
+- refresh system libzip patch
+- drop opcache patch merged upstream
+
* Thu Apr 11 2013 Remi Collet <rcollet@redhat.com> 5.5.0-0.25.beta3
- allow wildcard in opcache.blacklist_filename and provide
default /etc/php.d/opcache-default.blacklist