summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-05-03 18:11:56 +0200
committerRemi Collet <fedora@famillecollet.com>2013-05-03 18:11:56 +0200
commit3ffca787025ff74d9b4ad1b3cc39defdb88ed901 (patch)
tree64e28a59e30df7242f4f98b1eaa2ba3cdc326879
parentac74c9566baf15941245b7276f4493c5a3671cd3 (diff)
php: test build
-rw-r--r--php-wip.patch17
-rw-r--r--php-wip2.patch75
-rw-r--r--php55.spec8
3 files changed, 4 insertions, 96 deletions
diff --git a/php-wip.patch b/php-wip.patch
deleted file mode 100644
index 77699ce..0000000
--- a/php-wip.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- acinclude.m4.old 2012-12-10 12:30:11.684122918 +0100
-+++ acinclude.m4 2012-12-10 12:31:49.933474452 +0100
-@@ -2963,12 +2963,12 @@
- cat>>Makefile.objects<<EOF
-
- $ac_bdir[$]ac_hdrobj: $abs_srcdir/$ac_provsrc
-- dtrace -h -C -s $ac_srcdir[$]ac_provsrc -o \$[]@ && \$(SED) -ibak 's,PHP_,DTRACE_,g' \$[]@
-+ CFLAGS="\$(CFLAGS_CLEAN)" dtrace -h -C -s $ac_srcdir[$]ac_provsrc -o \$[]@ && \$(SED) -ibak 's,PHP_,DTRACE_,g' \$[]@
-
- \$(PHP_DTRACE_OBJS): $ac_bdir[$]ac_hdrobj
-
- $ac_bdir[$]ac_provsrc.o: \$(PHP_DTRACE_OBJS)
-- dtrace -G -o \$[]@ -s $abs_srcdir/$ac_provsrc $dtrace_objs
-+ CFLAGS="\$(CFLAGS_CLEAN)" dtrace -G -o \$[]@ -s $abs_srcdir/$ac_provsrc $dtrace_objs
-
- EOF
- ])
diff --git a/php-wip2.patch b/php-wip2.patch
deleted file mode 100644
index 91535e9..0000000
--- a/php-wip2.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From 4d8d5d83fce83c32a04cd8d8cf50d909ab101f38 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Tue, 11 Dec 2012 16:30:08 +0100
-Subject: [PATCH] Fixed Bug #63738 unpack: back result with Z format
-
-Fix result for empty string.
-Same output as perl
-perl -e 'print unpack("Z2","\0\0");' => ""
-perl -e 'print unpack("Z2","A\0");' => "A"
-perl -e 'print unpack("Z2","AB\0");' => "AB"
-perl -e 'print unpack("Z2","ABC\0");'=> "AB"
----
- ext/standard/pack.c | 3 +--
- ext/standard/tests/strings/pack_Z.phpt | 25 ++++++++++++++++++++++++-
- 2 files changed, 25 insertions(+), 3 deletions(-)
-
-diff --git a/ext/standard/pack.c b/ext/standard/pack.c
-index 9894746..0472cb2 100644
---- a/ext/standard/pack.c
-+++ b/ext/standard/pack.c
-@@ -729,8 +729,7 @@ PHP_FUNCTION(unpack)
- size = len;
-
- /* Remove everything after the first null */
-- s = 0;
-- while (s++ <= len) {
-+ for (s=0 ; s < len ; s++) {
- if (input[inputpos + s] == pad)
- break;
- }
-diff --git a/ext/standard/tests/strings/pack_Z.phpt b/ext/standard/tests/strings/pack_Z.phpt
-index 8a2ee67..4fd007a 100644
---- a/ext/standard/tests/strings/pack_Z.phpt
-+++ b/ext/standard/tests/strings/pack_Z.phpt
-@@ -9,9 +9,15 @@ var_dump(
- pack("Z4", "foo"),
- pack("Z*", "foo"),
- unpack("Z*", "foo\0\rbar\0 \t\r\n"),
-- unpack("Z9", "foo\0\rbar\0 \t\r\n")
-+ unpack("Z9", "foo\0\rbar\0 \t\r\n"),
-+ unpack("Z2", "\0"),
-+ unpack("Z2", "\0\0"),
-+ unpack("Z2", "A\0"),
-+ unpack("Z2", "AB\0"),
-+ unpack("Z2", "ABC")
- );
- --EXPECTF--
-+Warning: unpack(): Type Z: not enough input, need 2, have 1 in %s on line %d
- string(0) ""
- string(5) "foo%c%c"
- string(4) "foo%c"
-@@ -25,3 +31,20 @@ array(1) {
- [1]=>
- string(3) "foo"
- }
-+bool(false)
-+array(1) {
-+ [1]=>
-+ string(0) ""
-+}
-+array(1) {
-+ [1]=>
-+ string(1) "A"
-+}
-+array(1) {
-+ [1]=>
-+ string(2) "AB"
-+}
-+array(1) {
-+ [1]=>
-+ string(2) "AB"
-+}
---
-1.7.11.5
-
diff --git a/php55.spec b/php55.spec
index 482abc3..360751d 100644
--- a/php55.spec
+++ b/php55.spec
@@ -79,14 +79,14 @@
%global db_devel libdb-devel
%endif
-%global snapdate 201304291030
+%global snapdate 201305020630
#global rcver beta4
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.29.%{?snapdate}%{?rcver}%{?dist}.3
+Release: 0.29.%{?snapdate}%{?rcver}%{?dist}.4
%else
Release: 2%{?dist}
%endif
@@ -147,7 +147,7 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# WIP
-Patch99: php-5.5.0-wip.patch
+#Patch99: php-5.5.0-wip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -847,7 +847,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# wip patches
-%patch99 -p1 -b .wip
+#patch99 -p1 -b .wip
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE