summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-08 12:00:24 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-08 12:00:24 +0100
commit372dccd3521a0ec614470cf94ca03bc5eea49191 (patch)
treee04b55034a9f5db6122afee6b0b8c4e23d44ebd0
parent051634248b0a6938a3526904336330a5d44d0c59 (diff)
PHP 5.5.8
-rw-r--r--php-wip.patch12
-rw-r--r--php-wip2.patch93
-rw-r--r--php55.spec17
-rwxr-xr-xstrip.sh17
4 files changed, 19 insertions, 120 deletions
diff --git a/php-wip.patch b/php-wip.patch
deleted file mode 100644
index 7908956..0000000
--- a/php-wip.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up Zend/zend_compile.c.old Zend/zend_compile.c
---- Zend/zend_compile.c.old 2013-12-20 18:54:27.817018413 +0100
-+++ Zend/zend_compile.c 2013-12-20 18:54:37.015050252 +0100
-@@ -3209,7 +3209,7 @@ static zend_bool zend_do_perform_impleme
- }
-
- /* by-ref constraints on arguments are invariant */
-- if (fe->common.arg_info[i].pass_by_reference != proto->common.arg_info[i].pass_by_reference) {
-+ if ((fe->common.arg_info[i].pass_by_reference>0) != (proto->common.arg_info[i].pass_by_reference>0)) {
- return 0;
- }
- }
diff --git a/php-wip2.patch b/php-wip2.patch
deleted file mode 100644
index fcea691..0000000
--- a/php-wip2.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 5137cb5f0ccdeb78d6db25f6045b2c520463a38f Mon Sep 17 00:00:00 2001
-From: Derick Rethans <github@derickrethans.nl>
-Date: Thu, 2 Jan 2014 12:45:48 +0000
-Subject: [PATCH] Fixed (some of) add/sub.
-
-This worked in PHP 5.4 already, but with the introduction of DateTimeImmutable
-this code was not correctly merged.
----
- ext/date/php_date.c | 48 ++++++++----------------------------------------
- 1 file changed, 8 insertions(+), 40 deletions(-)
-
-diff --git a/ext/date/php_date.c b/ext/date/php_date.c
-index cd3bf74..d96428d 100644
---- a/ext/date/php_date.c
-+++ b/ext/date/php_date.c
-@@ -3137,33 +3137,16 @@ static void php_date_add(zval *object, zval *interval, zval *return_value TSRMLS
- {
- php_date_obj *dateobj;
- php_interval_obj *intobj;
-- int bias = 1;
-+ timelib_time *new_time;
-
- dateobj = (php_date_obj *) zend_object_store_get_object(object TSRMLS_CC);
- DATE_CHECK_INITIALIZED(dateobj->time, DateTime);
- intobj = (php_interval_obj *) zend_object_store_get_object(interval TSRMLS_CC);
- DATE_CHECK_INITIALIZED(intobj->initialized, DateInterval);
-
-- if (intobj->diff->have_weekday_relative || intobj->diff->have_special_relative) {
-- memcpy(&dateobj->time->relative, intobj->diff, sizeof(struct timelib_rel_time));
-- } else {
-- if (intobj->diff->invert) {
-- bias = -1;
-- }
-- memset(&dateobj->time->relative, 0, sizeof(struct timelib_rel_time));
-- dateobj->time->relative.y = intobj->diff->y * bias;
-- dateobj->time->relative.m = intobj->diff->m * bias;
-- dateobj->time->relative.d = intobj->diff->d * bias;
-- dateobj->time->relative.h = intobj->diff->h * bias;
-- dateobj->time->relative.i = intobj->diff->i * bias;
-- dateobj->time->relative.s = intobj->diff->s * bias;
-- }
-- dateobj->time->have_relative = 1;
-- dateobj->time->sse_uptodate = 0;
--
-- timelib_update_ts(dateobj->time, NULL);
-- timelib_update_from_sse(dateobj->time);
-- dateobj->time->have_relative = 0;
-+ new_time = timelib_add(dateobj->time, intobj->diff);
-+ timelib_time_dtor(dateobj->time);
-+ dateobj->time = new_time;
- }
-
- /* {{{ proto DateTime date_add(DateTime object, DateInterval interval)
-@@ -3204,7 +3187,7 @@ static void php_date_sub(zval *object, zval *interval, zval *return_value TSRMLS
- {
- php_date_obj *dateobj;
- php_interval_obj *intobj;
-- int bias = 1;
-+ timelib_time *new_time;
-
- dateobj = (php_date_obj *) zend_object_store_get_object(object TSRMLS_CC);
- DATE_CHECK_INITIALIZED(dateobj->time, DateTime);
-@@ -3216,24 +3199,9 @@ static void php_date_sub(zval *object, zval *interval, zval *return_value TSRMLS
- return;
- }
-
-- if (intobj->diff->invert) {
-- bias = -1;
-- }
--
-- memset(&dateobj->time->relative, 0, sizeof(struct timelib_rel_time));
-- dateobj->time->relative.y = 0 - (intobj->diff->y * bias);
-- dateobj->time->relative.m = 0 - (intobj->diff->m * bias);
-- dateobj->time->relative.d = 0 - (intobj->diff->d * bias);
-- dateobj->time->relative.h = 0 - (intobj->diff->h * bias);
-- dateobj->time->relative.i = 0 - (intobj->diff->i * bias);
-- dateobj->time->relative.s = 0 - (intobj->diff->s * bias);
-- dateobj->time->have_relative = 1;
-- dateobj->time->sse_uptodate = 0;
--
-- timelib_update_ts(dateobj->time, NULL);
-- timelib_update_from_sse(dateobj->time);
--
-- dateobj->time->have_relative = 0;
-+ new_time = timelib_sub(dateobj->time, intobj->diff);
-+ timelib_time_dtor(dateobj->time);
-+ dateobj->time = new_time;
- }
-
- /* {{{ proto DateTime date_sub(DateTime object, DateInterval interval)
---
-1.8.4.3
-
diff --git a/php55.spec b/php55.spec
index 5d2c11f..1069a40 100644
--- a/php55.spec
+++ b/php55.spec
@@ -100,7 +100,7 @@
%endif
#global snapdate 201308300430
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -108,7 +108,7 @@ Version: 5.5.8
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.2.%{?snapdate}%{?rcver}%{?dist}
%else
-Release: 1%{?dist}.1
+Release: 1%{?dist}
%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -175,8 +175,6 @@ Patch91: php-5.3.7-oci8conf.patch
# Fixes for tests
# WIP
-Patch200: php-wip.patch
-Patch201: php-wip2.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -380,10 +378,6 @@ Provides: php-pecl-zendopcache = %{opcachever}
Provides: php-pecl-zendopcache%{?_isa} = %{opcachever}
Provides: php-pecl(opcache) = %{opcachever}
Provides: php-pecl(opcache)%{?_isa} = %{opcachever}
-# Only one opcode cache could be enabled
-Conflicts: php-xcache
-# APC 3.1.15 offer an option to disable opcache
-Conflicts: php-pecl-apc < 3.1.15
%description opcache
The Zend OPcache provides faster PHP execution through opcode caching and
@@ -890,8 +884,6 @@ rm -rf ext/json
# security patches
# WIP patch
-%patch200 -p0 -b .wip
-%patch201 -p1 -b .wip2
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1866,6 +1858,11 @@ fi
%changelog
+* Wed Jan 8 2014 Remi Collet <rcollet@redhat.com> 5.5.8-1
+- update to 5.5.8
+- drop conflicts with other opcode caches as both can
+ be used only for user data cache
+
* Wed Jan 8 2014 Remi Collet <rcollet@redhat.com> 5.5.8-0.2.RC1
- another test build of 5.5.8RC1
diff --git a/strip.sh b/strip.sh
index 5939bec..d56547b 100755
--- a/strip.sh
+++ b/strip.sh
@@ -4,22 +4,29 @@ if [ -z "$1" ]; then
echo "usage $0 version"
exit 1;
fi
-if [ ! -f php-$1.tar.xz ]; then
+
+if [ -f php-$1.tar.xz ]; then
+ told=php-$1.tar.xz
+elif [ -f php-$1.tar.bz2 ]; then
+ told=php-$1.tar.bz2
+else
echo "missing php-$1.tar.xz archive"
exit 2;
fi
+tnew=php-$1-strip.tar.xz
+
old=$(mktemp)
new=$(mktemp)
echo "Untar..."
-tar xf php-$1.tar.xz
+tar xf $told
rm -rf php-$1/ext/json
echo "Tar..."
-tar cJf php-$1-strip.tar.xz php-$1
+tar cJf $tnew php-$1
echo "Diff..."
-tar tf php-$1.tar.xz | sort >$old
-tar tf php-$1-strip.tar.xz | sort >$new
+tar tf $told | sort >$old
+tar tf $tnew | sort >$new
diff $old $new
rm -f $old $new