summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-06-20 07:41:43 +0200
committerRemi Collet <fedora@famillecollet.com>2013-06-20 07:41:43 +0200
commit3630ef1e81c94e3a3232f6276856706933610490 (patch)
treee7804d5fa79530c209e6d0c11d1b1de6bad339d0
parentbbdabff19318c120baea33a1b537efa65c9c4f6e (diff)
php 5.5: drop json from sources
-rw-r--r--php55.spec35
-rwxr-xr-xstrip.sh25
2 files changed, 35 insertions, 25 deletions
diff --git a/php55.spec b/php55.spec
index ce323d5..5e92030 100644
--- a/php55.spec
+++ b/php55.spec
@@ -101,7 +101,9 @@ URL: http://www.php.net/
%if 0%{?snapdate}
Source0: http://snaps.php.net/php5.5-%{snapdate}.tar.xz
%else
-Source0: http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
+# Need to download official tarball and strip non-free stuff
+# wget http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
+# ./strip.sh %{version}
%endif
Source1: php.conf
Source2: php.ini
@@ -113,6 +115,7 @@ Source7: php-fpm.logrotate
Source8: php-fpm.sysconfig
Source9: php.modconf
Source10: php.ztsmodconf
+Source11: strip.sh
# Configuration files for some extensions
Source50: opcache.ini
Source51: opcache-default.blacklist
@@ -294,13 +297,8 @@ Provides: php-sockets, php-sockets%{?_isa}
Provides: php-spl, php-spl%{?_isa}
Provides: php-standard = %{version}, php-standard%{?_isa} = %{version}
Provides: php-tokenizer, php-tokenizer%{?_isa}
-%if %{with_json}
-Provides: php-json, php-json%{?_isa}
-Obsoletes: php-pecl-json < 1.2.2
-%else
# Temporary circular dep (to remove for bootstrap)
Requires: php-pecl-jsonc%{?_isa}
-%endif
%if %{with_zip}
Provides: php-zip, php-zip%{?_isa}
Obsoletes: php-pecl-zip < 1.11
@@ -329,10 +327,8 @@ Provides: php-zts-devel = %{version}-%{release}
Provides: php-zts-devel%{?_isa} = %{version}-%{release}
%endif
Obsoletes: php53-devel, php53u-devel, php54-devel, php55-devel
-%if ! %{with_json}
# Temporary circular dep (to remove for bootstrap)
Requires: php-pecl-jsonc-devel%{?_isa}
-%endif
%description devel
The php-devel package contains the files needed for building PHP
@@ -1108,11 +1104,6 @@ build --libdir=%{_libdir}/php \
%else
--without-sqlite3 \
%endif
-%if %{with_json}
- --enable-json=shared \
-%else
- --disable-json \
-%endif
%if %{with_zip}
--enable-zip=shared \
%endif
@@ -1142,7 +1133,7 @@ without_shared="--without-gd \
--disable-opcache \
--disable-xmlreader --disable-xmlwriter \
--without-sqlite3 --disable-phar --disable-fileinfo \
- --disable-json --without-pspell --disable-wddx \
+ --without-pspell --disable-wddx \
--without-curl --disable-posix --disable-xml \
--disable-simplexml --disable-exif --without-gettext \
--without-iconv --disable-ftp --without-bz2 --disable-ctype \
@@ -1255,11 +1246,6 @@ build --includedir=%{_includedir}/php-zts \
%else
--without-sqlite3 \
%endif
-%if %{with_json}
- --enable-json=shared \
-%else
- --disable-json \
-%endif
%if %{with_zip}
--enable-zip=shared \
%endif
@@ -1487,9 +1473,6 @@ for mod in pgsql odbc ldap snmp xmlrpc imap \
enchant phar fileinfo intl \
mcrypt tidy pdo_dblib mssql pspell curl wddx \
posix shmop sysvshm sysvsem sysvmsg recode xml \
-%if %{with_json}
- json \
-%endif
%if %{with_libmysql}
mysql mysqli pdo_mysql \
%endif
@@ -1563,9 +1546,6 @@ cat files.curl files.phar files.fileinfo \
files.exif files.gettext files.iconv files.calendar \
files.ftp files.bz2 files.ctype files.sockets \
files.tokenizer > files.common
-%if %{with_json}
-cat files.json >> files.common
-%endif
%if %{with_zip}
cat files.zip >> files.common
%endif
@@ -1820,6 +1800,11 @@ fi
%changelog
+* Fri Jun 14 2013 Remi Collet <rcollet@redhat.com> 5.5.0-0.11.RC3
+- also drop JSON from sources
+- clean conditional for JSON (as removed from the sources)
+- clean conditional for FPM (always build)
+
* Fri Jun 14 2013 Remi Collet <rcollet@redhat.com> 5.5.0-0.36.RC3.1
- EL-5 rebuild with gd-last
diff --git a/strip.sh b/strip.sh
new file mode 100755
index 0000000..5939bec
--- /dev/null
+++ b/strip.sh
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+if [ -z "$1" ]; then
+ echo "usage $0 version"
+ exit 1;
+fi
+if [ ! -f php-$1.tar.xz ]; then
+ echo "missing php-$1.tar.xz archive"
+ exit 2;
+fi
+old=$(mktemp)
+new=$(mktemp)
+
+echo "Untar..."
+tar xf php-$1.tar.xz
+rm -rf php-$1/ext/json
+echo "Tar..."
+tar cJf php-$1-strip.tar.xz php-$1
+
+echo "Diff..."
+tar tf php-$1.tar.xz | sort >$old
+tar tf php-$1-strip.tar.xz | sort >$new
+diff $old $new
+
+rm -f $old $new