summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-23 08:06:56 +0200
committerRemi Collet <remi@php.net>2022-06-23 08:06:56 +0200
commit2d3b0d79f3018e54d2d3aeab873d9f6f266c4b12 (patch)
tree120937917a72d01f6ad6cf4ec772ff6901389c65
parenta4201fe247b1230830bcf7f8b89db5b699f7ca99 (diff)
rebuild with gd 2.3.3HEADmaster
myqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626
-rw-r--r--bug81719.patch29
-rw-r--r--php55.spec19
2 files changed, 39 insertions, 9 deletions
diff --git a/bug81719.patch b/bug81719.patch
new file mode 100644
index 0000000..37eda17
--- /dev/null
+++ b/bug81719.patch
@@ -0,0 +1,29 @@
+From 569b03f03929588741bb3dce5168d70805838143 Mon Sep 17 00:00:00 2001
+From: Stanislav Malyshev <smalyshev@gmail.com>
+Date: Mon, 6 Jun 2022 00:56:51 -0600
+Subject: [PATCH] Fix bug #81719: mysqlnd/pdo password buffer overflow
+
+(cherry picked from commit 58006537fc5f133ae8549efe5118cde418b3ace9)
+(cherry picked from commit 9433de72e291db518357fe55531cc15432d43ec4)
+(cherry picked from commit 1560224d3a26574f0195af3853e4d7e050b0b06f)
+(cherry picked from commit 5e1d9182748c5330c4bf2154da858206e76914b6)
+(cherry picked from commit 1f8f48703c7800b0e90344ccd73e74a1727f8a72)
+(cherry picked from commit e47e59289578140103efd03fcd58ea24776a6347)
+---
+ ext/mysqlnd/mysqlnd_wireprotocol.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/ext/mysqlnd/mysqlnd_wireprotocol.c b/ext/mysqlnd/mysqlnd_wireprotocol.c
+index 844330fbf10..6e5c539d149 100644
+--- a/ext/mysqlnd/mysqlnd_wireprotocol.c
++++ b/ext/mysqlnd/mysqlnd_wireprotocol.c
+@@ -763,7 +763,8 @@ static size_t
+ php_mysqlnd_change_auth_response_write(void * _packet, MYSQLND_CONN_DATA * conn TSRMLS_DC)
+ {
+ MYSQLND_PACKET_CHANGE_AUTH_RESPONSE *packet= (MYSQLND_PACKET_CHANGE_AUTH_RESPONSE *) _packet;
+- zend_uchar * buffer = conn->net->cmd_buffer.length >= packet->auth_data_len? conn->net->cmd_buffer.buffer : mnd_emalloc(packet->auth_data_len);
++ size_t total_packet_size = packet->auth_data_len + MYSQLND_HEADER_SIZE;
++ zend_uchar * buffer = conn->net->cmd_buffer.length >= total_packet_size? conn->net->cmd_buffer.buffer : mnd_emalloc(total_packet_size);
+ zend_uchar *p = buffer + MYSQLND_HEADER_SIZE; /* start after the header */
+
+ DBG_ENTER("php_mysqlnd_change_auth_response_write");
diff --git a/php55.spec b/php55.spec
index 8701fd7..5111ba0 100644
--- a/php55.spec
+++ b/php55.spec
@@ -141,7 +141,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.38
-Release: 12%{?dist}
+Release: 13%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -266,6 +266,7 @@ Patch160: bug77231.patch
Patch161: bug77242.patch
Patch162: bug77380.patch
Patch163: bug78599.patch
+Patch164: bug81719.patch
# Security fixes (200+)
@@ -816,12 +817,7 @@ License: PHP and BSD
Requires: php-common%{?_isa} = %{version}-%{release}
BuildRequires: t1lib-devel
%if %{with_libgd}
-BuildRequires: gd-devel >= 2.1.1
-%if 0%{?fedora} <= 19 && 0%{?rhel} <= 7
-Requires: gd-last%{?_isa} >= 2.1.1
-%else
-Requires: gd%{?_isa} >= 2.1.1
-%endif
+BuildRequires: gd-devel >= 2.3.3
%else
# Required to build the bundled GD library
BuildRequires: libjpeg-devel
@@ -1095,6 +1091,7 @@ rm -rf ext/json
%patch161 -p1 -b .bug77242
%patch162 -p1 -b .bug77380
%patch163 -p1 -b .bug78599
+%patch164 -p1 -b .bug81719
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -1108,7 +1105,7 @@ rm -rf ext/json
# WIP patch
# Prevent %%doc confusion over LICENSE files
-cp Zend/LICENSE Zend/ZEND_LICENSE
+cp Zend/LICENSE ZEND_LICENSE
cp TSRM/LICENSE TSRM_LICENSE
cp ext/ereg/regex/COPYRIGHT regex_COPYRIGHT
%if ! %{with_libgd}
@@ -1985,7 +1982,7 @@ EOF
%files common -f files.common
%defattr(-,root,root)
%doc CODING_STANDARDS CREDITS EXTENSIONS LICENSE NEWS README*
-%doc Zend/ZEND_* TSRM_LICENSE regex_COPYRIGHT
+%doc ZEND_LICENSE TSRM_LICENSE regex_COPYRIGHT
%doc libmagic_LICENSE
%doc phar_LICENSE
%doc php.ini-*
@@ -2119,6 +2116,10 @@ EOF
%changelog
+* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 5.5.38-13
+- rebuild with gd 2.3.3
+- myqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626
+
* Tue Oct 22 2019 Remi Collet <remi@remirepo.net> - 5.5.38-12
- FPM:
Fix CVE-2019-11043 env_path_info underflow in fpm_main.c