summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-11-04 06:49:55 +0100
committerRemi Collet <fedora@famillecollet.com>2013-11-04 06:49:55 +0100
commit2011698bdfcd8b47fafb6dc94c0d519767e09537 (patch)
treef0feeda8793495e71c3a30bf4cf13c88266f789b
parent60402de9075dee1a5ac9da651360fd562ee26c92 (diff)
php 5.5: build phar shared, opcache loaded with RTLD_LAZY
-rw-r--r--php-5.4.0-dlopen.patch6
-rw-r--r--php55.spec15
2 files changed, 12 insertions, 9 deletions
diff --git a/php-5.4.0-dlopen.patch b/php-5.4.0-dlopen.patch
index c2b0e40..10d3f2b 100644
--- a/php-5.4.0-dlopen.patch
+++ b/php-5.4.0-dlopen.patch
@@ -5,13 +5,13 @@
# if defined(RTLD_GROUP) && defined(RTLD_WORLD) && defined(RTLD_PARENT)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
-+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
++# define DL_LOAD(libname) dlopen(libname, (strstr(libname, "opcache") ? RTLD_LAZY : RTLD_NOW) | RTLD_GLOBAL | RTLD_GROUP | RTLD_WORLD | RTLD_PARENT)
# elif defined(RTLD_DEEPBIND)
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL | RTLD_DEEPBIND)
-+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL | RTLD_DEEPBIND)
++# define DL_LOAD(libname) dlopen(libname, (strstr(libname, "opcache") ? RTLD_LAZY : RTLD_NOW) | RTLD_GLOBAL | RTLD_DEEPBIND)
# else
-# define DL_LOAD(libname) dlopen(libname, RTLD_LAZY | RTLD_GLOBAL)
-+# define DL_LOAD(libname) dlopen(libname, RTLD_NOW | RTLD_GLOBAL)
++# define DL_LOAD(libname) dlopen(libname, (strstr(libname, "opcache") ? RTLD_LAZY : RTLD_NOW) | RTLD_GLOBAL)
# endif
# define DL_UNLOAD dlclose
# if defined(DLSYM_NEEDS_UNDERSCORE)
diff --git a/php55.spec b/php55.spec
index b1844fd..4d55f2e 100644
--- a/php55.spec
+++ b/php55.spec
@@ -100,7 +100,7 @@ Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.6
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.2.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.3.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 2%{?dist}
%endif
@@ -1140,7 +1140,7 @@ build --libdir=%{_libdir}/php \
--without-readline \
--with-libedit \
--with-pspell=shared \
- --enable-phar \
+ --enable-phar=shared \
--with-mcrypt=shared,%{_prefix} \
--with-tidy=shared,%{_prefix} \
--with-mssql=shared,%{_prefix} \
@@ -1159,7 +1159,7 @@ without_shared="--without-gd \
--disable-dom --disable-dba --without-unixODBC \
--disable-opcache \
--disable-xmlreader --disable-xmlwriter \
- --without-sqlite3 --enable-phar --disable-fileinfo \
+ --without-sqlite3 --disable-phar --disable-fileinfo \
--without-pspell --disable-wddx \
--without-curl --disable-posix --disable-xml \
--disable-simplexml --disable-exif --without-gettext \
@@ -1282,7 +1282,7 @@ build --includedir=%{_includedir}/php-zts \
--without-readline \
--with-libedit \
--with-pspell=shared \
- --enable-phar \
+ --enable-phar=shared \
--with-mcrypt=shared,%{_prefix} \
--with-tidy=shared,%{_prefix} \
--with-mssql=shared,%{_prefix} \
@@ -1503,7 +1503,7 @@ for mod in pgsql odbc ldap snmp xmlrpc imap \
%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
sqlite3 \
%endif
- enchant fileinfo intl \
+ enchant phar fileinfo intl \
mcrypt tidy pdo_dblib mssql pspell curl wddx \
posix shmop sysvshm sysvsem sysvmsg recode xml \
%if %{with_libmysql}
@@ -1575,7 +1575,7 @@ cat files.sqlite3 >> files.pdo
%endif
# Package zip, curl, phar and fileinfo in -common.
-cat files.curl files.fileinfo \
+cat files.curl files.phar files.fileinfo \
files.exif files.gettext files.iconv files.calendar \
files.ftp files.bz2 files.ctype files.sockets \
files.tokenizer > files.common
@@ -1841,6 +1841,9 @@ fi
%changelog
+* Mon Nov 4 2013 Remi Collet <remi@fedoraproject.org> 5.5.6-0.3.RC1
+- build phar shared, opcache loaded with RTLD_LAZY
+
* Sat Nov 2 2013 Remi Collet <remi@fedoraproject.org> 5.5.6-0.2.RC1
- build phar static for opcache dep.