summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-14 14:38:48 +0100
commit14498c9dfb1211e6184b5972a2e274e1489d805b (patch)
tree9aa7affc834d39eba3828f0031cb3c9797a525ae
parent33b99d2acc9a943837ee6436513c6bd62e5ae4b2 (diff)
php/curl: add CURL_SSLVERSION_TLSv1_x constant
-rw-r--r--php-5.5.30-curl.patch14
-rw-r--r--php55.spec11
2 files changed, 23 insertions, 2 deletions
diff --git a/php-5.5.30-curl.patch b/php-5.5.30-curl.patch
new file mode 100644
index 0000000..0c72d56
--- /dev/null
+++ b/php-5.5.30-curl.patch
@@ -0,0 +1,14 @@
+diff -up php-5.5.30/ext/curl/interface.c.old php-5.5.30/ext/curl/interface.c
+--- php-5.5.30/ext/curl/interface.c.old 2015-12-14 13:58:27.911676702 +0100
++++ php-5.5.30/ext/curl/interface.c 2015-12-14 14:08:04.581124497 +0100
+@@ -1213,7 +1213,9 @@ PHP_MINIT_FUNCTION(curl)
+ REGISTER_CURL_CONSTANT(CURLSSLOPT_ALLOW_BEAST);
+ #endif
+
+-#if LIBCURL_VERSION_NUM >= 0x072200 /* Available since 7.34.0 */
++#if LIBCURL_VERSION_NUM >= 0x071300 /* Available since 7.19.0 (in upstream curl 7.34)
++ backported in RHEL-7 curl-7.29.0-16.el7 rhbz#1012136
++ backported in RHEL-6 curl-7.19.7-43.el6 rhbz#1036789 */
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_0);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_1);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_2);
diff --git a/php55.spec b/php55.spec
index b2a1cd5..d9f6613 100644
--- a/php55.spec
+++ b/php55.spec
@@ -152,8 +152,8 @@ URL: http://www.php.net/
Source0: http://snaps.php.net/php5.5-%{snapdate}.tar.xz
%else
# Need to download official tarball and strip non-free stuff
-# wget http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
-# ./strip.sh %{version}
+# wget http://www.php.net/distributions/php-%%{version}%%{?rcver}.tar.xz
+# ./strip.sh %%{version}
Source0: php-%{version}%{?rcver}-strip.tar.xz
%endif
Source1: php.conf
@@ -177,6 +177,7 @@ Patch5: php-5.2.0-includedir.patch
Patch6: php-5.5.19-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-5.4.7-libdb.patch
+Patch9: php-5.5.30-curl.patch
# Fixes for extension modules
# https://bugs.php.net/63171 no odbc call during timeout
@@ -936,6 +937,9 @@ rm -rf ext/json
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
%patch8 -p1 -b .libdb
+%if 0%{?rhel}
+%patch9 -p1 -b .curltls
+%endif
%patch21 -p1 -b .odbctimer
@@ -1967,6 +1971,9 @@ fi
%changelog
+* Mon Dec 14 2015 Remi Collet <remi@fedoraproject.org> 5.5.30-1.1
+- curl: add CURL_SSLVERSION_TLSv1_x constant
+
* Thu Oct 1 2015 Remi Collet <remi@fedoraproject.org> 5.5.30-1
- Update to 5.5.30
http://www.php.net/releases/5_5_30.php