summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-09-19 13:18:41 +0200
committerRemi Collet <fedora@famillecollet.com>2013-09-19 13:18:41 +0200
commit0d579eea43f821d5687091f23f08f062ce6edf89 (patch)
treec834f031e4a2282bbe2ce5149967cda5041e6139
parent7c923a4bd10082925e2260f7a79a501d62ebbef6 (diff)
PHP 5.5.4
-rw-r--r--php-5.5.4-date.patch63
-rw-r--r--php-fpm-www.conf3
-rw-r--r--php.conf1
-rw-r--r--php.ini19
-rw-r--r--php55.spec16
5 files changed, 25 insertions, 77 deletions
diff --git a/php-5.5.4-date.patch b/php-5.5.4-date.patch
deleted file mode 100644
index 5f9bffe..0000000
--- a/php-5.5.4-date.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- php5.5-201308300430/ext/date/php_date.c.old 2013-08-30 10:04:46.963985553 +0200
-+++ php5.5-201308300430/ext/date/php_date.c 2013-08-30 10:05:54.664183035 +0200
-@@ -2198,13 +2198,13 @@
- /* first we add the date and time in ISO format */
- MAKE_STD_ZVAL(zv);
- ZVAL_STRING(zv, date_format("Y-m-d H:i:s", 12, dateobj->time, 1), 0);
-- zend_hash_update(props, "date", 5, &zv, sizeof(zval), NULL);
-+ zend_hash_update(props, "date", 5, &zv, sizeof(zv), NULL);
-
- /* then we add the timezone name (or similar) */
- if (dateobj->time->is_localtime) {
- MAKE_STD_ZVAL(zv);
- ZVAL_LONG(zv, dateobj->time->zone_type);
-- zend_hash_update(props, "timezone_type", 14, &zv, sizeof(zval), NULL);
-+ zend_hash_update(props, "timezone_type", 14, &zv, sizeof(zv), NULL);
-
- MAKE_STD_ZVAL(zv);
- switch (dateobj->time->zone_type) {
-@@ -2227,7 +2227,7 @@
- ZVAL_STRING(zv, dateobj->time->tz_abbr, 1);
- break;
- }
-- zend_hash_update(props, "timezone", 9, &zv, sizeof(zval), NULL);
-+ zend_hash_update(props, "timezone", 9, &zv, sizeof(zv), NULL);
- }
-
- return props;
-@@ -2305,7 +2305,7 @@
-
- MAKE_STD_ZVAL(zv);
- ZVAL_LONG(zv, tzobj->type);
-- zend_hash_update(props, "timezone_type", 14, &zv, sizeof(zval), NULL);
-+ zend_hash_update(props, "timezone_type", 14, &zv, sizeof(zv), NULL);
-
- MAKE_STD_ZVAL(zv);
- switch (tzobj->type) {
-@@ -2327,7 +2327,7 @@
- ZVAL_STRING(zv, tzobj->tzi.z.abbr, 1);
- break;
- }
-- zend_hash_update(props, "timezone", 9, &zv, sizeof(zval), NULL);
-+ zend_hash_update(props, "timezone", 9, &zv, sizeof(zv), NULL);
-
- return props;
- }
-@@ -2394,7 +2394,7 @@
- #define PHP_DATE_INTERVAL_ADD_PROPERTY(n,f) \
- MAKE_STD_ZVAL(zv); \
- ZVAL_LONG(zv, (long)intervalobj->diff->f); \
-- zend_hash_update(props, n, strlen(n) + 1, &zv, sizeof(zval), NULL);
-+ zend_hash_update(props, n, strlen(n) + 1, &zv, sizeof(zv), NULL);
-
- PHP_DATE_INTERVAL_ADD_PROPERTY("y", y);
- PHP_DATE_INTERVAL_ADD_PROPERTY("m", m);
-@@ -2411,7 +2411,7 @@
- } else {
- MAKE_STD_ZVAL(zv);
- ZVAL_FALSE(zv);
-- zend_hash_update(props, "days", 5, &zv, sizeof(zval), NULL);
-+ zend_hash_update(props, "days", 5, &zv, sizeof(zv), NULL);
- }
- PHP_DATE_INTERVAL_ADD_PROPERTY("special_type", special.type);
- PHP_DATE_INTERVAL_ADD_PROPERTY("special_amount", special.amount);
diff --git a/php-fpm-www.conf b/php-fpm-www.conf
index 9cdbb4f..502feff 100644
--- a/php-fpm-www.conf
+++ b/php-fpm-www.conf
@@ -222,5 +222,6 @@ php_admin_flag[log_errors] = on
; Set session path to a directory owned by process user
php_value[session.save_handler] = files
-php_value[session.save_path] = /var/lib/php/session
+php_value[session.save_path] = /var/lib/php/session
+php_value[soap.wsdl_cache_dir] = /var/lib/php/wsdlcache
diff --git a/php.conf b/php.conf
index 64eb5fd..7000043 100644
--- a/php.conf
+++ b/php.conf
@@ -30,3 +30,4 @@ DirectoryIndex index.php
#
php_value session.save_handler "files"
php_value session.save_path "/var/lib/php/session"
+php_value soap.wsdl_cache_dir "/var/lib/php/wsdlcache"
diff --git a/php.ini b/php.ini
index 7210341..539f961 100644
--- a/php.ini
+++ b/php.ini
@@ -197,13 +197,12 @@
engine = On
; This directive determines whether or not PHP will recognize code between
-; <? and ?> tags as PHP source which should be processed as such. It's been
-; recommended for several years that you not use the short tag "short cut" and
-; instead to use the full <?php and ?> tag combination. With the wide spread use
-; of XML and use of these tags by other languages, the server can become easily
-; confused and end up parsing the wrong code in the wrong context. But because
-; this short cut has been a feature for such a long time, it's currently still
-; supported for backwards compatibility, but we recommend you don't use them.
+; <? and ?> tags as PHP source which should be processed as such. It is
+; generally recommended that <?php and ?> should be used and that this feature
+; should be disabled, as enabling it may result in issues when generating XML
+; documents, however this remains supported for backward compatibility reasons.
+; Note that this directive does not control the <?= shorthand tag, which can be
+; used regardless of this directive.
; Default Value: On
; Development Value: Off
; Production Value: Off
@@ -1764,7 +1763,11 @@ soap.wsdl_cache_enabled=1
; Sets the directory name where SOAP extension will put cache files.
; http://php.net/soap.wsdl-cache-dir
-soap.wsdl_cache_dir="/tmp"
+
+; RPM note : cache directory must be owned by process owner
+; for mod_php, see /etc/httpd/conf.d/php.conf
+; for php-fpm, see /etc/php-fpm.d/*conf
+;soap.wsdl_cache_dir="/tmp"
; (time to live) Sets the number of second while cached file will be used
; instead of original one.
diff --git a/php55.spec b/php55.spec
index 7dc9355..6e1dc7b 100644
--- a/php55.spec
+++ b/php55.spec
@@ -79,7 +79,7 @@
%global db_devel libdb-devel
%endif
-%global snapdate 201308300430
+#global snapdate 201308300430
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
@@ -126,7 +126,6 @@ Patch5: php-5.2.0-includedir.patch
Patch6: php-5.2.4-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-5.4.7-libdb.patch
-Patch9: php-5.5.4-date.patch
# Fixes for extension modules
# https://bugs.php.net/63171 no odbc call during timeout
@@ -836,7 +835,6 @@ rm -rf ext/json
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
%patch8 -p1 -b .libdb
-%patch9 -p1 -b .date
%patch21 -p1 -b .odbctimer
@@ -1036,7 +1034,7 @@ ln -sf ../configure
--with-layout=GNU \
--with-kerberos \
--with-libxml-dir=%{_prefix} \
-%if 0%{?fedora} >= 16 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 18 || 0%{?rhel} >= 5
--with-system-tzdata \
%endif
--with-mhash \
@@ -1427,6 +1425,7 @@ install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d
%endif
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
+install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
# PHP-FPM stuff
# Log
@@ -1600,7 +1599,7 @@ echo -e "\nWARNING : These %{name}-* RPM are not official Fedora / Red Hat build
echo -e "overrides the official ones. Don't file bugs on Fedora Project nor Red Hat.\n"
echo -e "Use dedicated forums http://forums.famillecollet.com/\n"
-%if %{?fedora}%{!?fedora:99} <= 17
+%if %{?fedora}%{!?fedora:99} < 18
echo -e "WARNING : Fedora %{fedora} is now EOL :"
echo -e "You should consider upgrading to a supported release.\n"
%endif
@@ -1689,6 +1688,7 @@ fi
%{_httpd_moddir}/libphp5-zts.so
%endif
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
+%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
%config(noreplace) %{_httpd_confdir}/php.conf
%if "%{_httpd_modconfdir}" != "%{_httpd_confdir}"
%config(noreplace) %{_httpd_modconfdir}/10-php.conf
@@ -1822,6 +1822,12 @@ fi
%changelog
+* Thu Sep 19 2013 Remi Collet <rcollet@redhat.com> - 5.5.4-1
+- update to 5.5.4
+- improve security, use specific soap.wsdl_cache_dir
+ use /var/lib/php/wsdlcache for mod_php and php-fpm
+- sync short_tag comments in php.ini with upstream
+
* Fri Aug 30 2013 Remi Collet <rcollet@redhat.com> - 5.5.4.0.1-201308300430
- test build with -fsanitize=address
- test build for https://bugs.php.net/65564