summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-11 11:26:20 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-11 11:26:20 +0100
commit08f6078a7af6dddcc2dbda6c2eb047a6148da5ce (patch)
treee888bc6ee70efe5b4df0064876665516d5a88fce
parent4eacc1a72022dd240658c79c792f6bbfc5e4aa0c (diff)
- prevent php_config.h changes across (otherwise identical) rebuilds
- drop "Configure Command" from phpinfo output
-rw-r--r--php-5.4.9-fixheader.patch23
-rw-r--r--php-5.4.9-phpinfo.patch27
-rw-r--r--php55.spec12
3 files changed, 61 insertions, 1 deletions
diff --git a/php-5.4.9-fixheader.patch b/php-5.4.9-fixheader.patch
new file mode 100644
index 0000000..f4e7db5
--- /dev/null
+++ b/php-5.4.9-fixheader.patch
@@ -0,0 +1,23 @@
+
+Make generated php_config.h constant across rebuilds.
+
+--- php-5.4.9/configure.in.fixheader
++++ php-5.4.9/configure.in
+@@ -1258,7 +1258,7 @@ fi
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
+ EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
+
+-PHP_BUILD_DATE=`date '+%Y-%m-%d'`
++PHP_BUILD_DATE=`date '+%Y-%m-%d' -r $srcdir/NEWS`
+ AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
+
+ case $host_alias in
+@@ -1269,7 +1269,7 @@ case $host_alias in
+ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[hardcode for each of the cross compiler host])
+ ;;
+ *)
+- PHP_UNAME=`uname -a | xargs`
++ PHP_UNAME=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
+ PHP_OS=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
diff --git a/php-5.4.9-phpinfo.patch b/php-5.4.9-phpinfo.patch
new file mode 100644
index 0000000..b52a2f8
--- /dev/null
+++ b/php-5.4.9-phpinfo.patch
@@ -0,0 +1,27 @@
+
+Drop "Configure Command" from phpinfo as it doesn't
+provide any useful information.
+The available extensions are not related to this command.
+
+--- php-5.4.9/ext/standard/info.c.orig 2012-12-11 10:43:02.450578276 +0100
++++ php-5.4.9/ext/standard/info.c 2012-12-11 10:44:12.530820821 +0100
+@@ -704,9 +704,6 @@
+ #ifdef ARCHITECTURE
+ php_info_print_table_row(2, "Architecture", ARCHITECTURE);
+ #endif
+-#ifdef CONFIGURE_COMMAND
+- php_info_print_table_row(2, "Configure Command", CONFIGURE_COMMAND );
+-#endif
+
+ if (sapi_module.pretty_name) {
+ php_info_print_table_row(2, "Server API", sapi_module.pretty_name );
+--- php-5.4.9/ext/standard/tests/general_functions/phpinfo.phpt.orig 2012-12-11 11:07:26.959156091 +0100
++++ php-5.4.9/ext/standard/tests/general_functions/phpinfo.phpt 2012-12-11 11:07:30.899170970 +0100
+@@ -20,7 +20,6 @@
+
+ System => %s
+ Build Date => %s%a
+-Configure Command => %s
+ Server API => Command Line Interface
+ Virtual Directory Support => %s
+ Configuration File (php.ini) Path => %s
diff --git a/php55.spec b/php55.spec
index 2a9c01c..0b93ec6 100644
--- a/php55.spec
+++ b/php55.spec
@@ -68,7 +68,7 @@ Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.6.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.7.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 2%{?dist}
%endif
@@ -115,6 +115,10 @@ Patch43: php-5.4.0-phpize.patch
Patch44: php-5.4.5-system-libzip.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.4.8-ldap_r.patch
+# Make php_config.h constant across builds
+Patch46: php-5.4.9-fixheader.patch
+# drop "Configure command" from phpinfo output
+Patch47: php-5.4.9-phpinfo.patch
# Fixes for tests
@@ -778,6 +782,8 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
%patch45 -p1 -b .ldap_r
%endif
+%patch46 -p1 -b .fixheader
+%patch47 -p1 -b .phpinfo
%patch91 -p1 -b .remi-oci8
@@ -1637,6 +1643,10 @@ fi
%changelog
+* Tue Dec 11 2012 Remi Collet <remi@fedoraproject.org> 5.5.0-0.7.201212110630
+- prevent php_config.h changes across (otherwise identical) rebuilds
+- drop "Configure Command" from phpinfo output
+
* Tue Dec 11 2012 Remi Collet <remi@fedoraproject.org> 5.5.0-0.6.201212110630
- new snapshot
- move gmp in new sub-package