summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-28 09:22:19 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-28 09:22:19 +0100
commit02c190c6d9e2a4a1e01c43621196b7366ef75624 (patch)
treed9bfda0074f63248f54593a35b2d7992399ff145
parent4513172ab2a6010950ef2e66520b38562516a1b0 (diff)
PHP 5.5.0beta2
-rw-r--r--php-5.5.0-wip.patch29
-rw-r--r--php55.spec25
2 files changed, 15 insertions, 39 deletions
diff --git a/php-5.5.0-wip.patch b/php-5.5.0-wip.patch
deleted file mode 100644
index dd2481d..0000000
--- a/php-5.5.0-wip.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/Zend/zend_language_parser.y b/Zend/zend_language_parser.y
-index ccbc9b1..6a9a24a 100644
---- a/Zend/zend_language_parser.y
-+++ b/Zend/zend_language_parser.y
-@@ -41,17 +41,19 @@ static YYSIZE_T zend_yytnamerr(char*, const char*);
-
- #define YYERROR_VERBOSE
- #define YYSTYPE znode
--#ifdef ZTS
--# define YYPARSE_PARAM tsrm_ls
--# define YYLEX_PARAM tsrm_ls
--#endif
--
-
- %}
-
- %pure_parser
- %expect 3
-
-+%code requires {
-+#ifdef ZTS
-+# define YYPARSE_PARAM tsrm_ls
-+# define YYLEX_PARAM tsrm_ls
-+#endif
-+}
-+
- %token END 0 "end of file"
- %left T_INCLUDE T_INCLUDE_ONCE T_EVAL T_REQUIRE T_REQUIRE_ONCE
- %token T_INCLUDE "include (T_INCLUDE)"
diff --git a/php55.spec b/php55.spec
index f4665ba..4e6ff42 100644
--- a/php55.spec
+++ b/php55.spec
@@ -72,14 +72,14 @@
%global db_devel libdb-devel
%endif
-%global snapdate 201303251230
-#global rcver RC1
+#global snapdate 201303251230
+%global rcver beta2
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.21.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.22.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 2%{?dist}
%endif
@@ -93,7 +93,7 @@ URL: http://www.php.net/
%if 0%{?snapdate}
Source0: http://snaps.php.net/php5.5-%{snapdate}.tar.xz
%else
-Source0: http://www.php.net/distributions/php-%{version}%{?rcver}.tar.bz2
+Source0: http://www.php.net/distributions/php-%{version}%{?rcver}.tar.xz
%endif
Source1: php.conf
Source2: php.ini
@@ -139,7 +139,6 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# WIP
-Patch99: php-5.5.0-wip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -323,7 +322,7 @@ extensions. If you need to compile your own PHP extensions, you will
need to install this package.
%package opcache
-Summary: The Zend Optimizer+
+Summary: The Zend OPcache
Group: Development/Languages
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -338,7 +337,7 @@ Conflicts: php-xcache
Conflicts: php-pecl-apc < 3.1.15
%description opcache
-The Zend Optimizer+ provides faster PHP execution through opcode caching and
+The Zend OPcache provides faster PHP execution through opcode caching and
optimization. It improves PHP performance by storing precompiled script
bytecode in the shared memory. This eliminates the stages of reading code from
the disk and compiling it on future access. In addition, it applies a few
@@ -834,7 +833,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch91 -p1 -b .remi-oci8
# wip patches
-%patch99 -p1 -b .wip
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -932,8 +930,10 @@ echo "d /run/php-fpm 755 root root" >php-fpm.tmpfiles
cp %{SOURCE50} .
# Regenerated bison files
-rm Zend/zend_{language,ini}_parser.[ch]
-./genfiles
+# to force, rm Zend/zend_{language,ini}_parser.[ch]
+if [ ! -f Zend/zend_language_parser.c ]; then
+ ./genfiles
+fi
%build
@@ -1780,6 +1780,11 @@ fi
%changelog
+* Thu Mar 28 2013 Remi Collet <rcollet@redhat.com> 5.5.0-0.22.beta2
+- update to 5.5.0beta2
+- Zend Optimizer+ renamed to Zend OPcache
+- sync provided configuration with upstream
+
* Mon Mar 25 2013 Remi Collet <remi@fedoraproject.org> 5.5.0-0.21-201303251230
- new snapshot
- generated parser using system bison, test for https://bugs.php.net/64503