summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-21 19:46:00 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-21 19:46:00 +0200
commit54c38d46e504a1b1545b586910cfa09cc16f2ff1 (patch)
tree38293c5495417a9620f3724075f615a8af090fea /Makefile
php55-extras for Copr
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..9a3dec3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+SRCDIR := $(shell pwd)
+NAME := php-extras
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
+
+debug:
+ time rpmbuild $(RPMDEFINES) --with debug -bb $(NAME).spec
+
+srpm:
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define "scl php55" --define "scl_prefix php55-" -bs $(NAME).spec