summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-5.4.30-noNO.patch43
-rw-r--r--php54.spec8
2 files changed, 49 insertions, 2 deletions
diff --git a/php-5.4.30-noNO.patch b/php-5.4.30-noNO.patch
new file mode 100644
index 0000000..52f54ab
--- /dev/null
+++ b/php-5.4.30-noNO.patch
@@ -0,0 +1,43 @@
+--- ext/standard/tests/strings/setlocale_variation2.phpt.orig 2014-06-11 16:10:00.259326468 +0200
++++ ext/standard/tests/strings/setlocale_variation2.phpt 2014-06-11 16:16:14.396138997 +0200
+@@ -52,6 +52,7 @@
+ //try different locale names
+ $failure_locale = array();
+ $success_count = 0;
++$expected = 0;
+
+ echo "-- Test setlocale() with all available locale in the system --\n";
+ // gather all locales installed in the system(stored $all_system_locales),
+@@ -61,6 +62,10 @@
+ if(setlocale(LC_ALL,$value )){
+ $success_count++;
+ }
++ else if ($value == 'no_NO.ISO-8859-1') {
++ // ignore this one, see rhbz #971416
++ $expected++;
++ }
+ else{
+ //failure values are put in to an array $failure_locale
+ $failure_locale[] = $value;
+@@ -69,11 +74,11 @@
+
+ echo "No of locales found on the machine = ".count($all_system_locales)."\n";
+ echo "No of setlocale() success = ".$success_count."\n";
+-echo "Expected no of failures = 0\n";
++echo "Expected no of failures = $expected\n";
+ echo "Test ";
+ // check if there were any failure of setlocale() function earlier, if any
+ // failure then dump the list of failing locales
+-if($success_count != count($all_system_locales)){
++if(($success_count + $expected) != count($all_system_locales)){
+ echo "FAILED\n";
+ echo "Names of locale() for which setlocale() failed ...\n";
+ var_dump($failure_locale);
+@@ -89,6 +94,6 @@
+ -- Test setlocale() with all available locale in the system --
+ No of locales found on the machine = %d
+ No of setlocale() success = %d
+-Expected no of failures = 0
++Expected no of failures = %d
+ Test PASSED
+ Done
diff --git a/php54.spec b/php54.spec
index 23e0b2a..b248d14 100644
--- a/php54.spec
+++ b/php54.spec
@@ -77,7 +77,7 @@
%endif
#global snapdate 201201041830
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -85,7 +85,7 @@ Version: 5.4.30
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.2.%{?snapdate}%{?rcver}%{?dist}
%else
-Release: 3%{?dist}
+Release: 1%{?dist}
%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -1654,6 +1654,10 @@ fi
%changelog
+* Wed Jun 25 2014 Remi Collet <remi@fedoraproject.org> 5.4.30-1
+- Update to 5.4.30
+ http://www.php.net/releases/5_4_30.php
+
* Tue Jun 17 2014 Remi Collet <rcollet@redhat.com> 5.4.30-0.2.RC1
- fix test for rhbz #971416