summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-5.4.7-libdb.patch24
-rw-r--r--php54.spec5
2 files changed, 28 insertions, 1 deletions
diff --git a/php-5.4.7-libdb.patch b/php-5.4.7-libdb.patch
index 0b1e305..bc4e1fc 100644
--- a/php-5.4.7-libdb.patch
+++ b/php-5.4.7-libdb.patch
@@ -60,3 +60,27 @@
fi
PHP_DBA_STD_RESULT(db4,Berkeley DB4)
+--- php-5.4.7/ext/dba/dba.c.old 2012-09-19 14:55:23.868456900 +0200
++++ php-5.4.7/ext/dba/dba.c 2012-09-19 15:02:42.796009320 +0200
+@@ -52,6 +52,10 @@
+ #include "php_qdbm.h"
+ #include "php_tcadb.h"
+
++#ifdef DB4_INCLUDE_FILE
++#include DB4_INCLUDE_FILE
++#endif
++
+ /* {{{ arginfo */
+ ZEND_BEGIN_ARG_INFO_EX(arginfo_dba_popen, 0, 0, 2)
+ ZEND_ARG_INFO(0, path)
+@@ -522,6 +526,10 @@
+
+ php_info_print_table_start();
+ php_info_print_table_row(2, "DBA support", "enabled");
++#ifdef DB_VERSION_STRING
++ php_info_print_table_row(2, "libdb header version", DB_VERSION_STRING);
++ php_info_print_table_row(2, "libdb library version", db_version(NULL, NULL, NULL));
++#endif
+ if (handlers.c) {
+ smart_str_0(&handlers);
+ php_info_print_table_row(2, "Supported handlers", handlers.c);
diff --git a/php54.spec b/php54.spec
index 1328ec0..bf66181 100644
--- a/php54.spec
+++ b/php54.spec
@@ -440,7 +440,6 @@ The php-soap package contains a dynamic shared object that will add
support to PHP for using the SOAP web services protocol.
%package interbase
-%package interbase
Summary: A module for PHP applications that use Interbase/Firebird databases
Group: Development/Languages
BuildRequires: firebird-devel
@@ -1478,6 +1477,10 @@ fi
%changelog
+* Wed Sep 19 2012 Remi Collet <RPMS@famillecollet.com> 5.4.7-5
+- sync with rawhide
+- patch to report libdb version https://bugs.php.net/63117
+
* Wed Sep 19 2012 Remi Collet <rcollet@redhat.com> 5.4.7-5
- patch to ensure we use latest libdb (not libdb4)