summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-wddx.patch41
-rw-r--r--php54.spec8
2 files changed, 48 insertions, 1 deletions
diff --git a/php-wddx.patch b/php-wddx.patch
new file mode 100644
index 0000000..c3b0eb6
--- /dev/null
+++ b/php-wddx.patch
@@ -0,0 +1,41 @@
+From 95ea1e7ca787537a93c25c401dba010d51aa8d59 Mon Sep 17 00:00:00 2001
+From: Anatol Belski <ab@php.net>
+Date: Sat, 11 May 2013 02:47:48 +0200
+Subject: [PATCH] fixed variable corruption under win x64
+
+---
+ ext/wddx/wddx.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/ext/wddx/wddx.c b/ext/wddx/wddx.c
+index 967da6a..afeca90 100644
+--- a/ext/wddx/wddx.c
++++ b/ext/wddx/wddx.c
+@@ -405,7 +405,7 @@ static void php_wddx_serialize_string(wddx_packet *packet, zval *var TSRMLS_DC)
+
+ if (Z_STRLEN_P(var) > 0) {
+ char *buf;
+- int buf_len;
++ size_t buf_len;
+
+ buf = php_escape_html_entities(Z_STRVAL_P(var), Z_STRLEN_P(var), &buf_len, 0, ENT_QUOTES, NULL TSRMLS_CC);
+
+@@ -626,12 +626,12 @@ static void php_wddx_serialize_array(wddx_packet *packet, zval *arr)
+ */
+ void php_wddx_serialize_var(wddx_packet *packet, zval *var, char *name, int name_len TSRMLS_DC)
+ {
+- char *tmp_buf;
+- char *name_esc;
+- int name_esc_len;
+ HashTable *ht;
+
+ if (name) {
++ size_t name_esc_len;
++ char *tmp_buf, *name_esc;
++
+ name_esc = php_escape_html_entities(name, name_len, &name_esc_len, 0, ENT_QUOTES, NULL TSRMLS_CC);
+ tmp_buf = emalloc(name_esc_len + sizeof(WDDX_VAR_S));
+ snprintf(tmp_buf, name_esc_len + sizeof(WDDX_VAR_S), WDDX_VAR_S, name_esc);
+--
+1.9.2
+
diff --git a/php54.spec b/php54.spec
index e892cc9..6966586 100644
--- a/php54.spec
+++ b/php54.spec
@@ -88,7 +88,7 @@ Version: 5.4.32
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.2.%{?snapdate}%{?rcver}%{?dist}
%else
-Release: 1%{?dist}
+Release: 2%{?dist}
%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -139,6 +139,7 @@ Patch46: php-5.4.9-fixheader.patch
Patch47: php-5.4.9-phpinfo.patch
# Upstream fixes
+Patch100: php-wddx.patch
# Security fixes
@@ -830,6 +831,8 @@ rm -f ext/json/utf8_to_utf16.*
%patch46 -p1 -b .fixheader
%patch47 -p1 -b .phpinfo
+%patch100 -p1 -b .wddx
+
%patch91 -p1 -b .remi-oci8
# upstream patches
@@ -1696,6 +1699,9 @@ fi
%changelog
+* Wed Aug 20 2014 Remi Collet <remi@fedoraproject.org> 5.4.32-2
+- test build for php bug #67873
+
* Wed Aug 20 2014 Remi Collet <remi@fedoraproject.org> 5.4.32-1
- Update to 5.4.32
http://www.php.net/releases/5_4_32.php