summaryrefslogtreecommitdiffstats
path: root/php54.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-24 09:06:34 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-24 09:06:34 +0200
commit8af03511f72ded5501bef7511b5d364ae8ba72a7 (patch)
tree5b73f298ec4e9f4457786c340ef34cf5b4bef369 /php54.spec
parent161da49509c69b3b0ab82f37d903b8a951a9487e (diff)
php54: add php-litespeed subpackage
Diffstat (limited to 'php54.spec')
-rw-r--r--php54.spec28
1 files changed, 28 insertions, 0 deletions
diff --git a/php54.spec b/php54.spec
index b33b93f..00edbcb 100644
--- a/php54.spec
+++ b/php54.spec
@@ -20,6 +20,9 @@
%global oraclever 12.1
%endif
+# Build for LiteSpeed Web Server (LSAPI)
+%global with_lsws 1
+
# Regression tests take a long time, you can skip 'em with this
%{!?runselftest: %{expand: %%global runselftest 1}}
@@ -253,6 +256,18 @@ implementation with some additional features useful for sites of
any size, especially busier sites.
%endif
+%if %{with_lsws}
+%package litespeed
+Summary: LiteSpeed Web Server PHP support
+Group: Development/Languages
+Requires: php-common%{?_isa} = %{version}-%{release}
+Obsoletes: php53-litespeed, php53u-litespeed, php54-litespeed, php54w-litespeed
+
+%description litespeed
+The php-litespeed package provides the %{_bindir}/lsphp command
+used by the LiteSpeed Web Server (LSAPI enabled PHP).
+%endif
+
%package common
Group: Development/Languages
Summary: Common files for PHP
@@ -1086,6 +1101,9 @@ without_shared="--without-gd \
pushd build-apache
build --with-apxs2=%{_httpd_apxs} \
--libdir=%{_libdir}/php \
+%if %{with_lsws}
+ --with-litespeed \
+%endif
--enable-pdo=shared \
--with-mysql=shared,%{_prefix} \
--with-mysqli=shared,%{mysql_config} \
@@ -1255,6 +1273,10 @@ mv $RPM_BUILD_ROOT%{_bindir}/php-config $RPM_BUILD_ROOT%{_bindir}/zts-php-config
make -C build-embedded install-sapi install-headers \
INSTALL_ROOT=$RPM_BUILD_ROOT
+%if %{with_lsws}
+install -m 755 build-apache/sapi/litespeed/php $RPM_BUILD_ROOT%{_bindir}/lsphp
+%endif
+
%if %{with_fpm}
# Install the php-fpm binary
make -C build-fpm install-fpm \
@@ -1597,6 +1619,12 @@ fi
%{_datadir}/fpm/status.html
%endif
+%if %{with_lsws}
+%files litespeed
+%defattr(-,root,root)
+%{_bindir}/lsphp
+%endif
+
%files devel
%defattr(-,root,root)
%{_bindir}/php-config