summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-14 08:01:07 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-14 08:01:07 +0100
commit96edf63418181aad311faf197a56dc042d285945 (patch)
tree2e0c77ef7f50d953d599286ac704c504b2278f34
parentdf605a8131721b080784ab6b2b97da94fc33b1c8 (diff)
php 5.4: improves php.conf, improves filter, apply ldap_r patch on fedora >= 18 only
-rw-r--r--php.conf11
-rw-r--r--php54.spec14
2 files changed, 16 insertions, 9 deletions
diff --git a/php.conf b/php.conf
index 82b206b..075ccaa 100644
--- a/php.conf
+++ b/php.conf
@@ -1,8 +1,9 @@
#
# Cause the PHP interpreter to handle files with a .php extension.
#
-AddHandler php5-script .php
-AddType text/html .php
+<FilesMatch \.php$>
+ SetHandler application/x-httpd-php
+</FilesMatch>
#
# Add index.php to the list of files that will be served as directory
@@ -11,10 +12,12 @@ AddType text/html .php
DirectoryIndex index.php
#
-# Uncomment the following line to allow PHP to pretty-print .phps
+# Uncomment the following lines to allow PHP to pretty-print .phps
# files as PHP source code:
#
-#AddType application/x-httpd-php-source .phps
+#<FilesMatch \.phps$>
+# SetHandler application/x-httpd-php-source
+#</FilesMatch>
#
# Apache specific PHP configuration options
diff --git a/php54.spec b/php54.spec
index d3ec4f0..8d1aa08 100644
--- a/php54.spec
+++ b/php54.spec
@@ -66,7 +66,7 @@ Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.4.9
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.2.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.3.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 5%{?dist}
%endif
@@ -165,13 +165,10 @@ Requires(pre): httpd
# Don't provides extensions, which are not shared library, as .so
-# RPM 4.8
%{?filter_provides_in: %filter_provides_in %{_libdir}/php/modules/.*\.so$}
%{?filter_provides_in: %filter_provides_in %{_libdir}/php-zts/modules/.*\.so$}
+%{?filter_provides_in: %filter_provides_in %{_libdir}/httpd/modules/.*\.so$}
%{?filter_setup}
-# RPM 4.9
-%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/php/modules/.*\\.so$
-%global __provides_exclude_from %{__provides_exclude_from}|%{_libdir}/php-zts/modules/.*\\.so$
%description
@@ -777,7 +774,9 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%if %{with_libzip}
%patch44 -p1 -b .systzip
%endif
+%if 0%{?fedora} >= 18
%patch45 -p1 -b .ldap_r
+%endif
%patch91 -p1 -b .remi-oci8
@@ -1613,6 +1612,11 @@ fi
%changelog
+* Wed Nov 14 2012 Remi Collet <remi@fedoraproject.org> 5.4.9-0.3.RC1
+- improves php.conf (use FilesMatch + SetHandler)
+- improves filter (httpd module)
+- apply ldap_r patch on fedora >= 18 only
+
* Fri Nov 9 2012 Remi Collet <remi@fedoraproject.org> 5.4.9-0.2.RC1
- sync with rawhide