summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-07-03 18:14:35 +0200
committerRemi Collet <fedora@famillecollet.com>2013-07-03 18:14:35 +0200
commit884aec8fccf460e29849958e44b34c71ba405608 (patch)
tree78b2d36734b010eab10bbb802b658449dc019c8f
parent51c8e70016761a46c2fe8ba214a2c425224f6d68 (diff)
PHP 5.4.17
-rw-r--r--php-5.4.16-fpm.patch31
-rw-r--r--php-5.4.16-gc.patch83
-rw-r--r--php-5.4.16-pdopgsql.patch33
-rw-r--r--php-5.4.16-pdotests.patch34
-rw-r--r--php-5.4.17-man.patch (renamed from php-5.4.16-man.patch)0
-rw-r--r--php54.spec23
6 files changed, 7 insertions, 197 deletions
diff --git a/php-5.4.16-fpm.patch b/php-5.4.16-fpm.patch
deleted file mode 100644
index 4a32fcf..0000000
--- a/php-5.4.16-fpm.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 9f6ca9bc6400fc9c8eaebf963f6eb048dde4b34f Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Fri, 24 May 2013 12:09:05 +0200
-Subject: [PATCH] Fixed Bug #64915 (error_log ignored when daemonize=0)
-
-Use configured error_log file when stderr is not a tty.
-So only use tty during interactive debug run.
----
- NEWS | 3 +++
- sapi/fpm/fpm/fpm_stdio.c | 4 ++++
- 2 files changed, 7 insertions(+)
-
-diff --git a/sapi/fpm/fpm/fpm_stdio.c b/sapi/fpm/fpm/fpm_stdio.c
-index 10b867d..d81e101 100644
---- a/sapi/fpm/fpm/fpm_stdio.c
-+++ b/sapi/fpm/fpm/fpm_stdio.c
-@@ -291,7 +291,11 @@ int fpm_stdio_open_error_log(int reopen) /* {{{ */
- fd = fpm_globals.error_log_fd; /* for FD_CLOSEXEC to work */
- } else {
- fpm_globals.error_log_fd = fd;
-+#if HAVE_UNISTD_H
-+ if (fpm_global_config.daemonize || !isatty(STDERR_FILENO)) {
-+#else
- if (fpm_global_config.daemonize) {
-+#endif
- zlog_set_fd(fpm_globals.error_log_fd);
- }
- }
---
-1.7.11.5
-
diff --git a/php-5.4.16-gc.patch b/php-5.4.16-gc.patch
deleted file mode 100644
index a1f4323..0000000
--- a/php-5.4.16-gc.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From 3c87945c95c9c31986e690bb046c70e58c8d8896 Mon Sep 17 00:00:00 2001
-From: Xinchen Hui <laruence@php.net>
-Date: Wed, 5 Jun 2013 17:25:00 +0800
-Subject: [PATCH] Fixed bug #64960 (Segfault in gc_zval_possible_root)
-
----
- NEWS | 2 ++
- Zend/tests/bug64960.phpt | 40 ++++++++++++++++++++++++++++++++++++++++
- Zend/zend_execute_API.c | 6 ++----
- 3 files changed, 44 insertions(+), 4 deletions(-)
- create mode 100644 Zend/tests/bug64960.phpt
-
-diff --git a/Zend/tests/bug64960.phpt b/Zend/tests/bug64960.phpt
-new file mode 100644
-index 0000000..b31cca3
---- /dev/null
-+++ b/Zend/tests/bug64960.phpt
-@@ -0,0 +1,40 @@
-+--TEST--
-+Bug #64960 (Segfault in gc_zval_possible_root)
-+--FILE--
-+<?php
-+// this makes ob_end_clean raise an error
-+ob_end_flush();
-+
-+class ExceptionHandler {
-+ public function __invoke (Exception $e)
-+ {
-+ // this triggers the custom error handler
-+ ob_end_clean();
-+ }
-+}
-+
-+// this must be a class, closure does not trigger segfault
-+set_exception_handler(new ExceptionHandler());
-+
-+// exception must be throwed from error handler.
-+set_error_handler(function()
-+{
-+ $e = new Exception;
-+ $e->_trace = debug_backtrace();
-+
-+ throw $e;
-+});
-+
-+// trigger error handler
-+$a['waa'];
-+?>
-+--EXPECTF--
-+Notice: ob_end_flush(): failed to delete and flush buffer. No buffer to delete or flush in %sbug64960.php on line 3
-+
-+Fatal error: Uncaught exception 'Exception' in %sbug64960.php:19
-+Stack trace:
-+#0 [internal function]: {closure}(8, 'ob_end_clean():...', '%s', 9, Array)
-+#1 %sbug64960.php(9): ob_end_clean()
-+#2 [internal function]: ExceptionHandler->__invoke(Object(Exception))
-+#3 {main}
-+ thrown in %sbug64960.php on line 19
-diff --git a/Zend/zend_execute_API.c b/Zend/zend_execute_API.c
-index 9781889..687520d 100644
---- a/Zend/zend_execute_API.c
-+++ b/Zend/zend_execute_API.c
-@@ -263,15 +263,13 @@ void shutdown_executor(TSRMLS_D) /* {{{ */
- if (EG(user_error_handler)) {
- zeh = EG(user_error_handler);
- EG(user_error_handler) = NULL;
-- zval_dtor(zeh);
-- FREE_ZVAL(zeh);
-+ zval_ptr_dtor(&zeh);
- }
-
- if (EG(user_exception_handler)) {
- zeh = EG(user_exception_handler);
- EG(user_exception_handler) = NULL;
-- zval_dtor(zeh);
-- FREE_ZVAL(zeh);
-+ zval_ptr_dtor(&zeh);
- }
-
- zend_stack_destroy(&EG(user_error_handlers_error_reporting));
---
-1.7.11.5
-
diff --git a/php-5.4.16-pdopgsql.patch b/php-5.4.16-pdopgsql.patch
deleted file mode 100644
index eff1edb..0000000
--- a/php-5.4.16-pdopgsql.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 1c623e3b07128e78362911ff5754e7eee57fa8bb Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Fri, 31 May 2013 08:39:32 +0200
-Subject: [PATCH] Fixed Bug #64949 (Buffer overflow in _pdo_pgsql_error)
-
-There is a lot of call such as:
- pdo_pgsql_error(dbh, PGRES_FATAL_ERROR, "Copy command failed");
-Where the 3rd paramater is a error message string where a sqlstate (5 chars)
-is expected. This cause a segfault in copy_from.phpt and copy_to.phpt.
-
-This is only a sanity check to avoid buffer overflow, but obviously this
-calls need to be fixed (using NULL or a correct sqlstate).
----
- NEWS | 3 +++
- ext/pdo_pgsql/pgsql_driver.c | 2 +-
- 2 files changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/ext/pdo_pgsql/pgsql_driver.c b/ext/pdo_pgsql/pgsql_driver.c
-index 645fd36..55f4418 100644
---- a/ext/pdo_pgsql/pgsql_driver.c
-+++ b/ext/pdo_pgsql/pgsql_driver.c
-@@ -76,7 +76,7 @@ int _pdo_pgsql_error(pdo_dbh_t *dbh, pdo_stmt_t *stmt, int errcode, const char *
- einfo->errmsg = NULL;
- }
-
-- if (sqlstate == NULL) {
-+ if (sqlstate == NULL || strlen(sqlstate) >= sizeof(pdo_error_type)) {
- strcpy(*pdo_err, "HY000");
- }
- else {
---
-1.7.11.5
-
diff --git a/php-5.4.16-pdotests.patch b/php-5.4.16-pdotests.patch
deleted file mode 100644
index 7371798..0000000
--- a/php-5.4.16-pdotests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From c08e1d2be948d63f7a9309344a0ed4092ac8dace Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikic@php.net>
-Date: Sun, 24 Mar 2013 17:52:16 +0100
-Subject: [PATCH] Fix PDO::inTransaction() test for pgsql
-
-inTransaction() nowadays casts the in_transaction result to boolean.
-I'm not sure whether the INERROR state should result in true or false.
-For now I went with the result that we actually get.
----
- ext/pdo_pgsql/tests/is_in_transaction.phpt | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/ext/pdo_pgsql/tests/is_in_transaction.phpt b/ext/pdo_pgsql/tests/is_in_transaction.phpt
-index 99ff561..72da4f4 100644
---- a/ext/pdo_pgsql/tests/is_in_transaction.phpt
-+++ b/ext/pdo_pgsql/tests/is_in_transaction.phpt
-@@ -57,10 +57,10 @@ var_dump($db->inTransaction());
- ?>
- --EXPECT--
- Test PDO::PGSQL_TRANSACTION_INTRANS
--int(2)
-+bool(true)
- Test PDO::PGSQL_TRANSACTION_IDLE
--int(0)
-+bool(false)
- Test PDO::PGSQL_TRANSACTION_INERROR
--int(3)
-+bool(true)
- Test PDO::PGSQL_TRANSACTION_IDLE
--int(0)
-+bool(false)
---
-1.7.11.5
-
diff --git a/php-5.4.16-man.patch b/php-5.4.17-man.patch
index d0c034a..d0c034a 100644
--- a/php-5.4.16-man.patch
+++ b/php-5.4.17-man.patch
diff --git a/php54.spec b/php54.spec
index 99e58ac..b32d82f 100644
--- a/php54.spec
+++ b/php54.spec
@@ -75,11 +75,11 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.4.16
+Version: 5.4.17
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.5.%{?snapdate}%{?rcver}%{?dist}
%else
-Release: 2%{?dist}
+Release: 1%{?dist}
%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -113,15 +113,9 @@ Patch8: php-5.4.7-libdb.patch
# Fixes for extension modules
# https://bugs.php.net/63171 no odbc call during timeout
Patch21: php-5.4.7-odbctimer.patch
-# Fixed Bug #64949 (Buffer overflow in _pdo_pgsql_error)
-Patch22: php-5.4.16-pdopgsql.patch
-# Fixed bug #64960 (Segfault in gc_zval_possible_root)
-Patch23: php-5.4.16-gc.patch
-# Fixed Bug #64915 (error_log ignored when daemonize=0)
-Patch24: php-5.4.16-fpm.patch
# https://bugs.php.net/65143 php-cgi man page
# https://bugs.php.net/65142 phar man page
-Patch25: php-5.4.16-man.patch
+Patch22: php-5.4.17-man.patch
# Functional changes
Patch40: php-5.4.0-dlopen.patch
@@ -139,7 +133,6 @@ Patch46: php-5.4.9-fixheader.patch
Patch47: php-5.4.9-phpinfo.patch
# Fixes for tests
-Patch60: php-5.4.16-pdotests.patch
# RC Patch
Patch91: php-5.3.7-oci8conf.patch
@@ -774,10 +767,7 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
rm -f ext/json/utf8_to_utf16.*
%patch21 -p1 -b .odbctimer
-%patch22 -p1 -b .pdopgsql
-%patch23 -p1 -b .gc
-%patch24 -p1 -b .fpm
-%patch25 -p1 -b .manpages
+%patch22 -p1 -b .manpages
%patch40 -p1 -b .dlopen
%patch41 -p1 -b .easter
@@ -794,8 +784,6 @@ rm -f ext/json/utf8_to_utf16.*
%patch46 -p1 -b .fixheader
%patch47 -p1 -b .phpinfo
-%patch60 -p1 -b .pdotests
-
%patch91 -p1 -b .remi-oci8
@@ -1640,6 +1628,9 @@ fi
%changelog
+* Wed Jul 3 2013 Remi Collet <rcollet@redhat.com> 5.4.17-1
+- update to 5.4.17
+
* Tue Jul 2 2013 Remi Collet <rcollet@redhat.com> 5.4.16-2
- add missing man pages (phar, php-cgi)